summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-05-21 11:44:37 +0200
committerJeroen Roovers <jer@gentoo.org>2016-05-21 11:45:33 +0200
commit66ea028746f90e7263c4171e5016234e0e635bd8 (patch)
tree9a148f11ec6295dbba6d7dc9d3cc2b7af8dc57ae /sys-boot/palo/files
parentwww-servers/apache-2.4.20-r0: add alpha keyword (diff)
downloadgentoo-66ea028746f90e7263c4171e5016234e0e635bd8.tar.gz
gentoo-66ea028746f90e7263c4171e5016234e0e635bd8.tar.bz2
gentoo-66ea028746f90e7263c4171e5016234e0e635bd8.zip
sys-boot/palo: Fix miscompilation of iplboot with sys-devel/gcc-4.9 by Werner Meisner (bug #583436).
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'sys-boot/palo/files')
-rw-r--r--sys-boot/palo/files/palo-1.95-iplboot-gcc-4.9.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-boot/palo/files/palo-1.95-iplboot-gcc-4.9.patch b/sys-boot/palo/files/palo-1.95-iplboot-gcc-4.9.patch
new file mode 100644
index 000000000000..bff0f4c65270
--- /dev/null
+++ b/sys-boot/palo/files/palo-1.95-iplboot-gcc-4.9.patch
@@ -0,0 +1,36 @@
+From eb869303b0c140e806f81f022211648e42290d6d Mon Sep 17 00:00:00 2001
+From: Helge Deller <deller@gmx.de>
+Date: Wed, 18 Feb 2015 21:26:43 +0100
+Subject: Add -fno-delete-null-pointer-checks compiler option
+
+Otherwise gcc-4.9 will miscompile the IPL bootloader since it
+will optimize out accesses to PAGE0
+---
+ ipl/Makefile | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/ipl/Makefile b/ipl/Makefile
+index 7695ea5..6b8e105 100644
+--- a/ipl/Makefile
++++ b/ipl/Makefile
+@@ -38,7 +38,7 @@ endif
+ # Source sharing with palo
+ VPATH=../lib:.
+
+-CFLAGS = -DIPL_LOADER -I. -I../lib -I../include -O2 -mdisable-fpregs -Wall
++CFLAGS = -DIPL_LOADER -I. -I../lib -I../include -O2 -mdisable-fpregs -Wall -fno-delete-null-pointer-checks
+ LDFLAGS = -N --section-start .init=0x60000 -e '$$START$$'
+
+ all: iplelf
+@@ -61,8 +61,6 @@ distclean: clean
+ .S.o:
+ $(CC) -D__ASSEMBLY__ $(AFLAGS) -traditional -c -o $*.o $<
+
+-###############}
+-
+ byteio.o \
+ ext2.o \
+ fileio.o \
+--
+cgit v0.12
+