summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Kangie@footclan.ninja>2020-06-01 20:02:38 +1000
committerJoonas Niilola <juippis@gentoo.org>2020-06-06 16:54:52 +0300
commit6ffd1bcd694a38cd023e148436d5b98c3572acee (patch)
tree77d59988375bb3ca6badd84619113b4be180823b /sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.3.ebuild
parentsys-boot/plymouth-openrc-plugin: Become proxied maintainer (diff)
downloadgentoo-6ffd1bcd694a38cd023e148436d5b98c3572acee.tar.gz
gentoo-6ffd1bcd694a38cd023e148436d5b98c3572acee.tar.bz2
gentoo-6ffd1bcd694a38cd023e148436d5b98c3572acee.zip
sys-boot/plymouth-openrc-plugin: version bump
Version 0.1.3 includes exit-at-mount-ro.patch, new upstream. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matt Jolly <Kangie@footclan.ninja> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.3.ebuild')
-rw-r--r--sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.3.ebuild b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.3.ebuild
new file mode 100644
index 000000000000..19a8ac634d18
--- /dev/null
+++ b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Plymouth plugin for OpenRC"
+HOMEPAGE="https://github.com/Kangie/plymouth-openrc-plugin"
+SRC_URI="https://github.com/Kangie/${PN}/archive/v${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/openrc:="
+RDEPEND="${DEPEND}
+ sys-boot/plymouth"
+
+src_install() {
+ insinto /$(get_libdir)/rc/plugins
+ doins plymouth.so
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ ewarn "You need to disable 'rc_interactive' feature in /etc/rc.conf to make"
+ ewarn "Plymouth work properly with OpenRC init system."
+ fi
+
+ if has_version sys-apps/systemd; then
+ eerror "sys-apps/systemd is installed, please uninstall this package if you"
+ eerror "are booting with systemd"
+ fi
+}