summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatija Skala <mskala@gmx.com>2018-11-07 16:20:57 +0100
committerMatthew Thode <prometheanfire@gentoo.org>2018-11-07 09:49:25 -0600
commitd3d7ec1a087bb904251d31e83120636ccc30e2fc (patch)
tree715184a96dde5ecb303a8fe939a45e780b7652fc /sys-boot/plymouth/plymouth-0.9.4-r1.ebuild
parentmedia-gfx/inkscape: Fixed compilation with >=app-text/poppler-0.69.0 (diff)
downloadgentoo-d3d7ec1a087bb904251d31e83120636ccc30e2fc.tar.gz
gentoo-d3d7ec1a087bb904251d31e83120636ccc30e2fc.tar.bz2
gentoo-d3d7ec1a087bb904251d31e83120636ccc30e2fc.zip
sys-boot/plymouth: add support for /usr merge
Signed-off-by: Matija Skala <mskala@gmx.com> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-boot/plymouth/plymouth-0.9.4-r1.ebuild')
-rw-r--r--sys-boot/plymouth/plymouth-0.9.4-r1.ebuild109
1 files changed, 109 insertions, 0 deletions
diff --git a/sys-boot/plymouth/plymouth-0.9.4-r1.ebuild b/sys-boot/plymouth/plymouth-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..cab004479b73
--- /dev/null
+++ b/sys-boot/plymouth/plymouth-0.9.4-r1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+SRC_URI="https://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/gentoo-logo.png"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/plymouth"
+else
+ SRC_URI="${SRC_URI} https://www.freedesktop.org/software/plymouth/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+inherit autotools readme.gentoo-r1 systemd toolchain-funcs
+
+DESCRIPTION="Graphical boot animation (splash) and logger"
+HOMEPAGE="https://cgit.freedesktop.org/plymouth/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug gdm +gtk +libkms +pango +split-usr static-libs"
+
+CDEPEND="
+ >=media-libs/libpng-1.2.16:=
+ gtk? (
+ dev-libs/glib:2
+ >=x11-libs/gtk+-3.14:3
+ x11-libs/cairo
+ )
+ libkms? ( x11-libs/libdrm[libkms] )
+ pango? ( >=x11-libs/pango-1.21 )
+"
+DEPEND="${CDEPEND}
+ elibc_musl? ( sys-libs/rpmatch-standalone )
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+# Block due bug #383067
+RDEPEND="${CDEPEND}
+ virtual/udev
+ !<sys-kernel/dracut-0.37-r3
+"
+
+DOC_CONTENTS="
+ Follow the following instructions to set up Plymouth:\n
+ https://wiki.gentoo.org/wiki/Plymouth#Configuration
+"
+
+PATCHES=(
+ "${FILESDIR}"/0.9.3-glibc-sysmacros.patch
+)
+
+src_prepare() {
+ use elibc_musl && append-ldflags -lrpmatch
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --with-system-root-install=no
+ --localstatedir=/var
+ --without-rhgb-compat-link
+ --enable-documentation
+ --enable-systemd-integration
+ --with-systemdunitdir="$(systemd_get_systemunitdir)"
+ $(use_enable !static-libs shared)
+ $(use_enable static-libs static)
+ $(use_enable debug tracing)
+ $(use_enable gtk gtk)
+ $(use_enable libkms drm)
+ $(use_enable pango)
+ $(use_enable gdm gdm-transition)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/plymouth
+ newins "${DISTDIR}"/gentoo-logo.png bizcom.png
+
+ if use split-usr ; then
+ # Install compatibility symlinks as some rdeps hardcode the paths
+ dosym ../usr/bin/plymouth /bin/plymouth
+ dosym ../usr/sbin/plymouth-set-default-theme /sbin/plymouth-set-default-theme
+ dosym ../usr/sbin/plymouthd /sbin/plymouthd
+ fi
+
+ readme.gentoo_create_doc
+
+ # looks like make install create /var/run/plymouth
+ # this is not needed for systemd, same should hold for openrc
+ # so remove
+ rm -rf "${D}"/var/run
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ if ! has_version "sys-kernel/dracut" && ! has_version "sys-kernel/genkernel-next[plymouth]"; then
+ ewarn "If you want initramfs builder with plymouth support, please emerge"
+ ewarn "sys-kernel/dracut or sys-kernel/genkernel-next[plymouth]."
+ fi
+}