summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-09 17:20:15 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-09 17:20:32 -0500
commitb1d74d3c7e50c8d93221278532d25060f12b34b4 (patch)
tree5cdc9aacd3772c0e7f2c08b9d0562fefa3eaeab8 /sys-boot/plymouth/plymouth-9999.ebuild
parentsys-boot/plymouth: 0.9.3 bup (diff)
downloadgentoo-b1d74d3c7e50c8d93221278532d25060f12b34b4.tar.gz
gentoo-b1d74d3c7e50c8d93221278532d25060f12b34b4.tar.bz2
gentoo-b1d74d3c7e50c8d93221278532d25060f12b34b4.zip
sys-boot/plymouth: fixing up 9999
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'sys-boot/plymouth/plymouth-9999.ebuild')
-rw-r--r--sys-boot/plymouth/plymouth-9999.ebuild47
1 files changed, 23 insertions, 24 deletions
diff --git a/sys-boot/plymouth/plymouth-9999.ebuild b/sys-boot/plymouth/plymouth-9999.ebuild
index e05e8ca9e1e7..ea9aa1bd7d6b 100644
--- a/sys-boot/plymouth/plymouth-9999.ebuild
+++ b/sys-boot/plymouth/plymouth-9999.ebuild
@@ -1,20 +1,18 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-SRC_URI="
- https://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/gentoo-logo.png"
+SRC_URI="https://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/gentoo-logo.png"
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="git://anongit.freedesktop.org/plymouth"
- AUTOTOOLS_AUTORECONF="1"
inherit git-r3
else
- SRC_URI="${SRC_URI} https://www.freedesktop.org/software/plymouth/releases/${P}.tar.bz2"
+ SRC_URI="${SRC_URI} https://www.freedesktop.org/software/plymouth/releases/${P}.tar.xz"
fi
-inherit autotools-utils readme.gentoo systemd toolchain-funcs
+inherit autotools readme.gentoo-r1 systemd toolchain-funcs
DESCRIPTION="Graphical boot animation (splash) and logger"
HOMEPAGE="https://cgit.freedesktop.org/plymouth/"
@@ -48,28 +46,29 @@ DOC_CONTENTS="
https://wiki.gentoo.org/wiki/Plymouth#Configuration
"
-src_prepare() {
- autotools-utils_src_prepare
-}
+PATCHES=(
+)
src_configure() {
- local myeconfargs=(
- --with-system-root-install=no
- --localstatedir=/var
- --without-rhgb-compat-link
- --enable-systemd-integration
- "$(systemd_with_unitdir)"
- $(use_enable debug tracing)
- $(use_enable gtk gtk)
- $(use_enable libkms drm)
- $(use_enable pango)
- $(use_enable gdm gdm-transition)
- )
- autotools-utils_src_configure
+ local myconf
+ myconf="--with-system-root-install=no
+ --localstatedir=/var
+ --without-rhgb-compat-link
+ --enable-systemd-integration
+ --with-systemdunitdir="$(systemd_get_systemunitdir)"
+ $(use_enable !static-libs shared)
+ $(use_enable static-libs static)
+ $(use_enable debug tracing)
+ $(use_enable gtk gtk)
+ $(use_enable libkms drm)
+ $(use_enable pango)
+ $(use_enable gdm gdm-transition)"
+ eautoreconf
+ econf ${myconf}
}
src_install() {
- autotools-utils_src_install
+ default
insinto /usr/share/plymouth
newins "${DISTDIR}"/gentoo-logo.png bizcom.png