summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2018-09-02 10:44:21 +1000
committerSam Jorna <wraeth@gentoo.org>2018-09-02 10:44:21 +1000
commitb6d2187e9c3ba35adeb83431485df503178244c6 (patch)
tree3ca72a1de5c5b6dbfd0907487e14fcad0df937c4 /sys-boot/refind/refind-0.11.3.ebuild
parentdev-util/vulkan-tools: Move some logic to pkg_setup (diff)
downloadgentoo-b6d2187e9c3ba35adeb83431485df503178244c6.tar.gz
gentoo-b6d2187e9c3ba35adeb83431485df503178244c6.tar.bz2
gentoo-b6d2187e9c3ba35adeb83431485df503178244c6.zip
sys-boot/refind: fix SIMLINK_LIB=no
Bug: https://bugs.gentoo.org/627744 Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'sys-boot/refind/refind-0.11.3.ebuild')
-rw-r--r--sys-boot/refind/refind-0.11.3.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-boot/refind/refind-0.11.3.ebuild b/sys-boot/refind/refind-0.11.3.ebuild
index 511e74dce7aa..61fa68128311 100644
--- a/sys-boot/refind/refind-0.11.3.ebuild
+++ b/sys-boot/refind/refind-0.11.3.ebuild
@@ -101,6 +101,9 @@ src_compile() {
AS="$(tc-getAS)"
LD="$(tc-getLD)"
AR="$(tc-getAR)"
+ GNUEFILIB="/usr/$(get_libdir)"
+ EFILIB="/usr/$(get_libdir)"
+ EFICRT0="/usr/$(get_libdir)"
RANLIB="$(tc-getRANLIB)"
OBJCOPY="$(tc-getOBJCOPY)"
GNUEFI_LDFLAGS="-T \$(GNUEFI_LDSCRIPT) -shared -nostdlib -Bsymbolic \
@@ -177,7 +180,7 @@ pkg_postinst() {
elog ""
if [[ -z "${REPLACING_VERSIONS}" ]]; then
elog "refind-install requires additional packages to be fully functional:"
- elog " app-crypt/sbsigntool for binary signing for use with SecureBoot"
+ elog " app-crypt/sbsigntools for binary signing for use with SecureBoot"
elog " sys-boot/efibootmgr for writing to NVRAM"
elog " sys-block/parted for automatic ESP location and mount"
elog ""