summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-05-30 14:50:50 -0400
committerMike Gilbert <floppym@gentoo.org>2017-05-30 14:51:22 -0400
commite297bb1001aaa9a87abb86f28c4ac786d7c97b45 (patch)
tree3cab01a0a5cf974668d6131138f092d4417db965 /sys-boot/systemd-boot/systemd-boot-233.ebuild
parentsys-apps/openrc: 0.26.3 version bump (diff)
downloadgentoo-e297bb1001aaa9a87abb86f28c4ac786d7c97b45.tar.gz
gentoo-e297bb1001aaa9a87abb86f28c4ac786d7c97b45.tar.bz2
gentoo-e297bb1001aaa9a87abb86f28c4ac786d7c97b45.zip
sys-boot/systemd-boot: bump to 233
Package-Manager: Portage-2.3.6_p1, Repoman-2.3.2_p69
Diffstat (limited to 'sys-boot/systemd-boot/systemd-boot-233.ebuild')
-rw-r--r--sys-boot/systemd-boot/systemd-boot-233.ebuild110
1 files changed, 110 insertions, 0 deletions
diff --git a/sys-boot/systemd-boot/systemd-boot-233.ebuild b/sys-boot/systemd-boot/systemd-boot-233.ebuild
new file mode 100644
index 000000000000..52aa812768a5
--- /dev/null
+++ b/sys-boot/systemd-boot/systemd-boot-233.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="UEFI boot manager from systemd (formerly gummiboot)"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/systemd/systemd-boot/"
+SRC_URI="https://github.com/systemd/systemd/archive/v${PV}.tar.gz -> systemd-${PV}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND="
+ >=sys-apps/util-linux-2.27.1
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt:0
+ >=dev-util/intltool-0.50
+ dev-util/gperf
+ >=sys-boot/gnu-efi-3.0.2
+ sys-libs/libcap
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ !sys-apps/systemd
+"
+
+S="${WORKDIR}/systemd-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/233-Force-libsystemd-shared-to-be-static.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ EFI_CC="$(tc-getPROG "EFI_CC CC" gcc)"
+ cc_cv_CFLAGS__flto=no
+ cc_cv_LDFLAGS__Wl__fuse_ld_gold=no
+ --enable-blkid
+ --enable-efi
+ --enable-gnuefi
+ --disable-acl
+ --disable-apparmor
+ --disable-audit
+ --disable-bzip2
+ --disable-elfutils
+ --disable-gcrypt
+ --disable-gnutls
+ --disable-kmod
+ --disable-libcryptsetup
+ --disable-libcurl
+ --disable-libidn
+ --disable-lz4
+ --disable-microhttpd
+ --disable-myhostname
+ --disable-pam
+ --disable-qrencode
+ --disable-seccomp
+ --disable-selinux
+ --disable-xkbcommon
+ --disable-xz
+ --disable-zlib
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ local targets=(
+ bootctl
+ man/bootctl.1
+ man/kernel-install.8
+ '$(bootlib_DATA)'
+ )
+ emake built-sources
+ echo "gentoo: ${targets[*]}" | emake -f Makefile -f - gentoo
+}
+
+src_install() {
+ local args=(
+ DESTDIR="${D%/}"
+
+ # bootctl
+ bin_PROGRAMS=bootctl
+ install-binPROGRAMS
+
+ # kernel-install
+ install-dist_binSCRIPTS
+ install-dist_kernelinstallSCRIPTS
+
+ man_MANS="man/bootctl.1 man/kernel-install.8"
+ install-man1
+ install-man8
+
+ install-bootlibDATA
+ )
+ emake "${args[@]}"
+ einstalldocs
+}