summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorvitalogy <vitalogy_github@milaw.biz>2015-11-01 20:28:25 +0100
committervitalogy <vitalogy_github@milaw.biz>2015-11-01 20:28:25 +0100
commit1e65133983f404ea64079df0933dd820619a9b44 (patch)
tree7bca20982025fa195c4b0cb13d776ebb6b281f58 /sys-boot/systemrescuecd-x86-grub/systemrescuecd-x86-grub-0.1.ebuild
parentdev-python/elasticsearch-py: follow up edit to doc, man page install (diff)
downloadgentoo-1e65133983f404ea64079df0933dd820619a9b44.tar.gz
gentoo-1e65133983f404ea64079df0933dd820619a9b44.tar.bz2
gentoo-1e65133983f404ea64079df0933dd820619a9b44.zip
sys-boot/systemrescuecd-x86-grub: new ebuild
Diffstat (limited to 'sys-boot/systemrescuecd-x86-grub/systemrescuecd-x86-grub-0.1.ebuild')
-rw-r--r--sys-boot/systemrescuecd-x86-grub/systemrescuecd-x86-grub-0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-boot/systemrescuecd-x86-grub/systemrescuecd-x86-grub-0.1.ebuild b/sys-boot/systemrescuecd-x86-grub/systemrescuecd-x86-grub-0.1.ebuild
new file mode 100644
index 000000000000..32f5706c0b58
--- /dev/null
+++ b/sys-boot/systemrescuecd-x86-grub/systemrescuecd-x86-grub-0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Grub menu entries for the .iso image of systemrescuecd-x86"
+HOMEPAGE="http://www.sysresccd.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT=0
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}
+
+RDEPEND="app-admin/systemrescuecd-x86
+ sys-boot/grub"
+
+src_install() {
+ exeinto /etc/grub.d
+ newexe "${FILESDIR}"/systemrescuecd.grub 39_systemrescuecd
+
+ insinto /etc/default
+ newins "${FILESDIR}"/systemrescuecd.default systemrescuecd
+}
+
+pkg_postinst() {
+ elog "To add the menu entries for systemrescuecd to grub, you should now run"
+ elog " grub-mkconfig -o /boot/grub/grub.cfg"
+ elog "You can set custom bootoptions in /etc/default/systemrescuecd"
+}