summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-08-22 11:34:55 +0800
committerJason Zaman <perfinion@gentoo.org>2016-08-29 09:23:38 +0800
commited8d3fd9362fc893c6fd035f5de32b28af5663e2 (patch)
treecc03f26206171d820f9c08195670b3d0d6b65f29 /sys-boot/tboot/tboot-1.9.4-r1.ebuild
parentdev-ruby/priorityqueue: Add ruby22 (diff)
downloadgentoo-ed8d3fd9362fc893c6fd035f5de32b28af5663e2.tar.gz
gentoo-ed8d3fd9362fc893c6fd035f5de32b28af5663e2.tar.bz2
gentoo-ed8d3fd9362fc893c6fd035f5de32b28af5663e2.zip
sys-boot/tboot: Add openssl[-bindist] dep
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-boot/tboot/tboot-1.9.4-r1.ebuild')
-rw-r--r--sys-boot/tboot/tboot-1.9.4-r1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/sys-boot/tboot/tboot-1.9.4-r1.ebuild b/sys-boot/tboot/tboot-1.9.4-r1.ebuild
new file mode 100644
index 000000000000..0ec16b886a80
--- /dev/null
+++ b/sys-boot/tboot/tboot-1.9.4-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic mount-boot
+
+DESCRIPTION="Performs a measured and verified boot using Intel Trusted Execution Technology"
+HOMEPAGE="https://sourceforge.net/projects/tboot/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 -*"
+IUSE="custom-cflags selinux"
+
+# requires patching the kernel src
+RESTRICT="test"
+
+DEPEND="app-crypt/trousers
+app-crypt/tpm-tools
+dev-libs/openssl:0=[-bindist]"
+
+RDEPEND="${DEPEND}
+sys-boot/grub:2
+selinux? ( sec-policy/selinux-tboot )"
+
+DOCS=(README COPYING CHANGELOG)
+
+src_prepare() {
+ sed -i 's/ -Werror//g' Config.mk || die
+ sed -i 's/^INSTALL_STRIP = -s$//' Config.mk || die # QA Errors
+
+ default
+}
+
+src_compile() {
+ use custom-cflags && export TBOOT_CFLAGS=${CFLAGS} || unset CCASFLAGS CFLAGS CPPFLAGS LDFLAGS
+
+ if use amd64; then
+ MAKEARGS="TARGET_ARCH=x86_64"
+ else
+ MAKEARGS="TARGET_ARCH=i686"
+ fi
+
+ default
+}
+
+src_install() {
+ emake DISTDIR="${D}" install
+
+ dodoc "${DOCS[@]}"
+ dodoc docs/*.txt lcptools/*.{txt,pdf} || die "docs failed"
+
+ cd "${D}"
+ mkdir -p usr/lib/tboot/ || die
+ mv boot usr/lib/tboot/ || die
+}
+
+pkg_postinst() {
+ mount-boot_mount_boot_partition
+
+ cp ${ROOT%/}/usr/lib/tboot/boot/* ${ROOT%/}/boot/
+
+ mount-boot_pkg_postinst
+
+ ewarn "Please remember to download the SINIT AC Module relevant"
+ ewarn "for your platform from:"
+ ewarn "http://software.intel.com/en-us/articles/intel-trusted-execution-technology/"
+}