summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-04-18 22:59:18 +0200
committerPacho Ramos <pacho@gentoo.org>2019-04-18 22:59:18 +0200
commit36e64d196922628ca5187724c2091c7514c67b06 (patch)
treefcc1b746453152c1266a0fa739143613b3819d42 /sys-boot/woeusb/woeusb-3.3.0.ebuild
parentmedia-libs/libaacs: Drop old (diff)
downloadgentoo-36e64d196922628ca5187724c2091c7514c67b06.tar.gz
gentoo-36e64d196922628ca5187724c2091c7514c67b06.tar.bz2
gentoo-36e64d196922628ca5187724c2091c7514c67b06.zip
sys-boot/woeusb: Version bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sys-boot/woeusb/woeusb-3.3.0.ebuild')
-rw-r--r--sys-boot/woeusb/woeusb-3.3.0.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sys-boot/woeusb/woeusb-3.3.0.ebuild b/sys-boot/woeusb/woeusb-3.3.0.ebuild
new file mode 100644
index 000000000000..81c09abcf2ef
--- /dev/null
+++ b/sys-boot/woeusb/woeusb-3.3.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools wxwidgets
+
+DESCRIPTION="Creates windows installer on usb media from an iso image"
+HOMEPAGE="https://github.com/slacka/WoeUSB"
+SRC_URI="https://github.com/slacka/WoeUSB/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+RDEPEND="
+ sys-apps/util-linux
+ sys-block/parted
+ sys-fs/dosfstools
+ sys-fs/ntfs3g
+ sys-boot/grub:2[grub_platforms_pc]
+ !minimal? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/WoeUSB-${PV}"
+
+src_prepare() {
+ default
+ find . -type f -print0 | xargs -0 sed -i "s/@@WOEUSB_VERSION@@/${PV}/" || die
+ if ! use minimal; then
+ setup-wxwidgets
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ ! use minimal && default
+}
+
+src_compile() {
+ ! use minimal && default
+}
+
+src_test() {
+ ! use minimal && default
+}
+
+src_install() {
+ if use minimal; then
+ dosbin src/woeusb
+ einstalldocs
+ else
+ default
+ fi
+}