summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-02-15 09:00:49 +0100
committerJeroen Roovers <jer@gentoo.org>2017-02-15 09:02:38 +0100
commit32ac85adf155318234f9dcd4e250a9e0d7a27d41 (patch)
treeefa299f8b6b5c4aa837b7856766b427df45a80ef /sys-boot
parentdev-libs/Ice: fix installation with USE=ruby, bug 605942, fix building with l... (diff)
downloadgentoo-32ac85adf155318234f9dcd4e250a9e0d7a27d41.tar.gz
gentoo-32ac85adf155318234f9dcd4e250a9e0d7a27d41.tar.bz2
gentoo-32ac85adf155318234f9dcd4e250a9e0d7a27d41.zip
sys-boot/palo: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/palo/Manifest1
-rw-r--r--sys-boot/palo/palo-1.97.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-boot/palo/Manifest b/sys-boot/palo/Manifest
index f88dd22e2a57..8400b29f1d55 100644
--- a/sys-boot/palo/Manifest
+++ b/sys-boot/palo/Manifest
@@ -1,2 +1,3 @@
DIST palo_1.95.tar.xz 102884 SHA256 c168df0255e83f06cf5ae4fd5266f9ee51ba3e9412a9c1bf3131ecff52cec9e8 SHA512 91960a7bbf5a4985809a082d4e75ee25670f6030e701bc106807de4f89c3617e47cf39ef857684b62dcaf906571f6f095b3caa371793754495567f4a14cc8a9d WHIRLPOOL cdf119aa0892fecce4c4dae73053dd9f3c9745a17276012b1d6fb649e3e55eea561dec8f40feb52fb6477f5b289a61844d39c0d8d0ab2ba2a2501c1323b28305
DIST palo_1.96.tar.xz 102480 SHA256 c5ea19dc90834266cf6cbd576c007899ef6628b843ab16c57ed98eecb6e72cf8 SHA512 d287cae0995f4c1f519fac5a83a5f71645b1382c6fbf5117ab416240adda5227bb58eb33ad384b84dfb2622af76948b48f1ccf83fa408e9d2d1c4fe7fbed299f WHIRLPOOL de57336608c2aa0d9b487e0d6cfac05ba608a6c24ed4c0acf59d7027b667cc161616ac3520afc974fa2c8496d93d2025e2dfa353118a941a356cde5a28bb62bc
+DIST palo_1.97.tar.xz 82780 SHA256 cafa629d7a5df124108f4500354d9c84e29565fe6c0ac33162906a30deec6355 SHA512 5e87858a3c91f32174c4debd2aee2ea8185d18fb1d20e6288b1d78b45b0f033fce4c0dadec249fc4e4189e9b7a3a8823e97742e822cfe1512c5edbc9a3d33545 WHIRLPOOL b118b63906e851db50182f6ec4d15ce699393a3cbc738442eb9c593f92dc1968b4ff59ca59e4b83273677d9dc49082e891e5df4fcb7f2a2cf5f2c8e2f00c45ad
diff --git a/sys-boot/palo/palo-1.97.ebuild b/sys-boot/palo/palo-1.97.ebuild
new file mode 100644
index 000000000000..d0d7b6f5f950
--- /dev/null
+++ b/sys-boot/palo/palo-1.97.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.96-toolchain.patch
+)
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ doman palo.8
+ dodoc TODO debian/changelog README.html
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc/kernel/postinst.d/
+ insopts -m 0744
+ doins "${FILESDIR}"/99palo
+}