summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-01-15 18:40:45 +0100
committerJeroen Roovers <jer@gentoo.org>2018-01-15 18:41:06 +0100
commit59b8c1b0cb11fd128e18b7d612edee0eda764150 (patch)
treefb5ebd965d1cf84d4ef101fab039c2f67a45c32a /sys-boot
parentnet-analyzer/ostinato: bump and bug #602098 (diff)
downloadgentoo-59b8c1b0cb11fd128e18b7d612edee0eda764150.tar.gz
gentoo-59b8c1b0cb11fd128e18b7d612edee0eda764150.tar.bz2
gentoo-59b8c1b0cb11fd128e18b7d612edee0eda764150.zip
sys-boot/palo: Version 2.00.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/palo/Manifest1
-rw-r--r--sys-boot/palo/files/palo-2.00-toolchain.patch22
-rw-r--r--sys-boot/palo/palo-2.00.ebuild42
3 files changed, 65 insertions, 0 deletions
diff --git a/sys-boot/palo/Manifest b/sys-boot/palo/Manifest
index 245d19d0011d..a17224547eec 100644
--- a/sys-boot/palo/Manifest
+++ b/sys-boot/palo/Manifest
@@ -1 +1,2 @@
DIST palo-1.99.tar.gz 123906 BLAKE2B 0180cc8398622119debbfaab34e7ace32e74fa60f0e8cb1fc5b36ee435f32f86c79f9beffa1e3d21c9fa3422f72cb8868b244e75aff022e9a6b03b16397d068f SHA512 b859144a5b145aa47d44926b69172818f1fdd577958649d72a99be26dd68d4e2f366acfaec406c8d09ac751ffcdd380b70606e4f3f66e42328d387fcd9022b73
+DIST palo-2.00.tar.gz 124484 BLAKE2B b46b616acf51534382f6a775b456cdcbd4771d6bc9d7a8339ad788a5c5a4a333e98a6e4815c40a6750408b1e8168a19800da11ddf7125621f77d478a651d9c75 SHA512 b6dab81e6c2641a64a40561a65b5412ee702136ac79dab94619e0094faf011e158c67e681f45d5aa51423f5f162da7c1fd07b391b58e8a2100e1306eb7148056
diff --git a/sys-boot/palo/files/palo-2.00-toolchain.patch b/sys-boot/palo/files/palo-2.00-toolchain.patch
new file mode 100644
index 000000000000..168031714bc9
--- /dev/null
+++ b/sys-boot/palo/files/palo-2.00-toolchain.patch
@@ -0,0 +1,22 @@
+--- a/palo/Makefile
++++ b/palo/Makefile
+@@ -10,9 +10,9 @@
+ OS := $(shell uname -s)
+ CC?=cc
+ ifeq ($(strip ${OS}),HP-UX)
+-CFLAGS=-g -O -I../include -I../lib -I$(PA)/include
++CFLAGS=-O -I../include -I../lib -I$(PA)/include
+ else
+-CFLAGS=-g -O -I../include -I../lib -D_FILE_OFFSET_BITS=64
++CFLAGS=-O -I../include -I../lib -D_FILE_OFFSET_BITS=64
+ endif
+
+ ifneq ("$(wildcard /etc/debian_version)","")
+@@ -22,7 +22,6 @@
+ endif
+
+ # LDFLAGS=-Wl,-Bstatic
+-LDFLAGS=
+
+ OFILES2=mkbootable.o elf64.o load.o paloio.o elf32.o error.o gzip.o
+
diff --git a/sys-boot/palo/palo-2.00.ebuild b/sys-boot/palo/palo-2.00.ebuild
new file mode 100644
index 000000000000..db1c24ddc6bb
--- /dev/null
+++ b/sys-boot/palo/palo-2.00.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/${PN}.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.00-toolchain.patch
+)
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ doman palo.8
+ dodoc TODO debian/changelog README.html
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc/kernel/postinst.d/
+ insopts -m 0744
+ doins "${FILESDIR}"/99palo
+}