summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-05-20 22:41:19 +0200
committerJeroen Roovers <jer@gentoo.org>2020-05-20 22:44:43 +0200
commit75ede7d0290aa5b218574b354a07520a1aa376cc (patch)
treee3798e9ac318a63d8cd0c78ecf9b58ddc91bf819 /sys-boot
parentmate-extra/caja-extensions: Newer gupnp is also supported by 0.24.x (diff)
downloadgentoo-75ede7d0290aa5b218574b354a07520a1aa376cc.tar.gz
gentoo-75ede7d0290aa5b218574b354a07520a1aa376cc.tar.bz2
gentoo-75ede7d0290aa5b218574b354a07520a1aa376cc.zip
sys-boot/palo: Version 2.13
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/palo/Manifest1
-rw-r--r--sys-boot/palo/palo-2.13.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-boot/palo/Manifest b/sys-boot/palo/Manifest
index 3a5e40c4d032..e6abab36f8cf 100644
--- a/sys-boot/palo/Manifest
+++ b/sys-boot/palo/Manifest
@@ -1 +1,2 @@
DIST palo-2.12.tar.gz 124911 BLAKE2B 79fa572e118e77114dcb3b888abc65163bd56cb44cf69cd25bcaa33a7c6151b8254bf00c459ad17ca1d948f9b440378133f048e2add123a757908c108b802703 SHA512 6ea20490b84bf18a1d1e8037de453f5f480cba8403b267d4d63fceceffb39e18545c6d20c8dd7b07044ff5567eedd2c58b2a626971b53d1d35c5b3a4e8fefbf0
+DIST palo-2.13.tar.gz 125108 BLAKE2B 9c73e66be7950ae6e7fd0a5dcb9cf460dfcb469580a25c121eb7ffc41aaf4a0b67d7f77ddf7a12479718c6ffc64a3a9327ab8c92cc73e79cffad07d61c6fd120 SHA512 6ecde0720fcf672cd7baf71bb04e16f2a1412d958ec35c4e2c9a7a3b372dab1a12ce6e47198ac8500aca750cbbb7190c3476ea626007c3418eb6c23f06011d37
diff --git a/sys-boot/palo/palo-2.13.ebuild b/sys-boot/palo/palo-2.13.ebuild
new file mode 100644
index 000000000000..17741656154b
--- /dev/null
+++ b/sys-boot/palo/palo-2.13.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/${PN}.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.00-toolchain.patch
+)
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /etc/kernel/postinst.d
+ insopts -m 0744
+ doins "${FILESDIR}"/99palo
+
+ doman palo.8
+
+ dodoc TODO debian/changelog README.html
+}