summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-05-20 11:55:43 +0200
committerJeroen Roovers <jer@gentoo.org>2020-05-20 11:56:22 +0200
commitde9ddf0d8414328da4af833bbf46c9810084852f (patch)
tree1703e08ac7d02475ac481961fe4c743e898675cf /sys-boot
parentkde-apps/dolphin: x86 stable wrt bug #719732 (diff)
downloadgentoo-de9ddf0d8414328da4af833bbf46c9810084852f.tar.gz
gentoo-de9ddf0d8414328da4af833bbf46c9810084852f.tar.bz2
gentoo-de9ddf0d8414328da4af833bbf46c9810084852f.zip
sys-boot/palo: Fix compiling ipl with GCC 10
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Bug: https://bugs.gentoo.org/724264 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/palo/files/palo-2.12-gcc10.patch11
-rw-r--r--sys-boot/palo/palo-2.12-r1.ebuild44
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-boot/palo/files/palo-2.12-gcc10.patch b/sys-boot/palo/files/palo-2.12-gcc10.patch
new file mode 100644
index 000000000000..7832fbeac942
--- /dev/null
+++ b/sys-boot/palo/files/palo-2.12-gcc10.patch
@@ -0,0 +1,11 @@
+--- a/ipl/Makefile
++++ b/ipl/Makefile
+@@ -39,7 +39,7 @@ endif
+ VPATH=../lib:.
+
+ AFLAGS = -I../lib
+-CFLAGS = -DIPL_LOADER -I. -I../lib -I../include -O2 -mdisable-fpregs -Wall -fno-delete-null-pointer-checks
++CFLAGS = -DIPL_LOADER -I. -I../lib -I../include -O2 -mdisable-fpregs -Wall -fno-delete-null-pointer-checks -fno-builtin
+ LDFLAGS = -N --section-start .init=0x60000 -e '$$START$$'
+
+ all: iplelf
diff --git a/sys-boot/palo/palo-2.12-r1.ebuild b/sys-boot/palo/palo-2.12-r1.ebuild
new file mode 100644
index 000000000000..f2982bfb4520
--- /dev/null
+++ b/sys-boot/palo/palo-2.12-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/${PN}.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.00-toolchain.patch
+ "${FILESDIR}"/${PN}-2.12-gcc10.patch
+)
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /etc/kernel/postinst.d
+ insopts -m 0744
+ doins "${FILESDIR}"/99palo
+
+ doman palo.8
+
+ dodoc TODO debian/changelog README.html
+}