summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Misbakh-Soloviov <mva@gentoo.org>2020-10-02 18:37:33 +0700
committerVadim Misbakh-Soloviov <mva@gentoo.org>2020-10-02 18:37:33 +0700
commit8430cafd2d19ed29b89829b7d61a033dbf55005b (patch)
tree01e7fb89edd2ad3ce3556e285a71ab63cd819d29 /sys-cluster/ceph
parentnet-analyzer/wireshark: Fix EGIT_REPO_URI (diff)
downloadgentoo-8430cafd2d19ed29b89829b7d61a033dbf55005b.tar.gz
gentoo-8430cafd2d19ed29b89829b7d61a033dbf55005b.tar.bz2
gentoo-8430cafd2d19ed29b89829b7d61a033dbf55005b.zip
sys-cluster/ceph: fix building with glibc-2.32
Bug: https://bugs.gentoo.org/739042 Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Vadim Misbakh-Soloviov <mva@gentoo.org>
Diffstat (limited to 'sys-cluster/ceph')
-rw-r--r--sys-cluster/ceph/ceph-15.2.4-r3.ebuild1
-rw-r--r--sys-cluster/ceph/ceph-15.2.5-r1.ebuild1
-rw-r--r--sys-cluster/ceph/files/ceph-15.2.5-glibc-2.32.patch15
3 files changed, 17 insertions, 0 deletions
diff --git a/sys-cluster/ceph/ceph-15.2.4-r3.ebuild b/sys-cluster/ceph/ceph-15.2.4-r3.ebuild
index d3903349156e..5a32d2f37876 100644
--- a/sys-cluster/ceph/ceph-15.2.4-r3.ebuild
+++ b/sys-cluster/ceph/ceph-15.2.4-r3.ebuild
@@ -199,6 +199,7 @@ PATCHES=(
"${FILESDIR}/ceph-15.2.3-spdk-compile.patch"
"${FILESDIR}/ceph-14.2.10-python-warnings.patch"
"${FILESDIR}/ceph-15.2.4-system-uring.patch"
+ "${FILESDIR}/ceph-15.2.5-glibc-2.32.patch"
)
check-reqs_export_vars() {
diff --git a/sys-cluster/ceph/ceph-15.2.5-r1.ebuild b/sys-cluster/ceph/ceph-15.2.5-r1.ebuild
index e86923bb2522..ace42c44650b 100644
--- a/sys-cluster/ceph/ceph-15.2.5-r1.ebuild
+++ b/sys-cluster/ceph/ceph-15.2.5-r1.ebuild
@@ -201,6 +201,7 @@ PATCHES=(
"${FILESDIR}/ceph-15.2.4-system-uring.patch"
"${FILESDIR}/ceph-15.2.5-missing-includes.patch"
"${FILESDIR}/ceph-15.2.5-systemd-unit-fix.patch"
+ "${FILESDIR}/ceph-15.2.5-glibc-2.32.patch"
)
check-reqs_export_vars() {
diff --git a/sys-cluster/ceph/files/ceph-15.2.5-glibc-2.32.patch b/sys-cluster/ceph/files/ceph-15.2.5-glibc-2.32.patch
new file mode 100644
index 000000000000..f8f7fad8b658
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-15.2.5-glibc-2.32.patch
@@ -0,0 +1,15 @@
+diff -NaurBwdp a/src/global/signal_handler.h src/global/b/signal_handler.h
+--- a/src/global/signal_handler.h 2020-10-01 03:15:48.208164979 +0700
++++ b/src/global/signal_handler.h 2020-10-01 03:15:40.655244081 +0700
+@@ -20,11 +20,7 @@
+
+ typedef void (*signal_handler_t)(int);
+
+-#ifndef HAVE_REENTRANT_STRSIGNAL
+-# define sig_str(signum) sys_siglist[signum]
+-#else
+ # define sig_str(signum) strsignal(signum)
+-#endif
+
+ void install_sighandler(int signum, signal_handler_t handler, int flags);
+