summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2022-03-31 19:02:53 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-04-08 15:16:54 +0300
commit394880913159d5b15b40f38264f967fad6379962 (patch)
tree65a3fcab112253d4b16fdb6fb86fda92f01b7348 /sys-cluster/charliecloud
parentnet-vpn/protonvpn-cli: allow python 3.10 (diff)
downloadgentoo-394880913159d5b15b40f38264f967fad6379962.tar.gz
gentoo-394880913159d5b15b40f38264f967fad6379962.tar.bz2
gentoo-394880913159d5b15b40f38264f967fad6379962.zip
sys-cluster/charliecloud: Bump to version 0.27.
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster/charliecloud')
-rw-r--r--sys-cluster/charliecloud/Manifest1
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.27.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/sys-cluster/charliecloud/Manifest b/sys-cluster/charliecloud/Manifest
index d22d9a85ba13..7cd7af9f381b 100644
--- a/sys-cluster/charliecloud/Manifest
+++ b/sys-cluster/charliecloud/Manifest
@@ -1,2 +1,3 @@
DIST charliecloud-0.25.tar.gz 454041 BLAKE2B 3a071f3b9fb06ca1db6d3b85a577943fe76440d395fdf1415d5085110db665fb75ee09dc14768d326e7e280e6c20096479e5f62290f7dee46821c356f5f18535 SHA512 a7a35b584dbdd6c6e27188d3555173c44f90c0e44fa685a15a47f47c94f9d76aa46ab80054a7c53e10a7f56bef87696f1db2a0eb8c49a388dbb0da0fe9112a60
DIST charliecloud-0.26.tar.gz 472324 BLAKE2B 2b4b8f44f05a497e9367e97e49de255170b610880ef5d7909f7837bc54962f2c2de929d8381b99dc3f4b6124583744993b59839f8f1481cdbd5dc32334d3da9f SHA512 a8638db42a5563723b62ba0e9b9861b41e76b9246b94887d57a8d4c421d9dd2e8c0965b62af166e47859b72a50a2e01ec6775ef13f79c52696a6b2fd95134174
+DIST charliecloud-0.27.tar.gz 471754 BLAKE2B b683847a79dd55a4bb79458e94e03988acdff0a1e6a24e7f67d56758bdbc3754cc3609e97bfc778f5cb6ce35d6f4df773235314c2ed642ac796b28b824ecadf6 SHA512 cfa5b1ac923008b9a38fc0228562b31551ea941bf222c9b9e12d8dce4c83ca896893e3509773a5ebc02d6b374d08dc049797226cf1432099aae7174c2bc5ee2b
diff --git a/sys-cluster/charliecloud/charliecloud-0.27.ebuild b/sys-cluster/charliecloud/charliecloud-0.27.ebuild
new file mode 100644
index 000000000000..0a5c5c382b07
--- /dev/null
+++ b/sys-cluster/charliecloud/charliecloud-0.27.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit autotools optfeature python-single-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
+ S="${WORKDIR}/${P}"
+else
+ SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~x86-linux"
+fi
+
+DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
+HOMEPAGE="https://hpc.github.io/charliecloud/"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+IUSE="ch-image doc"
+
+# Extensive test suite exists, but downloads container images
+# directly and via Docker and installs packages inside using apt/yum.
+# Additionally, clashes with portage namespacing and sandbox.
+RESTRICT="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ elibc_musl? ( sys-libs/argp-standalone )
+"
+DEPEND="
+ ch-image? (
+ $(python_gen_cond_dep '
+ dev-python/lark-parser[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ )
+ doc? (
+ $(python_gen_cond_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ ')
+ net-misc/rsync
+ )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local econf_args=()
+ econf_args+=(
+ $(use_enable doc html)
+ $(use_enable ch-image)
+ # Libdir is used as a libexec-style destination.
+ --libdir="${EPREFIX}"/usr/lib
+ # Attempts to call python-exec directly otherwise.
+ --with-sphinx-python=${PYTHON}
+ # This disables -Werror, see also: https://github.com/hpc/charliecloud/pull/808
+ --enable-buggy-build
+ # Do not use bundled version of dev-python/lark-parser.
+ --disable-bundled-lark
+ # Use correct shebang.
+ --with-python=${PYTHON}
+ )
+ econf "${econf_args[@]}"
+}
+
+pkg_postinst() {
+ elog "Various builders are supported, as alternative to the internal ch-image."
+ optfeature "Building with Buildah" app-containers/buildah
+ optfeature "Building with Docker" app-containers/docker
+ optfeature "Progress bars during long operations" sys-apps/pv
+ optfeature "Pack and unpack squashfs images" sys-fs/squashfs-tools
+ optfeature "Mount and umount squashfs images" sys-fs/squashfuse
+}