summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2023-09-13 23:47:16 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-15 07:32:59 +0300
commitdbd28f047d4a4503d58c6daf04085accd52343d9 (patch)
treed753132f3b158a645483963771c8f2632cd87ac0 /sys-cluster/charliecloud
parentdev-python/stripe: Bump to 6.5.0 (diff)
downloadgentoo-dbd28f047d4a4503d58c6daf04085accd52343d9.tar.gz
gentoo-dbd28f047d4a4503d58c6daf04085accd52343d9.tar.bz2
gentoo-dbd28f047d4a4503d58c6daf04085accd52343d9.zip
sys-cluster/charliecloud: add 0.34
Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-cluster/charliecloud')
-rw-r--r--sys-cluster/charliecloud/Manifest1
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.34.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/sys-cluster/charliecloud/Manifest b/sys-cluster/charliecloud/Manifest
index 739845db48d5..b22579fb6b97 100644
--- a/sys-cluster/charliecloud/Manifest
+++ b/sys-cluster/charliecloud/Manifest
@@ -1,2 +1,3 @@
DIST charliecloud-0.32.tar.gz 549184 BLAKE2B 5d574ccf2fb36b0acf4f436099ba8344b5d9058d5f79abb8d56082d86b2f9e7207052009b2d49ed50eaede7411796804944fbe11c0d7bcf21f2d62ba01b2c28f SHA512 c32362a219fbe7ec298ac314f58a17e0e6972a3436f66a0243a77c8c05007e6fea3ac8d4ddc15274737eacf3ba32601c0198fc5a39bccb4017d675a149366aee
DIST charliecloud-0.33.tar.gz 559786 BLAKE2B 46e8a488af5a27e6b52ae41118cea663cd6c01f8a24566576dbdc7bac99bd94ac50c0559da07a204c2e68ed46edb8c5a5e0bd26986b5bc960901457af632e134 SHA512 d6854873bdfca5512c54ba28ff70721442241a00cbec6d67c9693e946c6925d030773382c8ba9fc3ebcdfd52da56580e6c4e3ad7080d51d9844ad6f216f15e70
+DIST charliecloud-0.34.tar.gz 565976 BLAKE2B 0c86877bd3f17bf91d287f57b5e0844f7cb1777a499ea2bf67fb2cd5762f453239fe20afa6e4ba71acc98609c718028dd1e813a36aee881aa5c2cae79a65effd SHA512 5ede938a8015391758e0eef0b3661c12025cbac3e5153e2e5219fb4d50f8f78ac12076e4c3b658379a1521825372a0ed792a63210371cdbdad1e6631112e371d
diff --git a/sys-cluster/charliecloud/charliecloud-0.34.ebuild b/sys-cluster/charliecloud/charliecloud-0.34.ebuild
new file mode 100644
index 000000000000..22a7048b73de
--- /dev/null
+++ b/sys-cluster/charliecloud/charliecloud-0.34.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit autotools optfeature python-single-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
+ S="${WORKDIR}/${P}"
+else
+ SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~x86-linux"
+fi
+
+DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
+HOMEPAGE="https://hpc.github.io/charliecloud/"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+IUSE="ch-image doc"
+
+# Extensive test suite exists, but downloads container images
+# directly and via Docker and installs packages inside using apt/yum.
+# Additionally, clashes with portage namespacing and sandbox.
+RESTRICT="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ elibc_musl? ( sys-libs/argp-standalone )
+"
+DEPEND="
+ ch-image? (
+ $(python_gen_cond_dep '
+ dev-python/lark[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ )
+ doc? (
+ $(python_gen_cond_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
+ ')
+ net-misc/rsync
+ )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local econf_args=(
+ $(use_enable doc html)
+ $(use_enable ch-image)
+ # Libdir is used as a libexec-style destination.
+ --libdir="${EPREFIX}"/usr/lib
+ # Attempts to call python-exec directly otherwise.
+ --with-sphinx-python="${EPYTHON}"
+ # This disables -Werror, see also: https://github.com/hpc/charliecloud/pull/808
+ --enable-buggy-build
+ # Do not use bundled version of dev-python/lark.
+ --disable-bundled-lark
+ # Use correct shebang.
+ --with-python="${PYTHON}"
+ )
+ econf "${econf_args[@]}"
+}
+
+src_install() {
+ docompress -x "${EPREFIX}"/usr/share/doc/"${PF}"/examples
+ default
+}
+
+pkg_postinst() {
+ elog "Various builders are supported, as alternative to the internal ch-image."
+ optfeature "Building with Buildah" app-containers/buildah
+ optfeature "Building with Docker" app-containers/docker
+ optfeature "Building with Podman" app-containers/podman
+ optfeature "Progress bars during long operations" sys-apps/pv
+ optfeature "Pack and unpack squashfs images" sys-fs/squashfs-tools
+ optfeature "Mount and umount squashfs images" sys-fs/squashfuse
+ optfeature "Build versioning with ch-image" dev-vcs/git
+}