summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-cluster/ganglia/ganglia-3.7.1-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-cluster/ganglia/ganglia-3.7.1-r1.ebuild')
-rw-r--r--sys-cluster/ganglia/ganglia-3.7.1-r1.ebuild127
1 files changed, 127 insertions, 0 deletions
diff --git a/sys-cluster/ganglia/ganglia-3.7.1-r1.ebuild b/sys-cluster/ganglia/ganglia-3.7.1-r1.ebuild
new file mode 100644
index 000000000000..babd14ca2d62
--- /dev/null
+++ b/sys-cluster/ganglia/ganglia-3.7.1-r1.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
+
+inherit distutils-r1 eutils multilib systemd
+
+DESCRIPTION="A scalable distributed monitoring system for clusters and grids"
+HOMEPAGE="http://ganglia.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ganglia/${P}.tar.gz"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="minimal pcre python examples"
+
+DEPEND="dev-libs/confuse
+ dev-libs/expat
+ >=dev-libs/apr-1.0
+ !dev-db/firebird
+ pcre? ( dev-libs/libpcre )
+ python? ( ${PYTHON_DEPS} )"
+
+RDEPEND="
+ ${DEPEND}
+ !minimal? ( net-analyzer/rrdtool )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+src_prepare() {
+ if use python && ! use minimal; then
+ pushd gmetad-python >/dev/null || die
+ distutils-r1_src_prepare
+ popd >/dev/null || die
+ fi
+}
+
+src_configure() {
+ if use python; then
+ python_setup
+ fi
+
+ econf \
+ --with-systemdsystemunitdir=$(systemd_get_unitdir) \
+ --enable-gexec \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --enable-static=no \
+ $(use_enable python) \
+ $(use_with pcre libpcre) \
+ $(use_with !minimal gmetad)
+}
+
+src_compile() {
+ default_src_compile
+
+ if use python && ! use minimal; then
+ pushd gmetad-python >/dev/null || die
+ distutils-r1_src_compile
+ popd >/dev/null || die
+ fi
+}
+
+src_install() {
+ local exdir=/usr/share/doc/${P}
+
+ emake DESTDIR="${D}" install || die
+
+ newinitd "${FILESDIR}"/gmond.rc-2 gmond
+ doman {mans/*.1,gmond/*.5} || die "Failed to install manpages"
+ dodoc AUTHORS INSTALL NEWS README || die
+
+ dodir /etc/ganglia/conf.d
+ use python && dodir /usr/$(get_libdir)/ganglia/python_modules
+ gmond/gmond -t > "${ED}"/etc/ganglia/gmond.conf
+
+ if use examples; then
+ insinto ${exdir}/cmod-examples
+ doins gmond/modules/example/*.c
+ if use python; then
+ # Installing as an examples per upstream.
+ insinto ${exdir}/pymod-examples
+ doins gmond/python_modules/*/*.py
+ insinto ${exdir}/pymod-examples/conf.d
+ doins gmond/python_modules/conf.d/*.pyconf
+ fi
+ fi
+
+ if ! use minimal; then
+ insinto /etc/ganglia
+ doins gmetad/gmetad.conf
+ doman mans/gmetad.1
+
+ newinitd "${FILESDIR}"/gmetad.rc-2 gmetad
+ keepdir /var/lib/ganglia/rrds
+ fowners nobody:nobody /var/lib/ganglia/rrds
+
+ if use python; then
+ pushd gmetad-python >/dev/null || die
+ distutils-r1_src_install
+ popd >/dev/null || die
+ newinitd "${FILESDIR}"/gmetad-python.rc gmetad-python
+ fi
+ fi
+}
+
+src_test() {
+ default_src_test
+
+ if use python && ! use minimal; then
+ pushd gmetad-python >/dev/null || die
+ distutils-r1_src_test
+ popd >/dev/null || die
+ fi
+}
+
+pkg_postinst() {
+ elog "A default configuration file for gmond has been generated"
+ elog "for you as a template by running:"
+ elog " /usr/sbin/gmond -t > /etc/ganglia/gmond.conf"
+
+ elog "The web frontend for Ganglia has been split off. Emerge"
+ elog "sys-cluster/ganglia-web if you need it."
+}