summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 02:33:43 +0100
committerSam James <sam@gentoo.org>2021-07-31 02:37:11 +0100
commite68166f39e0c03b05b98cafc019b92b3e1a04807 (patch)
treea34125d931eb370b67d1d768d6d5d15241fcc2ea /sys-cluster/glusterfs
parentapp-crypt/nitrocli: Bump version to 0.4.1 (diff)
downloadgentoo-e68166f39e0c03b05b98cafc019b92b3e1a04807.tar.gz
gentoo-e68166f39e0c03b05b98cafc019b92b3e1a04807.tar.bz2
gentoo-e68166f39e0c03b05b98cafc019b92b3e1a04807.zip
sys-cluster/glusterfs: consistently call tmpfiles_process in pkg_postinst
We weren't always calling tmpfiles_process in pkg_postinst, nor we were always using the correct filename. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster/glusterfs')
-rw-r--r--sys-cluster/glusterfs/glusterfs-7.9-r1.ebuild12
-rw-r--r--sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild12
-rw-r--r--sys-cluster/glusterfs/glusterfs-8.4-r1.ebuild12
-rw-r--r--sys-cluster/glusterfs/glusterfs-8.5-r1.ebuild5
-rw-r--r--sys-cluster/glusterfs/glusterfs-9.1-r1.ebuild12
-rw-r--r--sys-cluster/glusterfs/glusterfs-9.2-r1.ebuild4
6 files changed, 33 insertions, 24 deletions
diff --git a/sys-cluster/glusterfs/glusterfs-7.9-r1.ebuild b/sys-cluster/glusterfs/glusterfs-7.9-r1.ebuild
index c06064e3dd84..8fe9cb9d3d7a 100644
--- a/sys-cluster/glusterfs/glusterfs-7.9-r1.ebuild
+++ b/sys-cluster/glusterfs/glusterfs-7.9-r1.ebuild
@@ -104,7 +104,7 @@ src_configure() {
$(use_enable xml xml-output) \
$(use libtirpc || echo --without-libtirpc) \
$(use ipv6 && echo --with-ipv6-default) \
- --with-tmpfilesdir="${EPREFIX}"/etc/tmpfiles.d \
+ --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
--localstatedir="${EPREFIX}"/var
}
@@ -113,6 +113,10 @@ src_compile() {
use emacs && elisp-compile extras/glusterfs-mode.el
}
+src_test() {
+ ./run-tests.sh || die
+}
+
src_install() {
default
@@ -171,11 +175,9 @@ src_install() {
python_optimize "${ED}"
}
-src_test() {
- ./run-tests.sh || die
-}
-
pkg_postinst() {
+ tmpfiles_process gluster.conf
+
elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
elog " /etc/init.d/glusterd start"
diff --git a/sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild b/sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild
index c6fc8ce35bc6..79808b9e3ff6 100644
--- a/sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild
+++ b/sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild
@@ -98,7 +98,7 @@ src_configure() {
$(use_enable xml xml-output) \
$(use libtirpc || echo --without-libtirpc) \
$(use ipv6 && echo --with-ipv6-default) \
- --with-tmpfilesdir="${EPREFIX}"/etc/tmpfiles.d \
+ --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
--localstatedir="${EPREFIX}"/var
}
@@ -107,6 +107,10 @@ src_compile() {
use emacs && elisp-compile extras/glusterfs-mode.el
}
+src_test() {
+ ./run-tests.sh || die
+}
+
src_install() {
default
@@ -158,11 +162,9 @@ src_install() {
python_optimize "${ED}"
}
-src_test() {
- ./run-tests.sh || die
-}
-
pkg_postinst() {
+ tmpfiles_process gluster.conf
+
elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
elog " /etc/init.d/glusterd start"
diff --git a/sys-cluster/glusterfs/glusterfs-8.4-r1.ebuild b/sys-cluster/glusterfs/glusterfs-8.4-r1.ebuild
index c6fc8ce35bc6..79808b9e3ff6 100644
--- a/sys-cluster/glusterfs/glusterfs-8.4-r1.ebuild
+++ b/sys-cluster/glusterfs/glusterfs-8.4-r1.ebuild
@@ -98,7 +98,7 @@ src_configure() {
$(use_enable xml xml-output) \
$(use libtirpc || echo --without-libtirpc) \
$(use ipv6 && echo --with-ipv6-default) \
- --with-tmpfilesdir="${EPREFIX}"/etc/tmpfiles.d \
+ --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
--localstatedir="${EPREFIX}"/var
}
@@ -107,6 +107,10 @@ src_compile() {
use emacs && elisp-compile extras/glusterfs-mode.el
}
+src_test() {
+ ./run-tests.sh || die
+}
+
src_install() {
default
@@ -158,11 +162,9 @@ src_install() {
python_optimize "${ED}"
}
-src_test() {
- ./run-tests.sh || die
-}
-
pkg_postinst() {
+ tmpfiles_process gluster.conf
+
elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
elog " /etc/init.d/glusterd start"
diff --git a/sys-cluster/glusterfs/glusterfs-8.5-r1.ebuild b/sys-cluster/glusterfs/glusterfs-8.5-r1.ebuild
index 147d96407341..18671f3fc19e 100644
--- a/sys-cluster/glusterfs/glusterfs-8.5-r1.ebuild
+++ b/sys-cluster/glusterfs/glusterfs-8.5-r1.ebuild
@@ -163,6 +163,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process gluster.conf
+
elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
elog " /etc/init.d/glusterd start"
@@ -184,9 +186,8 @@ pkg_postinst() {
elog "If you are upgrading from a previous version of ${PN}, please read:"
elog " http://docs.gluster.org/en/latest/Upgrade-Guide/upgrade_to_$(ver_cut '1-2')/"
- tmpfiles_process glusterfs.conf
-
use emacs && elisp-site-regen
+
}
pkg_postrm() {
diff --git a/sys-cluster/glusterfs/glusterfs-9.1-r1.ebuild b/sys-cluster/glusterfs/glusterfs-9.1-r1.ebuild
index 8f52fcdca644..4b3b440fa715 100644
--- a/sys-cluster/glusterfs/glusterfs-9.1-r1.ebuild
+++ b/sys-cluster/glusterfs/glusterfs-9.1-r1.ebuild
@@ -99,7 +99,7 @@ src_configure() {
$(use_enable xml xml-output) \
$(use libtirpc || echo --without-libtirpc) \
$(use ipv6 && echo --with-ipv6-default) \
- --with-tmpfilesdir="${EPREFIX}"/etc/tmpfiles.d \
+ --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
--localstatedir="${EPREFIX}"/var
}
@@ -108,6 +108,10 @@ src_compile() {
use emacs && elisp-compile extras/glusterfs-mode.el
}
+src_test() {
+ ./run-tests.sh || die
+}
+
src_install() {
default
@@ -159,11 +163,9 @@ src_install() {
python_optimize "${ED}"
}
-src_test() {
- ./run-tests.sh || die
-}
-
pkg_postinst() {
+ tmpfiles_process gluster.conf
+
elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
elog " /etc/init.d/glusterd start"
diff --git a/sys-cluster/glusterfs/glusterfs-9.2-r1.ebuild b/sys-cluster/glusterfs/glusterfs-9.2-r1.ebuild
index 0ce6675dcb75..8bc22e9cba26 100644
--- a/sys-cluster/glusterfs/glusterfs-9.2-r1.ebuild
+++ b/sys-cluster/glusterfs/glusterfs-9.2-r1.ebuild
@@ -164,6 +164,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process gluster.conf
+
elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
elog " /etc/init.d/glusterd start"
@@ -185,8 +187,6 @@ pkg_postinst() {
elog "If you are upgrading from a previous version of ${PN}, please read:"
elog " http://docs.gluster.org/en/latest/Upgrade-Guide/upgrade_to_$(ver_cut '1-2')/"
- tmpfiles_process gluster.conf
-
use emacs && elisp-site-regen
}