summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2020-03-26 16:49:36 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-03-28 16:21:17 +0200
commit2ced84299fcd9ddd3e457fce9819ba70e40fbf8b (patch)
tree343c23f6cdbb6f29e9412423dd451b4e6426860d /sys-cluster/hpx
parentsys-cluster/hpx: Add myself as maintainer (diff)
downloadgentoo-2ced84299fcd9ddd3e457fce9819ba70e40fbf8b.tar.gz
gentoo-2ced84299fcd9ddd3e457fce9819ba70e40fbf8b.tar.bz2
gentoo-2ced84299fcd9ddd3e457fce9819ba70e40fbf8b.zip
sys-cluster/hpx: Drop old
The only library using hpx is libgeodecomp and that one should/will work with v1.4. Remove the old version and close bugs along with it. Closes: https://bugs.gentoo.org/679958 Closes: https://bugs.gentoo.org/623434 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster/hpx')
-rw-r--r--sys-cluster/hpx/Manifest1
-rw-r--r--sys-cluster/hpx/hpx-1.2.1.ebuild82
2 files changed, 0 insertions, 83 deletions
diff --git a/sys-cluster/hpx/Manifest b/sys-cluster/hpx/Manifest
index 18b6ea7b1ed9..1fa6355399d8 100644
--- a/sys-cluster/hpx/Manifest
+++ b/sys-cluster/hpx/Manifest
@@ -1,2 +1 @@
-DIST hpx_1.2.1.tar.gz 3919474 BLAKE2B 5f62f97a047c1b931068b671855bc9d7b8ff03d7f26793ee58445fb4c567d68c6c24c87844c7a6463901d784e11afe475120a41038e783a67cc75ede508473c5 SHA512 057724de1ef252e941a776174fa594a855255b5600461725a4da6e9002b1424a1e59be3f8a40673bb3db5a8aabd3c7b38abbb78042490befe247dd73c921b87c
DIST hpx_1.4.1.tar.gz 4213023 BLAKE2B dc8a9cda3061359ea1bb8eba9ccee60dea308f5425cfe0f18d9003032726962d74d417b8748124c8e6a0b207624093ccf625c82e9e1a71fce8dde74d41d987d2 SHA512 f110d5e5c10ec396f6e762568c9ecd5b767cb6efe91168b5caa8fe1e07bb5870cd13b3392fa4e008a2cc0e044b02084a35b0866e943d9b9c7435599c131f1582
diff --git a/sys-cluster/hpx/hpx-1.2.1.ebuild b/sys-cluster/hpx/hpx-1.2.1.ebuild
deleted file mode 100644
index d075974e0bd9..000000000000
--- a/sys-cluster/hpx/hpx-1.2.1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/STEllAR-GROUP/hpx.git"
-else
- SRC_URI="https://stellar.cct.lsu.edu/files/${PN}_${PV}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
- S="${WORKDIR}/${PN}_${PV}"
-fi
-inherit cmake fortran-2 python-any-r1
-
-DESCRIPTION="C++ runtime system for parallel and distributed applications"
-HOMEPAGE="https://stellar.cct.lsu.edu/tag/hpx/"
-
-SLOT="0"
-LICENSE="Boost-1.0"
-IUSE="doc examples jemalloc papi +perftools tbb test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="?? ( jemalloc perftools tbb )"
-
-BDEPEND="
- virtual/pkgconfig
- doc? ( >=dev-libs/boost-1.56.0-r1[tools] )
-"
-RDEPEND="
- >=dev-libs/boost-1.49:=
- >=sys-apps/hwloc-1.8
- >=sys-libs/libunwind-1
- sys-libs/zlib
- papi? ( dev-libs/papi )
- perftools? ( >=dev-util/google-perftools-1.7.1 )
- tbb? ( dev-cpp/tbb )
-"
-DEPEND="${RDEPEND}
- test? ( ${PYTHON_DEPS} )
-"
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DHPX_WITH_EXAMPLES=OFF
- -DHPX_WITH_DOCUMENTATION=$(usex doc)
- -DHPX_WITH_PAPI=$(usex papi)
- -DHPX_WITH_GOOGLE_PERFTOOLS=$(usex perftools)
- -DBUILD_TESTING=$(usex test)
- )
- if use jemalloc; then
- mycmakeargs+=( -DHPX_WITH_MALLOC=jemalloc )
- elif use perftools; then
- mycmakeargs+=( -DHPX_WITH_MALLOC=tcmalloc )
- elif use tbb; then
- mycmakeargs+=( -DHPX_WITH_MALLOC=tbbmalloc )
- else
- mycmakeargs+=( -DHPX_WITH_MALLOC=system )
- fi
-
- cmake_src_configure
-}
-
-src_test() {
- # avoid over-suscribing
- cmake_build -j1 tests
-}
-
-src_install() {
- cmake_src_install
- if use examples; then
- mv "${D}/usr/bin/spin" "${D}/usr/bin/hpx_spin" || die
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}