summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2020-02-25 12:56:51 -0600
committerWilliam Hubbs <williamh@gentoo.org>2020-02-25 12:58:14 -0600
commitbd27b28989a540f9c8c5a94183c1e06699e6f4f9 (patch)
tree7e69019cdd3a0d4bdf76f9661e6089e6fa2b9d5c /sys-cluster/kube-scheduler/kube-scheduler-1.15.10.ebuild
parentsys-cluster/kube-proxy: 1.15.10 bump (diff)
downloadgentoo-bd27b28989a540f9c8c5a94183c1e06699e6f4f9.tar.gz
gentoo-bd27b28989a540f9c8c5a94183c1e06699e6f4f9.tar.bz2
gentoo-bd27b28989a540f9c8c5a94183c1e06699e6f4f9.zip
sys-cluster/kube-scheduler: 1.15.10 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-cluster/kube-scheduler/kube-scheduler-1.15.10.ebuild')
-rw-r--r--sys-cluster/kube-scheduler/kube-scheduler-1.15.10.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-cluster/kube-scheduler/kube-scheduler-1.15.10.ebuild b/sys-cluster/kube-scheduler/kube-scheduler-1.15.10.ebuild
new file mode 100644
index 000000000000..73527681151b
--- /dev/null
+++ b/sys-cluster/kube-scheduler/kube-scheduler-1.15.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="k8s.io/kubernetes"
+ARCHIVE_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Kubernetes Scheduler"
+HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
+SRC_URI="${ARCHIVE_URI}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+COMMON_DEPEND="acct-group/kube-scheduler
+ acct-user/kube-scheduler"
+DEPEND="${COMMON_DEPEND}
+ dev-go/go-bindata
+ =dev-lang/go-1.12"
+ RDEPEND="${COMMON_DEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed -i -e "/vendor\/github.com\/jteeuwen\/go-bindata\/go-bindata/d" -e "s/-s -w/-w/" src/${EGO_PN}/hack/lib/golang.sh || die
+ sed -i -e "/export PATH/d" src/${EGO_PN}/hack/generate-bindata.sh || die
+}
+
+src_compile() {
+ LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -j1 -C src/${EGO_PN} WHAT=cmd/${PN} GOFLAGS=-v
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin _output/bin/${PN}
+ popd || die
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotated ${PN}
+}