summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-03-17 16:30:28 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-03-17 16:51:22 -0500
commite012da18ee7ab5f75feca72a3ad7c4f37c4b64c8 (patch)
treeb4d84543eadde79b7a1bd40b92f0df2e5697662b /sys-cluster/kubeadm/kubeadm-1.15.11.ebuild
parentsys-cluster/kubectl: 1.15.11 bump (diff)
downloadgentoo-e012da18ee7ab5f75feca72a3ad7c4f37c4b64c8.tar.gz
gentoo-e012da18ee7ab5f75feca72a3ad7c4f37c4b64c8.tar.bz2
gentoo-e012da18ee7ab5f75feca72a3ad7c4f37c4b64c8.zip
sys-cluster/kubeadm-1.15.11 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-cluster/kubeadm/kubeadm-1.15.11.ebuild')
-rw-r--r--sys-cluster/kubeadm/kubeadm-1.15.11.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-cluster/kubeadm/kubeadm-1.15.11.ebuild b/sys-cluster/kubeadm/kubeadm-1.15.11.ebuild
new file mode 100644
index 000000000000..6f09247989fc
--- /dev/null
+++ b/sys-cluster/kubeadm/kubeadm-1.15.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit golang-build golang-vcs-snapshot bash-completion-r1
+
+EGO_PN="k8s.io/kubernetes"
+ARCHIVE_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
+
+DESCRIPTION="CLI to Easily bootstrap a secure Kubernetes cluster"
+HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
+SRC_URI="${ARCHIVE_URI}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="=dev-lang/go-1.12*
+ dev-go/go-bindata"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed -i -e "/vendor\/github.com\/jteeuwen\/go-bindata\/go-bindata/d" -e "s/-s -w/-w/" src/${EGO_PN}/hack/lib/golang.sh || die
+ sed -i -e "/export PATH/d" src/${EGO_PN}/hack/generate-bindata.sh || die
+}
+
+src_compile() {
+ LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -j1 -C src/${EGO_PN} WHAT=cmd/${PN} GOFLAGS=-v
+ pushd src/${EGO_PN} || die
+ _output/bin/${PN} completion bash > ${PN}.bash || die
+ _output/bin/${PN} completion zsh > ${PN}.zsh || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin _output/bin/${PN}
+
+ newbashcomp ${PN}.bash ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ popd || die
+}