summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-04-06 14:48:01 -0600
committerChristoph Junghans <junghans@gentoo.org>2017-04-06 14:48:16 -0600
commite60d4da873835abc39f5f8fc78198bf07c1670dd (patch)
tree8d3854a10d5815c91e61b6c413fb01cace632ecf /sys-cluster/legion/legion-17.02.0.ebuild
parentprofiles: Drop mask for removed media-libs/libechonest (diff)
downloadgentoo-e60d4da873835abc39f5f8fc78198bf07c1670dd.tar.gz
gentoo-e60d4da873835abc39f5f8fc78198bf07c1670dd.tar.bz2
gentoo-e60d4da873835abc39f5f8fc78198bf07c1670dd.zip
sys-cluster/legion: version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-cluster/legion/legion-17.02.0.ebuild')
-rw-r--r--sys-cluster/legion/legion-17.02.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-cluster/legion/legion-17.02.0.ebuild b/sys-cluster/legion/legion-17.02.0.ebuild
new file mode 100644
index 000000000000..03e2d594815d
--- /dev/null
+++ b/sys-cluster/legion/legion-17.02.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A data-centric parallel programming system"
+HOMEPAGE="http://legion.stanford.edu/"
+SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gasnet +hwloc"
+
+DEPEND="
+ gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
+ hwloc? ( sys-apps/hwloc )
+ "
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_configure() {
+ mycmakeargs=(
+ -DLegion_USE_HWLOC=$(usex hwloc)
+ -DLegion_USE_GASNet=$(usex gasnet)
+ -DBUILD_SHARED_LIBS=ON
+ -DLegion_BUILD_EXAMPLES=ON
+ -DLegion_BUILD_TESTS=ON
+ -DLegion_BUILD_TUTORIAL=ON
+ )
+ cmake-utils_src_configure
+}