summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-05-26 16:08:51 -0600
committerChristoph Junghans <junghans@gentoo.org>2017-05-26 16:09:25 -0600
commit76f3654bc1746267fa9d9b8a28692beba6792878 (patch)
treeb11d3d4dd8a754ee224ffa9ef19ff3828f473203 /sys-cluster/legion/legion-9999.ebuild
parentnet-libs/webkit-gtk: bump to 2.16.3; includes 3 security bug fixes (diff)
downloadgentoo-76f3654bc1746267fa9d9b8a28692beba6792878.tar.gz
gentoo-76f3654bc1746267fa9d9b8a28692beba6792878.tar.bz2
gentoo-76f3654bc1746267fa9d9b8a28692beba6792878.zip
sys-cluster/legion: version bump
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'sys-cluster/legion/legion-9999.ebuild')
-rw-r--r--sys-cluster/legion/legion-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-cluster/legion/legion-9999.ebuild b/sys-cluster/legion/legion-9999.ebuild
new file mode 100644
index 000000000000..443814e2abdd
--- /dev/null
+++ b/sys-cluster/legion/legion-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A data-centric parallel programming system"
+HOMEPAGE="http://legion.stanford.edu/"
+if [[ $PV = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${P}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="gasnet +hwloc"
+
+DEPEND="
+ gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
+ hwloc? ( sys-apps/hwloc )
+ "
+
+src_configure() {
+ mycmakeargs=(
+ -DLegion_USE_HWLOC=$(usex hwloc)
+ -DLegion_USE_GASNet=$(usex gasnet)
+ -DBUILD_SHARED_LIBS=ON
+ -DLegion_BUILD_EXAMPLES=ON
+ -DLegion_BUILD_TESTS=ON
+ -DLegion_BUILD_TUTORIAL=ON
+ )
+ cmake-utils_src_configure
+}