summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-12 10:14:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-12 10:41:24 +0100
commit638dd49bacabb37e89a0934c53acd6a2b89aa86c (patch)
tree80ba187a62df1015855e1c6c19f7cf40ad197f36 /sys-cluster/mpich
parentapp-shells/fzf: add 0.29.0 (diff)
downloadgentoo-638dd49bacabb37e89a0934c53acd6a2b89aa86c.tar.gz
gentoo-638dd49bacabb37e89a0934c53acd6a2b89aa86c.tar.bz2
gentoo-638dd49bacabb37e89a0934c53acd6a2b89aa86c.zip
sys-cluster/mpich: Drop 3.0.4-r2, EAPI5--
Closes: https://bugs.gentoo.org/828688 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-cluster/mpich')
-rw-r--r--sys-cluster/mpich/Manifest1
-rw-r--r--sys-cluster/mpich/mpich-3.0.4-r2.ebuild122
2 files changed, 0 insertions, 123 deletions
diff --git a/sys-cluster/mpich/Manifest b/sys-cluster/mpich/Manifest
index 9c37079a9388..e87ddd6bff95 100644
--- a/sys-cluster/mpich/Manifest
+++ b/sys-cluster/mpich/Manifest
@@ -1,2 +1 @@
-DIST mpich-3.0.4.tar.gz 10921075 BLAKE2B 341aaac23277aed05a4448ea03d9caf1ee14cfe327a770c95d620fc1ee1ea7bfa6df36860aa44aad162eb6d630d35fdfb30ae9a866d67680ab71c7b4326c109c SHA512 f9d8b2cf561fe5f85c12512ef4dd7b0cf5ec8b53ddb07bfa0d1db2e3c8ae0382c77e0661f46b82ec96b05d18ea2d25328bb84e9528ac06e5925f30ec8ef030d0
DIST mpich-3.4.3.tar.gz 32853411 BLAKE2B 889f8d4077cd9e8a727e46431ad505b2a17d7391dec00910254d8dbdbc992e2df92efd355d290881fb3a73966bf3504b6942003f88041669c16a8aa142c2dab2 SHA512 d8455a3e7150dc720ba8a0660bfbbec364b62729f4a319928bb910644d20ee68d267baf9e9e2c322540a725e41858b416ed5fff001fb1f6aa45d1c08db8dad1a
diff --git a/sys-cluster/mpich/mpich-3.0.4-r2.ebuild b/sys-cluster/mpich/mpich-3.0.4-r2.ebuild
deleted file mode 100644
index 8a215eacfc6b..000000000000
--- a/sys-cluster/mpich/mpich-3.0.4-r2.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-FORTRAN_NEEDED=fortran
-
-inherit fortran-2 flag-o-matic
-
-MY_PV=${PV/_/}
-DESCRIPTION="A high performance and portable MPI implementation"
-HOMEPAGE="http://www.mpich.org/"
-SRC_URI="http://www.mpich.org/static/downloads/${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="mpich2"
-KEYWORDS="amd64 ~hppa ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="+cxx doc fortran mpi-threads romio threads"
-
-COMMON_DEPEND="
- dev-libs/libaio
- <sys-apps/hwloc-2:=
- romio? ( net-fs/nfs-utils )"
-
-DEPEND="${COMMON_DEPEND}
- dev-lang/perl
- sys-devel/libtool"
-
-RDEPEND="${COMMON_DEPEND}
- !sys-cluster/mpich2
- !sys-cluster/openmpi"
-
-S="${WORKDIR}"/${PN}-${MY_PV}
-
-pkg_setup() {
- FORTRAN_STANDARD="77 90"
- fortran-2_pkg_setup
-
- if use mpi-threads && ! use threads; then
- ewarn "mpi-threads requires threads, assuming that's what you want"
- fi
-}
-
-src_prepare() {
- # Using MPICHLIB_LDFLAGS doesn't seem to fully work.
- sed -i 's| *@WRAPPER_LDFLAGS@ *||' \
- src/packaging/pkgconfig/mpich.pc.in \
- src/env/*.in \
- || die
-}
-
-src_configure() {
- local c="--enable-shared"
-
- # The configure statements can be somewhat confusing, as they
- # don't all show up in the top level configure, however, they
- # are picked up in the children directories.
-
- if use mpi-threads; then
- # MPI-THREAD requries threading.
- c="${c} --with-thread-package=pthreads"
- c="${c} --enable-threads=runtime"
- else
- if use threads ; then
- c="${c} --with-thread-package=pthreads"
- else
- c="${c} --with-thread-package=none"
- fi
- c="${c} --enable-threads=single"
- fi
-
- c="${c} --sysconfdir=${EPREFIX}/etc/${PN}"
- c="${c} --docdir=${EPREFIX}/usr/share/doc/${PF}"
-
- # GCC 10 compatibility workaround
- # bug #725842
- append-fflags $(test-flags-FC -fallow-argument-mismatch)
-
- export MPICHLIB_CFLAGS=${CFLAGS}
- export MPICHLIB_CPPFLAGS=${CPPFLAGS}
- export MPICHLIB_CXXFLAGS=${CXXFLAGS}
- export MPICHLIB_FFLAGS=${FFLAGS}
- export MPICHLIB_FCFLAGS=${FCFLAGS}
- export MPICHLIB_LDFLAGS=${LDFLAGS}
- # dropped w/ bug #725842 fix
- #unset CFLAGS CPPFLAGS CXXFLAGS FFLAGS FCFLAGS LDFLAGS
-
- # Possible workaround for bug #818280
- append-flags -fcommon
-
- # Forcing Bash as there's quite a few bashisms in the build system
- CONFIG_SHELL="${BROOT}/bin/bash" econf ${c} \
- --with-pm=hydra \
- --disable-mpe \
- --disable-fast \
- --enable-smpcoll \
- --enable-versioning \
- --with-hwloc-prefix=/usr \
- $(use_enable romio) \
- $(use_enable cxx) \
- $(use_enable fortran f77) \
- $(use_enable fortran fc)
-}
-
-src_test() {
- emake -j1 check
-}
-
-src_install() {
- default
-
- dodir /usr/share/doc/${PF}
- dodoc README{,.envvar} CHANGES RELEASE_NOTES
- newdoc src/pm/hydra/README README.hydra
- if use romio; then
- newdoc src/mpi/romio/README README.romio
- fi
-
- if ! use doc; then
- rm -rf "${D}"usr/share/doc/${PF}/www*
- fi
-}