summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-02-27 13:27:47 -0600
committerWilliam Hubbs <williamh@gentoo.org>2021-02-27 13:31:35 -0600
commit41e5be70e544079f6e9669a55d870444496455ce (patch)
tree37b3fe56733572b01c50abc567e1914ae7e94c2d /sys-cluster/nomad/nomad-1.0.4.ebuild
parentapp-crypt/xca: Bump stable for 733000 (diff)
downloadgentoo-41e5be70e544079f6e9669a55d870444496455ce.tar.gz
gentoo-41e5be70e544079f6e9669a55d870444496455ce.tar.bz2
gentoo-41e5be70e544079f6e9669a55d870444496455ce.zip
sys-cluster/nomad: 1.0.4 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-cluster/nomad/nomad-1.0.4.ebuild')
-rw-r--r--sys-cluster/nomad/nomad-1.0.4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-cluster/nomad/nomad-1.0.4.ebuild b/sys-cluster/nomad/nomad-1.0.4.ebuild
new file mode 100644
index 000000000000..dc33a1137979
--- /dev/null
+++ b/sys-cluster/nomad/nomad-1.0.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module systemd
+GIT_COMMIT=149b150fb2d87766b8462346d68b72831f622047
+
+DESCRIPTION="A simple and flexible workload orchestrator"
+HOMEPAGE="https://nomadproject.io"
+SRC_URI="https://github.com/hashicorp/nomad/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="nvidia"
+
+RESTRICT+=" test"
+
+src_compile() {
+ local go_ldflags go_tags
+ go_ldflags="-X github.com/hashicorp/nomad/version.GitCommit=${GIT_COMMIT}"
+ go_tags="codegen_generated $(usex nvidia '' 'nonvidia')"
+ CGO_ENABLED=1 \
+ go build \
+ -ldflags "${go_ldflags}" \
+ -mod=vendor \
+ -tags "${go_tags}" \
+ -trimpath \
+ -o bin/${PN} || die "compile failed"
+}
+
+src_install() {
+ dobin bin/${PN}
+ systemd_dounit dist/systemd/nomad.service
+ insinto /etc/nomad.d
+ newins dist/client.hcl client.hcl.example
+ newins dist/server.hcl server.hcl.example
+ einstalldocs
+ dodoc CHANGELOG.md
+ keepdir /var/lib/nomad /var/log/nomad
+ newconfd "${FILESDIR}/nomad.confd" nomad
+ newinitd "${FILESDIR}/nomad.initd" nomad
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/nomad.logrotated" nomad
+}