summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-cluster/open-mx/open-mx-1.5.2-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-cluster/open-mx/open-mx-1.5.2-r1.ebuild')
-rw-r--r--sys-cluster/open-mx/open-mx-1.5.2-r1.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/sys-cluster/open-mx/open-mx-1.5.2-r1.ebuild b/sys-cluster/open-mx/open-mx-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..740f7b11aab8
--- /dev/null
+++ b/sys-cluster/open-mx/open-mx-1.5.2-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils linux-mod multilib toolchain-funcs udev
+
+DESCRIPTION="Open-MX - Myrinet Express over Generic Ethernet Hardware"
+HOMEPAGE="http://open-mx.gforge.inria.fr/"
+SRC_URI="http://gforge.inria.fr/frs/download.php/30245/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug modules static-libs"
+
+DEPEND="
+ sys-apps/hwloc
+ virtual/linux-sources
+ virtual/pkgconfig"
+RDEPEND="
+ sys-apps/hwloc
+ virtual/modutils"
+
+MODULE_NAMES="open-mx(misc:${S}/driver/linux)"
+BUILD_TARGETS="all"
+BUILD_PARAMS="KDIR=${KERNEL_DIR}"
+
+pkg_setup() {
+ einfo "You can set desired mtu by setting OPEN_MX_MTU in make.conf"
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ # We still want to configure driver but dont want to build it at all
+ epatch "${FILESDIR}/open-mx-1.4.0-driver.patch"
+ # We dont want tests
+ sed -e 's:tests/mx::g' \
+ -e 's:tests::g' \
+ -i Makefile.am || die "sed failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-mtu=${OPEN_MX_MTU:-9000} \
+ --with-linux="${KERNEL_DIR}" \
+ --with-linux-release=${KV_FULL} \
+ $(use_enable static-libs static) \
+ $(use_enable debug)
+}
+
+src_compile() {
+ default
+ if use modules; then
+ cd "${S}/driver/linux"
+ linux-mod_src_compile || die "failed to build driver"
+ fi
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.*a' -exec rm {} +
+ # Drop init scripts
+ rm -rf "${ED}/usr/sbin" || die
+ rm "${ED}/usr/bin/omx_check"
+ # install udev rules
+ udev_dorules "${ED}/etc/open-mx/10-open-mx.rules"
+ dodoc "${ED}/usr/share/open-mx/FAQ.html"
+ # Drop misc stuff
+ rm "${ED}/etc/open-mx/10-open-mx.rules" || die
+ rm -rf "${ED}/usr/share/open-mx" || die
+ newinitd "${FILESDIR}/omxoed.initd" omxoed
+ if use modules; then
+ cd "${S}/driver/linux"
+ linux-mod_src_install || die "failed to install driver"
+ fi
+}