summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /sys-cluster/openmpi/openmpi-1.4.5.ebuild
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-cluster/openmpi/openmpi-1.4.5.ebuild')
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.5.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-cluster/openmpi/openmpi-1.4.5.ebuild b/sys-cluster/openmpi/openmpi-1.4.5.ebuild
index ad3f8b66f21a..0bbe9b66f66f 100644
--- a/sys-cluster/openmpi/openmpi-1.4.5.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.5.ebuild
@@ -93,11 +93,11 @@ src_configure() {
}
src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc README AUTHORS NEWS VERSION || die
+ emake DESTDIR="${D}" install
+ dodoc README AUTHORS NEWS VERSION
}
src_test() {
# Doesn't work with the default src_test as the dry run (-n) fails.
- emake -j1 check || die "emake check failed"
+ emake -j1 check
}