summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-03-22 17:51:47 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-03-22 17:51:47 +0300
commit2e0bfd2c0215bf0063c7ecf5767273136934af7a (patch)
treef2afe9c86a6d621058fea0fe08be6793d097b250 /sys-cluster/openmpi/openmpi-1.7.5-r1.ebuild
parentsys-cluster/openmpi: migrate 1.6.5 to EAPI=7 (diff)
downloadgentoo-2e0bfd2c0215bf0063c7ecf5767273136934af7a.tar.gz
gentoo-2e0bfd2c0215bf0063c7ecf5767273136934af7a.tar.bz2
gentoo-2e0bfd2c0215bf0063c7ecf5767273136934af7a.zip
sys-cluster/openmpi: migrate 1.7 to EAPI=7
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-cluster/openmpi/openmpi-1.7.5-r1.ebuild')
-rw-r--r--sys-cluster/openmpi/openmpi-1.7.5-r1.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/sys-cluster/openmpi/openmpi-1.7.5-r1.ebuild b/sys-cluster/openmpi/openmpi-1.7.5-r1.ebuild
index dab0046aced8..507c969a7829 100644
--- a/sys-cluster/openmpi/openmpi-1.7.5-r1.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.7.5-r1.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
FORTRAN_NEEDED=fortran
-inherit autotools cuda eutils flag-o-matic fortran-2 multilib toolchain-funcs versionator
+inherit autotools cuda flag-o-matic fortran-2 toolchain-funcs
MY_P=${P/-mpi}
+
S=${WORKDIR}/${MY_P}
IUSE_OPENMPI_FABRICS="
@@ -28,7 +29,7 @@ IUSE_OPENMPI_OFED_FEATURES="
DESCRIPTION="A high-performance message passing library (MPI)"
HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v$(get_version_component_range 1-2)/downloads/${MY_P}.tar.bz2"
+SRC_URI="http://www.open-mpi.org/software/ompi/v$(ver_cut 1-2)/downloads/${MY_P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
@@ -86,6 +87,7 @@ pkg_setup() {
}
src_prepare() {
+ default
# Necessary for scalibility, see
# http://www.open-mpi.org/community/lists/users/2008/09/6514.php
if use threads; then
@@ -94,7 +96,7 @@ src_prepare() {
fi
# https://github.com/open-mpi/ompi/issues/163
- epatch "${FILESDIR}"/openmpi-ltdl.patch
+ eapply "${FILESDIR}"/openmpi-ltdl.patch
AT_M4DIR=config eautoreconf
}
@@ -146,11 +148,11 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install
+ default
# From USE=vt see #359917
- rm "${ED}"/usr/share/libtool &> /dev/null
+ rm "${ED}"/usr/share/libtool || die
# Avoid collisions with libevent
- rm -rf "${ED}"/usr/include/event2 &> /dev/null
+ rm -rf "${ED}"/usr/include/event2 || die
dodoc README AUTHORS NEWS VERSION
}