summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Rothenpieler <btbn@btbn.de>2020-07-24 21:35:49 +0200
committerAlexys Jacob <ultrabug@gentoo.org>2020-10-21 14:58:11 +0200
commit694bc6925f5e973d4eda78d9366013dc5974a487 (patch)
tree60f5ec89ce398c6bbdedc5eed3e0652f66c95084 /sys-cluster/pacemaker
parentsys-cluster/corosync: bump for 3.0.4 (diff)
downloadgentoo-694bc6925f5e973d4eda78d9366013dc5974a487.tar.gz
gentoo-694bc6925f5e973d4eda78d9366013dc5974a487.tar.bz2
gentoo-694bc6925f5e973d4eda78d9366013dc5974a487.zip
sys-cluster/pacemaker: bump for 2.0.4
Bug: https://bugs.gentoo.org/711674 Signed-off-by: Timo Rothenpieler <btbn@btbn.de> Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'sys-cluster/pacemaker')
-rw-r--r--sys-cluster/pacemaker/Manifest1
-rw-r--r--sys-cluster/pacemaker/files/pacemaker-2.0.4-qa-warnings.patch16
-rw-r--r--sys-cluster/pacemaker/pacemaker-2.0.4.ebuild78
3 files changed, 95 insertions, 0 deletions
diff --git a/sys-cluster/pacemaker/Manifest b/sys-cluster/pacemaker/Manifest
index d9410b999b28..7873e347cfde 100644
--- a/sys-cluster/pacemaker/Manifest
+++ b/sys-cluster/pacemaker/Manifest
@@ -1,2 +1,3 @@
DIST Pacemaker-1.1.16.tar.gz 4897772 BLAKE2B a6ea8b3e5f6ef776a67d8895a0361945c5bcd98ecd861c0fd8d8b3c474a6f14c816e1f36da1dccd429ab8d92c53a9dd071796968d5080d6a900518df200fafbd SHA512 967c860fab7b9e73dd8643e6d09083a2a1298a77d71c3b138187803c89153bee7219da13e6b94b20f2881b53ba7fc1c8584a43ff058a265e76708fd5dbccf534
DIST Pacemaker-1.1.19.tar.gz 5369381 BLAKE2B 9134f014b4da61c01bb2533ad33201400335d9e722e064f5e838df851777cfd17115430bd4623b08b97330bfe98340091f06a98c06dd125761053e79f0375dd2 SHA512 c41403441a3ba7a4fb81b6c3e84d7eff5ee951e1040918597ea8462284c83dc6f572607d4903b1238c55757f1eca78132878a172da4e3b5db2dbfe0831c34548
+DIST Pacemaker-2.0.4.tar.gz 5134516 BLAKE2B 8fa9a648d9d3971a579852833cba2bbf2d45d2d02870bf314813389fe6d49bb2109f9436224d8e0abe8449660b319a37ea9aa2b28250f14874608bcba6e4472d SHA512 fbff3b5ab05ad52d469304d5bc7fca518df2f491a1176a24735cd1a9b46f7ff90dc5aeae65e5e29feb86e8a210e69e528261138847d6f8773933fb557e71133d
diff --git a/sys-cluster/pacemaker/files/pacemaker-2.0.4-qa-warnings.patch b/sys-cluster/pacemaker/files/pacemaker-2.0.4-qa-warnings.patch
new file mode 100644
index 000000000000..33cf74d73260
--- /dev/null
+++ b/sys-cluster/pacemaker/files/pacemaker-2.0.4-qa-warnings.patch
@@ -0,0 +1,16 @@
+diff -Naur pacemaker-Pacemaker-2.0.4.orig/extra/resources/pingd pacemaker-Pacemaker-2.0.4/extra/resources/pingd
+--- pacemaker-Pacemaker-2.0.4.orig/extra/resources/pingd 2020-07-13 22:30:01.503255159 +0200
++++ pacemaker-Pacemaker-2.0.4/extra/resources/pingd 2020-07-13 22:33:27.434714056 +0200
+@@ -25,8 +25,10 @@
+ : ${OCF_RESKEY_interval:="1"}
+ : ${OCF_RESKEY_CRM_meta_interval:=0}
+
+-ocf_log err "This agent (ocf:pacemaker:pingd) is deprecated, does not work, and"
+-ocf_log err "will be removed in a future release (use ocf:pacemaker:ping instead)"
++if [ "$__OCF_ACTION" != "meta-data" ]; then
++ ocf_log err "This agent (ocf:pacemaker:pingd) is deprecated, does not work, and"
++ ocf_log err "will be removed in a future release (use ocf:pacemaker:ping instead)"
++fi
+
+ case "$__OCF_ACTION" in
+ start|monitor)
diff --git a/sys-cluster/pacemaker/pacemaker-2.0.4.ebuild b/sys-cluster/pacemaker/pacemaker-2.0.4.ebuild
new file mode 100644
index 000000000000..0d030893990e
--- /dev/null
+++ b/sys-cluster/pacemaker/pacemaker-2.0.4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit autotools python-single-r1
+
+MY_PN="${PN^}"
+MY_P="${MY_PN}-${PV/_/-}"
+
+DESCRIPTION="Pacemaker CRM"
+HOMEPAGE="http://www.linux-ha.org/wiki/Pacemaker"
+SRC_URI="https://github.com/ClusterLabs/${PN}/archive/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="acl smtp snmp"
+
+DEPEND="${PYTHON_DEPS}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ >=sys-cluster/cluster-glue-1.0.12-r1
+ >=sys-cluster/libqb-2.0.0:=
+ sys-cluster/resource-agents
+ sys-cluster/corosync
+ smtp? ( net-libs/libesmtp )
+ snmp? ( net-analyzer/net-snmp )
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.4-qa-warnings.patch
+)
+
+S="${WORKDIR}/${PN}-${MY_P}"
+
+src_prepare() {
+ default
+ sed -i -e "s/ -ggdb//g" configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ # appends lib to localstatedir automatically
+ local myconf=(
+ --with-ocfdir=/usr/$(get_libdir)/ocf
+ --localstatedir=/var
+ --disable-fatal-warnings
+ --disable-static
+ --without-cs-quorum
+ --without-cman
+ --without-heartbeat
+ --with-corosync
+ --with-ais
+ $(use_with acl)
+ $(use_with smtp esmtp)
+ $(use_with snmp)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ python_optimize
+ rm -rf "${D}/var/run" "${D}/etc/init.d"
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+
+ keepdir /var/lib/pacemaker/{blackbox,cib,cores,pengine}
+ keepdir /var/log/pacemaker/bundles
+
+ find "${D}" -name '*.la' -delete || die
+}