summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-05-27 11:41:08 +0100
committerMarek Szuba <marecki@gentoo.org>2021-05-27 11:41:18 +0100
commit0cd4c10d4020370628d2f0938f856a65db8b672e (patch)
treede603b74135415f37f1988e9bd9ba9eb4e93deb7 /sys-cluster/singularity
parentapp-text/coolreader: remove old (diff)
downloadgentoo-0cd4c10d4020370628d2f0938f856a65db8b672e.tar.gz
gentoo-0cd4c10d4020370628d2f0938f856a65db8b672e.tar.bz2
gentoo-0cd4c10d4020370628d2f0938f856a65db8b672e.zip
sys-cluster/singularity: add 3.7.4
Security release addressing CVE-2021-32635. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-cluster/singularity')
-rw-r--r--sys-cluster/singularity/Manifest1
-rw-r--r--sys-cluster/singularity/singularity-3.7.4.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index adefc22ab8ec..15e2478aade7 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1 +1,2 @@
DIST singularity-3.7.3.tar.gz 6444607 BLAKE2B eb37944f443e73ad258ba2b0f5e769c0e531fc9adc29ed1241940739b549b1bb409dfd8aff729229515c993ee2f842eb0ee00f0f52fec4d2e406f719c0f6e03c SHA512 56e797eb29a2fafaf6ccd730fb8cc9e35713020dacb4d19be02a7204272894360b0d254bd8066d9f14181b935f7179effbac2dfa776b2ff3e0e201388c372836
+DIST singularity-3.7.4.tar.gz 6446703 BLAKE2B f9263a18c138cffa116ab06d59533948e48500fad69917598adc36b47fb0b8bf81e868ea924d1cd0e39ca6345a2fdc38a1c9788944729a43c4c8b63bbe82a184 SHA512 a02d8e5c3c229e454c7736173cbe3709ccaafb0ffedcf537501eb091cd3ee54899542e0c6e1221f35dcffbaf48d27be7e91a9bd510bdaacfd8a2285ea41e6f3d
diff --git a/sys-cluster/singularity/singularity-3.7.4.ebuild b/sys-cluster/singularity/singularity-3.7.4.ebuild
new file mode 100644
index 000000000000..50873aff393c
--- /dev/null
+++ b/sys-cluster/singularity/singularity-3.7.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="Application containers for Linux"
+HOMEPAGE="https://sylabs.io"
+SRC_URI="https://github.com/hpcng/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples +network +suid"
+
+# Do not complain about CFLAGS etc. since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+COMMON="sys-libs/libseccomp"
+BDEPEND="virtual/pkgconfig"
+DEPEND="${COMMON}
+ >=dev-lang/go-1.13.0
+ app-crypt/gpgme
+ dev-libs/openssl
+ sys-apps/util-linux
+ sys-fs/cryptsetup"
+RDEPEND="${COMMON}
+ sys-fs/squashfs-tools"
+
+CONFIG_CHECK="~SQUASHFS"
+
+S=${WORKDIR}/${PN}
+
+src_configure() {
+ local myconfargs=(
+ -c "$(tc-getBUILD_CC)" \
+ -x "$(tc-getBUILD_CXX)" \
+ -C "$(tc-getCC)" \
+ -X "$(tc-getCXX)" \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --runstatedir=/run \
+ --localstatedir=/var \
+ $(usex network "" "--without-network") \
+ $(usex suid "" "--without-suid")
+ )
+ ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
+}
+
+src_compile() {
+ emake -C builddir
+}
+
+src_install() {
+ emake DESTDIR="${ED}" -C builddir install
+ keepdir /var/singularity/mnt/session
+
+ # As of version 3.5.3 this seems to be very much broken, affecting
+ # commands which have got nothing to do with singularity (example:
+ # completion on 'udisks mount -b /dev/' rejects all files from that
+ # directory other than 'autofs'). Moreover, this should go into
+ # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
+ # Hopefully temporary, which is why we delete this at install time
+ # instead of patching build scripts not to generate bash-completion
+ # data in the first place.
+ rm -rf "${ED}"/etc/bash_completion.d || die
+
+ dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
+ if use examples; then
+ dodoc -r examples
+ fi
+}