summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-10-05 14:03:43 +0200
committerMarek Szuba <marecki@gentoo.org>2020-10-05 14:03:43 +0200
commit48b50da8ccd7882fffb3a9239b7ac9cab6b6cbdc (patch)
treed2cb10a0e016ef3a68b793f0c94f9cd7f720a49c /sys-cluster/singularity
parentnet-fs/s3fs: Specify slot for dev-fs/fuse in 1.80 (diff)
downloadgentoo-48b50da8ccd7882fffb3a9239b7ac9cab6b6cbdc.tar.gz
gentoo-48b50da8ccd7882fffb3a9239b7ac9cab6b6cbdc.tar.bz2
gentoo-48b50da8ccd7882fffb3a9239b7ac9cab6b6cbdc.zip
sys-cluster/singularity: remove old
Bug: https://bugs.gentoo.org/746431 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-cluster/singularity')
-rw-r--r--sys-cluster/singularity/Manifest1
-rw-r--r--sys-cluster/singularity/singularity-3.6.2.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index a7981fc79233..7d08c7edc685 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1,2 +1 @@
-DIST singularity-3.6.2.tar.gz 5933938 BLAKE2B 86b79687ef7591a255d01b83e857d87b7ab45aa9a84c40a7c90b493c0fc04cb33ff4f1616f38c5178e22ff1b19d390ab3b96f0fb05d6c66534e60d9ef2d7ea33 SHA512 fed2ebd286a3f250d8f4a7677e4bc0b13ec9b2e2eacff91c9a7f6efe6abc766a2d1b713bc291f0239585d5dacd5d4657309ef81eceb77f849f01be934a76499f
DIST singularity-3.6.3.tar.gz 5935146 BLAKE2B ff5c572c016fac36032e595765319dcdff65975f2036da1222b7b74911def0bc85a2cc86ad50cb0994397251e35d629b52b59f9d6894608448d23ceba808db5c SHA512 2c3342197a5075b89eb37bdf9127f9abaf3676f67dae0d164813f94e84f12b9f51f22eafd2e81a82e686622d93f90bcdf6f62c051903a2f122f960d0c116d5b1
diff --git a/sys-cluster/singularity/singularity-3.6.2.ebuild b/sys-cluster/singularity/singularity-3.6.2.ebuild
deleted file mode 100644
index 23232305c173..000000000000
--- a/sys-cluster/singularity/singularity-3.6.2.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info toolchain-funcs
-
-DESCRIPTION="Application containers for Linux"
-HOMEPAGE="https://sylabs.io"
-SRC_URI="https://github.com/hpcng/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples +network +suid"
-
-# Do not complain about CFLAGS etc since go projects do not use them.
-QA_FLAGS_IGNORED='.*'
-
-COMMON="sys-libs/libseccomp"
-BDEPEND="virtual/pkgconfig"
-DEPEND="${COMMON}
- >=dev-lang/go-1.13.0
- app-crypt/gpgme
- dev-libs/openssl
- sys-apps/util-linux
- sys-fs/cryptsetup"
-RDEPEND="${COMMON}
- sys-fs/squashfs-tools"
-
-CONFIG_CHECK="~SQUASHFS"
-
-S=${WORKDIR}/${PN}
-
-src_configure() {
- local myconfargs=(
- -c "$(tc-getBUILD_CC)" \
- -x "$(tc-getBUILD_CXX)" \
- -C "$(tc-getCC)" \
- -X "$(tc-getCXX)" \
- --prefix=/usr \
- --sysconfdir=/etc \
- --runstatedir=/run \
- --localstatedir=/var \
- $(usex network "" "--without-network") \
- $(usex suid "" "--without-suid")
- )
- ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
-}
-
-src_compile() {
- emake -C builddir
-}
-
-src_install() {
- emake DESTDIR="${ED}" -C builddir install
- keepdir /var/singularity/mnt/session
-
- # As of version 3.5.3 this seems to be very much broken, affecting
- # commands which have got nothing to do with singularity (example:
- # completion on 'udisks mount -b /dev/' rejects all files from that
- # directory other than 'autofs'). Moreover, this should go into
- # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
- # Hopefully temporary, which is why we delete this at install time
- # instead of patching build scripts not to generate bash-completion
- # data in the first place.
- rm -rf "${ED}"/etc/bash_completion.d || die
-
- dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
- if use examples; then
- dodoc -r examples
- fi
-}