summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-04-30 12:00:58 +0100
committerJustin Lecher <jlec@gentoo.org>2017-04-30 12:01:09 +0100
commit57ccd5f44dfedde8cbbff4637205d6d9c6667680 (patch)
tree2d31e3a92f6c6820d9617905e9c4001179edde05 /sys-cluster/singularity
parentapp-misc/grc: Version Bump and Py3.6 support (diff)
downloadgentoo-57ccd5f44dfedde8cbbff4637205d6d9c6667680.tar.gz
gentoo-57ccd5f44dfedde8cbbff4637205d6d9c6667680.tar.bz2
gentoo-57ccd5f44dfedde8cbbff4637205d6d9c6667680.zip
sys-cluster/singularity: Version Bump
Fix for glibc-2.25 https://github.com/singularityware/singularity/pull/648 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=617082 Package-Manager: Portage-2.3.5, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-cluster/singularity')
-rw-r--r--sys-cluster/singularity/Manifest2
-rw-r--r--sys-cluster/singularity/files/singularity-2.2.1-glibc-2.25.patch28
-rw-r--r--sys-cluster/singularity/metadata.xml2
-rw-r--r--sys-cluster/singularity/singularity-2.2.1.ebuild (renamed from sys-cluster/singularity/singularity-2.2.ebuild)6
4 files changed, 35 insertions, 3 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index 19aacc06202e..8ac63cfcb319 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1 +1 @@
-DIST singularity-2.2.tar.gz 492273 SHA256 3dcb23300d6a5a248659880cbcd98a073bc4a49d19c279ba0460256ed480f3e9 SHA512 ae22a2a33dd7d013f4fd12e751d83aeaf3b0acfe98d79d4f827e1380703cc17e624b67afde1f8af6e5a762d493a8748d073570133207b82db8f8e3483055379b WHIRLPOOL d7f5eed1515599086082c3877648ef1bacfa5e88441cc5f20736a56065f8b4f60778b3c4f2fef035cb00339a8a4cd8cba05ae6e1dc76fde8eae16b07ecd34952
+DIST singularity-2.2.1.tar.gz 493368 SHA256 0e2a0b0cf6c8d4dc041365f715b2df157e0d8d89986e4eb111c61716df031c8a SHA512 b1195e98254957cd8d80b35b13d4f11060c5836f05ed450d242544fc30f8c298b837ba8986b1184288bc9a5ff2ebb5b1f56dc55a0686b540242b0042a152f902 WHIRLPOOL 3d3c5cb0928bd5beb683c4075c88453d076795c0e41ad30676f7169ccbd6d71a70ad64104833925913138f47b8fc318e90366af79259a05bad41bb0a42703b05
diff --git a/sys-cluster/singularity/files/singularity-2.2.1-glibc-2.25.patch b/sys-cluster/singularity/files/singularity-2.2.1-glibc-2.25.patch
new file mode 100644
index 000000000000..e550811dc676
--- /dev/null
+++ b/sys-cluster/singularity/files/singularity-2.2.1-glibc-2.25.patch
@@ -0,0 +1,28 @@
+ src/lib/loop-control.c | 1 +
+ src/lib/mount/dev/dev.c | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/src/lib/loop-control.c b/src/lib/loop-control.c
+index f9ab2d6f..4bfed843 100644
+--- a/src/lib/loop-control.c
++++ b/src/lib/loop-control.c
+@@ -26,6 +26,7 @@
+ #include <sys/file.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <errno.h>
+ #include <string.h>
+ #include <fcntl.h>
+diff --git a/src/lib/mount/dev/dev.c b/src/lib/mount/dev/dev.c
+index 547157a4..c994c264 100644
+--- a/src/lib/mount/dev/dev.c
++++ b/src/lib/mount/dev/dev.c
+@@ -25,6 +25,7 @@
+ #include <sys/mount.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <unistd.h>
+ #include <stdlib.h>
+
diff --git a/sys-cluster/singularity/metadata.xml b/sys-cluster/singularity/metadata.xml
index e06fcd257fed..f47500258195 100644
--- a/sys-cluster/singularity/metadata.xml
+++ b/sys-cluster/singularity/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
diff --git a/sys-cluster/singularity/singularity-2.2.ebuild b/sys-cluster/singularity/singularity-2.2.1.ebuild
index 4ffbb268f804..0d679f703fed 100644
--- a/sys-cluster/singularity/singularity-2.2.ebuild
+++ b/sys-cluster/singularity/singularity-2.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,6 +14,10 @@ LICENSE="cctbx-2.0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="examples"
+PATCHES=(
+ "${FILESDIR}"/${P}-glibc-2.25.patch
+)
+
src_configure() {
econf --with-userns
}