summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-07-09 15:50:58 +0100
committerJustin Lecher <jlec@gentoo.org>2017-07-09 19:48:30 +0100
commit7c939e7a1b163ab5a754ba6592067be14ed9158c (patch)
tree50b7fbdc22f1da1dba4415b032ff89bc5e516566 /sys-cluster/slurm/files
parentx11-libs/vte: ia64 stable, bug #624312 (diff)
downloadgentoo-7c939e7a1b163ab5a754ba6592067be14ed9158c.tar.gz
gentoo-7c939e7a1b163ab5a754ba6592067be14ed9158c.tar.bz2
gentoo-7c939e7a1b163ab5a754ba6592067be14ed9158c.zip
sys-cluster/slurm: Fix compilation error with glibc-2.25
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=617192 Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-cluster/slurm/files')
-rw-r--r--sys-cluster/slurm/files/slurm-16.05.2-sysmacros.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-cluster/slurm/files/slurm-16.05.2-sysmacros.patch b/sys-cluster/slurm/files/slurm-16.05.2-sysmacros.patch
new file mode 100644
index 000000000000..f9d22f479f89
--- /dev/null
+++ b/sys-cluster/slurm/files/slurm-16.05.2-sysmacros.patch
@@ -0,0 +1,34 @@
+ configure.ac | 2 +-
+ src/plugins/task/cgroup/task_cgroup_devices.c | 6 ++++++
+ 2 files changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 869a989..2936983 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -141,7 +141,7 @@ AC_CHECK_HEADERS(mcheck.h values.h socket.h sys/socket.h \
+ AC_HEADER_SYS_WAIT
+ AC_HEADER_TIME
+ AC_HEADER_STDC
+-
++AC_HEADER_MAJOR
+
+ dnl Checks for structures.
+ dnl
+diff --git a/src/plugins/task/cgroup/task_cgroup_devices.c b/src/plugins/task/cgroup/task_cgroup_devices.c
+index 554583c..9be99d8 100644
+--- a/src/plugins/task/cgroup/task_cgroup_devices.c
++++ b/src/plugins/task/cgroup/task_cgroup_devices.c
+@@ -42,6 +42,12 @@
+ #include <sched.h>
+ #include <glob.h>
+ #include <sys/types.h>
++#ifdef MAJOR_IN_MKDEV
++# include <sys/mkdev.h>
++#endif
++#ifdef MAJOR_IN_SYSMACROS
++# include <sys/sysmacros.h>
++#endif
+ #include <sys/stat.h>
+ #include <slurm/slurm.h>
+ #include <slurm/slurm_errno.h>