summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Ten Harmsel <alec@alectenharmsel.com>2020-06-23 06:39:15 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-07-16 17:38:42 +0300
commit9c182e63b5cb2e159edd60c2ebaebfefe46504d9 (patch)
treefdf7e38478f3a1f6bbbe51238a963b005b994ff9 /sys-cluster/spark-bin/spark-bin-2.4.6.ebuild
parentwww-apps/gitea: drop old (diff)
downloadgentoo-9c182e63b5cb2e159edd60c2ebaebfefe46504d9.tar.gz
gentoo-9c182e63b5cb2e159edd60c2ebaebfefe46504d9.tar.bz2
gentoo-9c182e63b5cb2e159edd60c2ebaebfefe46504d9.zip
sys-cluster/spark-bin: Bump to 2.4.6
2.4.5 and earlier are insecure (see CVE-2020-9480). Bug: https://bugs.gentoo.org/729222 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alec Ten Harmsel <alec@alectenharmsel.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster/spark-bin/spark-bin-2.4.6.ebuild')
-rw-r--r--sys-cluster/spark-bin/spark-bin-2.4.6.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-cluster/spark-bin/spark-bin-2.4.6.ebuild b/sys-cluster/spark-bin/spark-bin-2.4.6.ebuild
new file mode 100644
index 000000000000..c178519a3a77
--- /dev/null
+++ b/sys-cluster/spark-bin/spark-bin-2.4.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2
+
+DESCRIPTION="Lightning-fast unified analytics engine"
+HOMEPAGE="https://spark.apache.org"
+SRC_URI="mirror://apache/spark/spark-${PV}/spark-${PV}-bin-hadoop2.7.tgz -> ${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=virtual/jre-1.8"
+
+DEPEND="
+ >=virtual/jdk-1.8"
+
+S="${WORKDIR}/spark-${PV}-bin-hadoop2.7"
+
+DOCS=( LICENSE NOTICE README.md RELEASE )
+
+# Nothing to compile here.
+src_compile() { :; }
+
+src_install() {
+ dodir usr/lib/spark
+ into usr/lib/spark
+
+ dobin bin/beeline \
+ bin/find-spark-home \
+ bin/pyspark \
+ bin/spark-class \
+ bin/spark-shell \
+ bin/spark-sql \
+ bin/spark-submit
+
+ insinto usr/lib/spark/bin
+ doins bin/load-spark-env.sh
+
+ insinto usr/lib/spark
+ doins -r conf
+ doins -r jars
+ doins -r python
+ doins -r sbin
+ doins -r yarn
+
+ dosym ../lib/spark/bin/beeline /usr/bin/beeline
+ dosym ../lib/spark/bin/find-spark-home /usr/bin/find-spark-home
+ dosym ../lib/spark/bin/pyspark /usr/bin/pyspark
+ dosym ../lib/spark/bin/spark-class /usr/bin/spark-class
+ dosym ../lib/spark/bin/spark-shell /usr/bin/spark-shell
+ dosym ../lib/spark/bin/spark-sql /usr/bin/spark-sql
+ dosym ../lib/spark/bin/spark-submit /usr/bin/spark-submit
+
+ doenvd "${FILESDIR}"/99spark
+ einstalldocs
+}