summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-03-23 21:05:03 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-03-23 21:05:20 -0500
commit065e3ee22b780d06d650b400db93dd6fae9cab46 (patch)
tree459d8b740362e45c3236d3e2282326a992191af4 /sys-cluster/swift
parentsys-devel/gcc: cut 2 patchset for 6.5.0 (diff)
downloadgentoo-065e3ee22b780d06d650b400db93dd6fae9cab46.tar.gz
gentoo-065e3ee22b780d06d650b400db93dd6fae9cab46.tar.bz2
gentoo-065e3ee22b780d06d650b400db93dd6fae9cab46.zip
sys-cluster/swift: clarify the kernel check
Closes: https://bugs.gentoo.org/713654 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-cluster/swift')
-rw-r--r--sys-cluster/swift/swift-2019.2.9999.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/sys-cluster/swift/swift-2019.2.9999.ebuild b/sys-cluster/swift/swift-2019.2.9999.ebuild
index dfb4786356f7..afeeb15cce38 100644
--- a/sys-cluster/swift/swift-2019.2.9999.ebuild
+++ b/sys-cluster/swift/swift-2019.2.9999.ebuild
@@ -46,12 +46,11 @@ RDEPEND="
pkg_pretend() {
linux-info_pkg_setup
- CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
- ~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
- ~ZFS"
+ CONFIG_CHECK="~EXT3_FS_XATTR ~CIFS_XATTR ~TMPFS_XATTR ~UBIFS_FS_XATTR
+ ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR ~ZFS"
if linux_config_exists; then
for module in ${CONFIG_CHECK}; do
- linux_chkconfig_present ${module} || ewarn "${module} needs to be enabled"
+ linux_chkconfig_present ${module} || ewarn "you may want to enable the ${module} module"
done
fi
}