summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-07-14 11:54:20 +0200
committerHans de Graaff <graaff@gentoo.org>2019-07-14 11:54:42 +0200
commitb0315a1c158e7d652da3d55da025e7f33df82b99 (patch)
tree5e7a38b87aff4d7dd469c64bff5b9b6b8b9fae8c /sys-cluster/torque/files
parentsci-visualization/gnuplot: stable 5.2.6 for ia64, bug #689718 (diff)
downloadgentoo-b0315a1c158e7d652da3d55da025e7f33df82b99.tar.gz
gentoo-b0315a1c158e7d652da3d55da025e7f33df82b99.tar.bz2
gentoo-b0315a1c158e7d652da3d55da025e7f33df82b99.zip
sys-cluster/torque: avoid unneeded openssl dependency
Fixes: https://bugs.gentoo.org/677736 Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'sys-cluster/torque/files')
-rw-r--r--sys-cluster/torque/files/torque-6.0.4-no-openssl.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/sys-cluster/torque/files/torque-6.0.4-no-openssl.patch b/sys-cluster/torque/files/torque-6.0.4-no-openssl.patch
new file mode 100644
index 000000000000..3b7e3cd49188
--- /dev/null
+++ b/sys-cluster/torque/files/torque-6.0.4-no-openssl.patch
@@ -0,0 +1,60 @@
+From 840bee84bff9529f2f7de4293cf7d5f567985123 Mon Sep 17 00:00:00 2001
+From: Matt Ezell <ezellma@ornl.gov>
+Date: Thu, 8 Oct 2015 15:32:30 -0400
+Subject: [PATCH] Remove unnecessary dependency on openssl-devel
+
+Closes #219
+---
+ README.building_40 | 3 ---
+ configure.ac | 10 ----------
+ src/daemon_client/Makefile.am | 2 +-
+ 3 files changed, 1 insertion(+), 14 deletions(-)
+
+diff --git a/README.building_40 b/README.building_40
+index bd2af03070..4b3a8c5f8a 100644
+--- a/README.building_40
++++ b/README.building_40
+@@ -14,9 +14,6 @@ automake
+ libtool
+ pkg-config
+
+-Non-standard packages required for building the source:
+-libssl-dev (name may vary among OSes)
+-
+ *** For admins that use cpusets in any form ***
+ hwloc version 1.1 or greater is now required for building TORQUE with cpusets, as pbs_mom now uses the
+ hwloc API to create the cpusets instead of creating them manually.
+diff --git a/configure.ac b/configure.ac
+index 14f238a519..636575c1b4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -745,16 +745,6 @@ AC_CHECK_LIB(pthread, pthread_create,
+ LIBS="$LIBS $PTHREAD_LIBS"
+
+
+-dnl we need -lssl and -lcrypto, lets make sure they exist
+-AC_CHECK_LIB(ssl, SSL_accept,
+- [],
+- [AC_MSG_ERROR([TORQUE needs lib openssl-devel in order to build]) ])
+-AC_CHECK_LIB(crypto, BN_init,
+- [],
+- [AC_MSG_ERROR([TORQUE needs lib crypto (often openssl-devel) in order to build]) ])
+-
+-
+-
+ dnl
+ dnl we need libxml2
+ dnl
+diff --git a/src/daemon_client/Makefile.am b/src/daemon_client/Makefile.am
+index e39f5e70b2..fe9d592b06 100644
+--- a/src/daemon_client/Makefile.am
++++ b/src/daemon_client/Makefile.am
+@@ -5,7 +5,7 @@ CLEANFILES = *.gcda *.gcno *.gcov
+
+ include_HEADERS = trq_auth_daemon.h
+
+-AM_CFLAGS = -DPBS_SERVER_HOME=\"$(PBS_SERVER_HOME)\" -Wall -pthread -ldl -lrt -lssl -lcrypto
++AM_CFLAGS = -DPBS_SERVER_HOME=\"$(PBS_SERVER_HOME)\" -Wall -pthread -ldl -lrt
+
+ sbin_PROGRAMS = trqauthd
+