summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-23 16:55:44 +0000
committerSam James <sam@gentoo.org>2022-01-23 16:56:29 +0000
commit55542ecffa3a87159287157e9514795b27c41799 (patch)
treec047ae25d4cb9ec4f84ff4f0254232d86b396aee /sys-cluster/torque
parentdev-libs/cdk: add HOMEPAGE (diff)
downloadgentoo-55542ecffa3a87159287157e9514795b27c41799.tar.gz
gentoo-55542ecffa3a87159287157e9514795b27c41799.tar.bz2
gentoo-55542ecffa3a87159287157e9514795b27c41799.zip
sys-cluster/torque: fix multiple build issues
- Pull in Fedora patch which sorts out autoconf quoting problems - Build with CC=CXX given odd upstream naming (.c is C++ there) - Fix glibc-2.34 build too Closes: https://bugs.gentoo.org/827474 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster/torque')
-rw-r--r--sys-cluster/torque/Manifest1
-rw-r--r--sys-cluster/torque/torque-6.0.4-r2.ebuild9
2 files changed, 9 insertions, 1 deletions
diff --git a/sys-cluster/torque/Manifest b/sys-cluster/torque/Manifest
index 712c69b3f5a5..8c324318e59e 100644
--- a/sys-cluster/torque/Manifest
+++ b/sys-cluster/torque/Manifest
@@ -2,3 +2,4 @@ DIST torque-4.1.7.tar.gz 6218108 BLAKE2B 6c1ad0f1bb3f364603ad7f498999bd910491910
DIST torque-4.2.10-gh-20150517.tar.gz 5836286 BLAKE2B 7108f1adcb6f674526b7db97df4ebcee04ae5c818d4f35ed1230a4e72e52ec0bc3b44e17334a143b21bcd3acccefc3927eca4f98d54d37745c8bb46a75e07045 SHA512 600bb5389b6a4161732b7aa82627f1ebeae238d7091aa2e223d9a14c44bf4668662f664b976f62ba3f1d8a366f90fb6058a8c904e20c26432dccd6abcd9c57fa
DIST torque-6.0.4-gcc7.patch 50412 BLAKE2B 43748e9bfd3811abdfeb56f93dd517fcb07a6902194120e2c9e16bbe5bbe0f04afd3f898616d46e0310902a6376671be0c8f3865e8f7dd5381fca46e7ad62fc8 SHA512 430ae6a80ebbfb2066831326f8ce25a34cb6fc17c1fbe4a202c495baceb2b7011c9f6782da31b78c34287f26765c76c587611d689791523b8bd53d634e3681b6
DIST torque-6.0.4-gh-20170829.tar.gz 6182495 BLAKE2B f9156ae4ffe388a7f3fa0df142e5f2d48c16fd7b8c148a3a80cd1c977eb0c1ef4a455da275f993100867be043422526ed05c53734e707851083d6d23ee1a2cc4 SHA512 8f1101adb89e06617de501f7956e126633b78b495baeb7980d3c534d34537cc604a3cf0a7c23c48eb2554b26cc13672b0e00c75d0f722d63ac4d42d57388ed94
+DIST torque-6.0.4-glibc-2.34-pthread.patch.bz2 6266 BLAKE2B b5175b8bfe2deabe86b067f1ec5269770bcf096c6e875b8fd3cb404a976c9cb550ddcbe6e4ebb1e59c96044f95c285519e70fb4acd5c9db86c3050093ff65b3b SHA512 dbe0bd6000c140e1fe9b36e55c1a844701406a563bd178b9c972793b83282f3434e2160da5280666dcc0934c2b88e36c0a2b9518ffe7695b23d73fce0a07388d
diff --git a/sys-cluster/torque/torque-6.0.4-r2.ebuild b/sys-cluster/torque/torque-6.0.4-r2.ebuild
index feb8fad349fe..cbf64c077648 100644
--- a/sys-cluster/torque/torque-6.0.4-r2.ebuild
+++ b/sys-cluster/torque/torque-6.0.4-r2.ebuild
@@ -8,7 +8,8 @@ inherit autotools flag-o-matic linux-info
DESCRIPTION="Resource manager and queuing system based on OpenPBS"
HOMEPAGE="http://www.adaptivecomputing.com/products/open-source/torque"
SRC_URI="https://github.com/adaptivecomputing/torque/archive/6a0b37f85c7d644e9217cbab1542792d646f59a6.tar.gz -> ${P}-gh-20170829.tar.gz
- https://dev.gentoo.org/~juippis/distfiles/tmp/torque-6.0.4-gcc7.patch"
+ https://dev.gentoo.org/~juippis/distfiles/tmp/torque-6.0.4-gcc7.patch
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-6.0.4-glibc-2.34-pthread.patch.bz2"
LICENSE="torque-2.5"
SLOT="0"
@@ -52,6 +53,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-6.0.3-fix-emptystring-comparison.patch
"${FILESDIR}"/${P}-no-openssl.patch
"${FILESDIR}"/${P}-error_buf_overflow_prevent.patch
+ "${WORKDIR}"/${P}-glibc-2.34-pthread.patch
)
pkg_setup() {
@@ -118,6 +120,11 @@ src_configure() {
--without-loadlibfile
}
+src_compile() {
+ # The .c files are C++, and $(CC) is misused.
+ emake CC="$(tc-getCXX)"
+}
+
src_install() {
local dir