summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-cluster/wulfware
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-cluster/wulfware')
-rw-r--r--sys-cluster/wulfware/Manifest1
-rw-r--r--sys-cluster/wulfware/files/wulfware-2.6.0-opts_and_strip.patch142
-rw-r--r--sys-cluster/wulfware/metadata.xml8
-rw-r--r--sys-cluster/wulfware/wulfware-2.6.0.ebuild53
4 files changed, 204 insertions, 0 deletions
diff --git a/sys-cluster/wulfware/Manifest b/sys-cluster/wulfware/Manifest
new file mode 100644
index 000000000000..1d922c2e92fa
--- /dev/null
+++ b/sys-cluster/wulfware/Manifest
@@ -0,0 +1 @@
+DIST wulfware-2.6.0.tgz 469000 SHA256 b89fe5bd46a687811ac682a59b63d0fac9e9b4218eaa1d6ffbae56590b71cc9c
diff --git a/sys-cluster/wulfware/files/wulfware-2.6.0-opts_and_strip.patch b/sys-cluster/wulfware/files/wulfware-2.6.0-opts_and_strip.patch
new file mode 100644
index 000000000000..bc26b7baa997
--- /dev/null
+++ b/sys-cluster/wulfware/files/wulfware-2.6.0-opts_and_strip.patch
@@ -0,0 +1,142 @@
+diff -ur wulfware-2.6.0.orig/libwulf/Makefile.am wulfware-2.6.0/libwulf/Makefile.am
+--- wulfware-2.6.0.orig/libwulf/Makefile.am 2007-07-12 00:58:25.000000000 +0300
++++ wulfware-2.6.0/libwulf/Makefile.am 2008-05-22 16:25:18.000000000 +0300
+@@ -48,14 +48,14 @@
+ # Define parameters and directives needed in compile/link steps.
+ #========================================================================
+ # C Compiler
+-CC = gcc
++CC ?= gcc
+
+ # Compile flags. -fpic creates "position independent code" for
+ # shared libraries!
+-CFLAGS = -O3 -I/usr/include/libxml2 -I ../include $(DEFINES)
++CFLAGS += -I/usr/include/libxml2 -I ../include $(DEFINES)
+
+ # Linker flags
+-LDFLAGS = -g -fpic --shared -Wl,-soname,$(PROGLIB_SONAME)
++LDFLAGS += -fpic --shared -Wl,-soname,$(PROGLIB_SONAME)
+
+ # Libraries
+ LIBS = -lpthread -lxml2 -lm
+@@ -110,7 +110,7 @@
+ install: $(PROGLIB_SO_VERSION) $(PROGMAN)
+ (install -d $(libdir); \
+ install -m 755 $(PROGLIB_SO_VERSION) $(libdir)/$(PROGLIB_SO_VERSION); \
+- ln -sf $(libdir)/$(PROGLIB_SO_VERSION) $(libdir)/$(PROGLIB_SO); \
++ ln -sf $(PROGLIB_SO_VERSION) $(libdir)/$(PROGLIB_SO); \
+ install -d $(includedir)/wulfware; \
+ install -m 644 ../include/wulfware/*.h $(includedir)/wulfware; \
+ install -d $(prefix)/share/man/man3; \
+diff -ur wulfware-2.6.0.orig/wulf2html/Makefile.am wulfware-2.6.0/wulf2html/Makefile.am
+--- wulfware-2.6.0.orig/wulf2html/Makefile.am 2007-07-12 00:58:25.000000000 +0300
++++ wulfware-2.6.0/wulf2html/Makefile.am 2008-05-22 12:52:36.000000000 +0300
+@@ -62,8 +62,7 @@
+ echo "Clean does nothing"
+
+ install : $(PROGRAM)
+- (strip $(PROGRAM);\
+- install -d $(prefix)/bin; \
++ (install -d $(prefix)/bin; \
+ install -m 755 $(PROGRAM) $(prefix)/bin; \
+ install -d $(sysconfdir); \
+ install -d $(sysconfdir)/init.d; \
+diff -ur wulfware-2.6.0.orig/wulflogger/Makefile.am wulfware-2.6.0/wulflogger/Makefile.am
+--- wulfware-2.6.0.orig/wulflogger/Makefile.am 2007-07-12 00:58:25.000000000 +0300
++++ wulfware-2.6.0/wulflogger/Makefile.am 2008-05-22 16:25:14.000000000 +0300
+@@ -54,13 +54,13 @@
+ # Define parameters and directives needed in compile/link steps.
+ #========================================================================
+ # C Compiler
+-CC = gcc
++CC ?= gcc
+
+ # Compile flags
+-CFLAGS = -O3 -I/usr/include/libxml2 -I ../include $(DEFINES)
++CFLAGS += -I/usr/include/libxml2 -I ../include $(DEFINES)
+
+ # Linker flags
+-LDFLAGS =
++LDFLAGS +=
+
+ # Libraries
+ LIBS = -L ../libwulf -lwulf -lpthread -lcurses -lxml2 -lm
+@@ -108,8 +108,7 @@
+ - rm -f core $(PROGRAM) *.o $(PROGRAM).1.gz
+
+ install : $(PROGRAM)
+- (strip $(PROGRAM);\
+- install -d $(prefix)/bin; \
++ (install -d $(prefix)/bin; \
+ install -m 755 $(PROGRAM) $(prefix)/bin; \
+ install -d $(prefix)/share/man/man1; \
+ gzip -c -9 $(PROGRAM).1 > $(PROGRAM).1.gz; \
+diff -ur wulfware-2.6.0.orig/wulfstat/Makefile.am wulfware-2.6.0/wulfstat/Makefile.am
+--- wulfware-2.6.0.orig/wulfstat/Makefile.am 2007-07-12 00:58:25.000000000 +0300
++++ wulfware-2.6.0/wulfstat/Makefile.am 2008-05-22 16:23:57.000000000 +0300
+@@ -54,13 +54,13 @@
+ # Define parameters and directives needed in compile/link steps.
+ #========================================================================
+ # C Compiler
+-CC = gcc
++CC ?= gcc
+
+ # Compile flags
+-CFLAGS = -O3 -I/usr/include/libxml2 -I ../include $(DEFINES)
++CFLAGS += -I/usr/include/libxml2 -I ../include $(DEFINES)
+
+ # Linker flags
+-LDFLAGS =
++LDFLAGS +=
+
+ # Libraries
+ LIBS = -L ../libwulf -lwulf -lpthread -lcurses -lxml2 -lm
+@@ -108,8 +108,7 @@
+ - rm -f core $(PROGRAM) *.o $(PROGRAM).1.gz
+
+ install : $(PROGRAM)
+- (strip $(PROGRAM);\
+- install -d $(prefix)/bin; \
++ (install -d $(prefix)/bin; \
+ install -m 755 $(PROGRAM) $(prefix)/bin; \
+ install -d $(prefix)/share/man/man1; \
+ gzip -c -9 $(PROGRAM).1 > $(PROGRAM).1.gz; \
+diff -ur wulfware-2.6.0.orig/xmlsysd/Makefile.am wulfware-2.6.0/xmlsysd/Makefile.am
+--- wulfware-2.6.0.orig/xmlsysd/Makefile.am 2007-07-12 00:58:25.000000000 +0300
++++ wulfware-2.6.0/xmlsysd/Makefile.am 2008-05-22 16:28:30.000000000 +0300
+@@ -60,13 +60,13 @@
+ # Define parameters and directives needed in compile/link steps.
+ #========================================================================
+ # C Compiler
+-CC = gcc
++CC ?= gcc
+
+ # Compile flags
+-CFLAGS = -O3 -I/usr/include/libxml2 $(DEFINES)
++CFLAGS += -I/usr/include/libxml2 $(DEFINES)
+
+ # Linker flags
+-LDFLAGS =
++LDFLAGS +=
+
+ # Libraries
+ LIBS = -lxml2 -lz -lm
+@@ -79,7 +79,7 @@
+ all: $(PROGRAM)
+
+ $(PROGRAM): $(OBJECTS) $(INCLUDES)
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(LIBS) $(OBJECTS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJECTS) $(LIBS) -o $@
+
+ #========================================================================
+ # The only safe place to do commits is in the toplevel directory
+@@ -109,8 +109,7 @@
+ # Application installation.
+ #========================================================================
+ install : $(PROGRAM)
+- (strip $(PROGRAM); \
+- install -d $(sbindir); \
++ (install -d $(sbindir); \
+ install -m 755 $(PROGRAM) $(sbindir); \
+ install -d $(sysconfdir); \
+ install -d $(sysconfdir)/xinetd.d; \
diff --git a/sys-cluster/wulfware/metadata.xml b/sys-cluster/wulfware/metadata.xml
new file mode 100644
index 000000000000..59e2b8f78cb5
--- /dev/null
+++ b/sys-cluster/wulfware/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-cluster/wulfware/wulfware-2.6.0.ebuild b/sys-cluster/wulfware/wulfware-2.6.0.ebuild
new file mode 100644
index 000000000000..333007764410
--- /dev/null
+++ b/sys-cluster/wulfware/wulfware-2.6.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit autotools eutils multilib toolchain-funcs
+
+DESCRIPTION="Applications to monitor on a beowulf- or GRID-style clusters"
+HOMEPAGE="http://www.phy.duke.edu/~rgb/Beowulf/wulfware.php"
+SRC_URI="http://www.phy.duke.edu/~rgb/Beowulf/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxml2
+ sys-libs/ncurses
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ !sys-cluster/wulfstat
+ !sys-cluster/xmlsysd"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-opts_and_strip.patch
+ eautoreconf
+}
+
+src_compile() {
+ tc-export CC
+ econf --disable-dependency-tracking
+ emake -j1 || die "emake failed."
+}
+
+src_install() {
+ emake prefix="${D}/usr" libdir="${D}/usr/$(get_libdir)" \
+ includedir="${D}/usr/include" sysconfdir="${D}/etc" \
+ install || die "emake install failed."
+
+ dodoc AUTHORS ChangeLog NEWS NOTES README xmlsysd/DESIGN
+
+ # FIXME: Update to Gentoo style init script.
+ rm -rf "${D}"/etc/init.d/wulf2html
+}
+
+pkg_postinst() {
+ elog "Add following line to /etc/services if you haven't done so already:"
+ elog
+ elog "xmlsysd 7887/tcp # xmlsysd remote system stats"
+ elog
+ elog "Be sure to edit /etc/xinetd.d/xmylsysd to suit your own options."
+}