summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraeme Lawes <graemelawes@gmail.com>2017-07-02 09:48:26 -0400
committerMichael Palimaka <kensington@gentoo.org>2017-09-03 01:20:29 +1000
commit00bd2f9524ff99b2d17f1cc79c9d5b678e1576f7 (patch)
tree6f8fa38f3bc9e4d35ae465796e8a25bb0f65767e /sys-cluster
parentx11-wm/awesome: warning about nonexistent path in src_install (diff)
downloadgentoo-00bd2f9524ff99b2d17f1cc79c9d5b678e1576f7.tar.gz
gentoo-00bd2f9524ff99b2d17f1cc79c9d5b678e1576f7.tar.bz2
gentoo-00bd2f9524ff99b2d17f1cc79c9d5b678e1576f7.zip
sys-cluster/teleport: fix src_test, restrict tests
src_test needs the same GOPATH as src_compile to run. Some tests are currently failing, so add RESTRICT=test until upstream devs can fix tests. Bug: https://bugs.gentoo.org/show_bug.cgi?id=623430
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/teleport/teleport-2.2.0.ebuild5
-rw-r--r--sys-cluster/teleport/teleport-2.2.1.ebuild5
-rw-r--r--sys-cluster/teleport/teleport-9999.ebuild4
3 files changed, 14 insertions, 0 deletions
diff --git a/sys-cluster/teleport/teleport-2.2.0.ebuild b/sys-cluster/teleport/teleport-2.2.0.ebuild
index 3fafc3ed333d..90fddb344c0c 100644
--- a/sys-cluster/teleport/teleport-2.2.0.ebuild
+++ b/sys-cluster/teleport/teleport-2.2.0.ebuild
@@ -21,6 +21,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
+RESTRICT="test"
DEPEND="
app-arch/zip
@@ -51,3 +52,7 @@ src_install() {
systemd_dounit "${FILESDIR}"/${PN}.service
systemd_install_serviced "${FILESDIR}"/${PN}.service.conf ${PN}.service
}
+
+src_test() {
+ GOPATH="${S}" emake -C src/${EGO_PN%/*} test
+}
diff --git a/sys-cluster/teleport/teleport-2.2.1.ebuild b/sys-cluster/teleport/teleport-2.2.1.ebuild
index 3fafc3ed333d..90fddb344c0c 100644
--- a/sys-cluster/teleport/teleport-2.2.1.ebuild
+++ b/sys-cluster/teleport/teleport-2.2.1.ebuild
@@ -21,6 +21,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
+RESTRICT="test"
DEPEND="
app-arch/zip
@@ -51,3 +52,7 @@ src_install() {
systemd_dounit "${FILESDIR}"/${PN}.service
systemd_install_serviced "${FILESDIR}"/${PN}.service.conf ${PN}.service
}
+
+src_test() {
+ GOPATH="${S}" emake -C src/${EGO_PN%/*} test
+}
diff --git a/sys-cluster/teleport/teleport-9999.ebuild b/sys-cluster/teleport/teleport-9999.ebuild
index 3e870fac4bd4..a16c3c133705 100644
--- a/sys-cluster/teleport/teleport-9999.ebuild
+++ b/sys-cluster/teleport/teleport-9999.ebuild
@@ -49,3 +49,7 @@ src_install() {
systemd_dounit "${FILESDIR}"/${PN}.service
systemd_install_serviced "${FILESDIR}"/${PN}.service.conf ${PN}.service
}
+
+src_test() {
+ GOPATH="${S}" emake -C src/${EGO_PN%/*} test
+}