summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-07-21 17:14:59 +0200
committerMarek Szuba <marecki@gentoo.org>2020-07-21 17:14:59 +0200
commit042d44f63a5f66394ffa94e0e904f5437d349d1f (patch)
tree77ca1e5e24b6d54fcae1d3869c8364438ac07f52 /sys-cluster
parentsys-cluster/singularity: bump to 3.6.0 (diff)
downloadgentoo-042d44f63a5f66394ffa94e0e904f5437d349d1f.tar.gz
gentoo-042d44f63a5f66394ffa94e0e904f5437d349d1f.tar.bz2
gentoo-042d44f63a5f66394ffa94e0e904f5437d349d1f.zip
sys-cluster/singularity: remove old
2.6.1 is ancient and doesn't support Python versions newer than 3.6, 3.5.3 has several known security vulnerabilities. Bug: https://bugs.gentoo.org/733238 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/singularity/Manifest2
-rw-r--r--sys-cluster/singularity/singularity-2.6.1.ebuild44
-rw-r--r--sys-cluster/singularity/singularity-3.5.3-r1.ebuild69
3 files changed, 0 insertions, 115 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index c5fb4e10a0af..92b34c1c6a62 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1,3 +1 @@
-DIST singularity-2.6.1.tar.gz 835029 BLAKE2B 4a581e1bc5df9d664d68f17e275f01081c850aa53f8a9bfcceaf5eb2b8f16e3a018f88669674c7427c60ab00ec0f21b4ec5e6ecaab261c16f70a998cb54ff855 SHA512 063327c67dae2629d1decebc060c474a72e6741f6dc9b6373734e429ccf11d53ee55c1578c28e74e8f8bcda87f3e0b735a3a0e982c9ea894f03a31eaaadf617c
-DIST singularity-3.5.3.tar.gz 7885009 BLAKE2B 8afa2223906e7abf5f3d796efe7cf243dd9d91e61c8ca143a755ad772618ed01d20b7f4a030e82767cf9bf2a7431848d8344e30bde38f413ecd2eef0a9bab53e SHA512 b8bb44539e78eaf74c1b97e5bae8fae1f390412456d76b573fffe2a90240b182db1aec60aee80715547c3edfbaa0607506e2727a575bc951223f9a7c3be0a97e
DIST singularity-3.6.0.tar.gz 6169388 BLAKE2B ea07da3d586a96625a1016f9b4aa6b99072c89393dcb7c80aab624807e51fc107eee2629020bf3e1c19d6103544b63aad960d2ac27804fa6e03323a806fdf270 SHA512 695f3b4c1bd8cc4049fc3e8e296b369f5aadcd6b4717521b9aca68d997fd8a8c0bf349a2851c31b8a22f37fa010b4c7b93562fd6ac24cdc9699230a182f36d29
diff --git a/sys-cluster/singularity/singularity-2.6.1.ebuild b/sys-cluster/singularity/singularity-2.6.1.ebuild
deleted file mode 100644
index 0ae3cb4ae918..000000000000
--- a/sys-cluster/singularity/singularity-2.6.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit autotools eutils python-single-r1
-
-DESCRIPTION="Application containers for Linux"
-HOMEPAGE="https://sylabs.io"
-SRC_URI="https://github.com/${PN}ware/${PN}/releases/download/${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples static-libs +suid"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-RDEPEND="
- ${PYTHON_DEPS}
- sys-fs/squashfs-tools:0
-"
-DEPEND=${PYTHON_DEPS}
-
-src_prepare() {
- default
- # automake version hardcoding
- eautoreconf
-}
-
-src_configure() {
- econf \
- --with-userns \
- $(usex suid "" "--disable-suid") \
- $(use_enable static-libs static)
-}
-
-src_install() {
- MAKEOPTS+=" -j1"
- default
- dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
- use examples && dodoc -r examples
-}
diff --git a/sys-cluster/singularity/singularity-3.5.3-r1.ebuild b/sys-cluster/singularity/singularity-3.5.3-r1.ebuild
deleted file mode 100644
index 16834ae083a3..000000000000
--- a/sys-cluster/singularity/singularity-3.5.3-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info
-
-DESCRIPTION="Application containers for Linux"
-HOMEPAGE="https://sylabs.io"
-SRC_URI="https://github.com/sylabs/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples +network +suid"
-
-# Do not complain about CFLAGS etc since go projects do not use them.
-QA_FLAGS_IGNORED='.*'
-
-COMMON="sys-libs/libseccomp"
-BDEPEND="virtual/pkgconfig"
-DEPEND="${COMMON}
- >=dev-lang/go-1.13.0
- app-crypt/gpgme
- dev-libs/openssl
- sys-apps/util-linux
- sys-fs/cryptsetup"
-RDEPEND="${COMMON}
- sys-fs/squashfs-tools"
-
-CONFIG_CHECK="~SQUASHFS"
-
-S=${WORKDIR}/${PN}
-
-src_configure() {
- local myconfargs=(
- --prefix=/usr \
- --sysconfdir=/etc \
- --runstatedir=/run \
- --localstatedir=/var \
- $(usex network "" "--without-network") \
- $(usex suid "" "--without-suid")
- )
- ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
-}
-
-src_compile() {
- emake -C builddir
-}
-
-src_install() {
- emake DESTDIR="${ED}" -C builddir install
- keepdir /var/singularity/mnt/session
-
- # As of version 3.5.3 this seems to be very much broken, affecting
- # commands which have got nothing to do with singularity (example:
- # completion on 'udisks mount -b /dev/' rejects all files from that
- # directory other than 'autofs'). Moreover, this should go into
- # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
- # Hopefully temporary, which is why we delete this at install time
- # instead of patching build scripts not to generate bash-completion
- # data in the first place.
- rm -rf "${ED}"/etc/bash_completion.d || die
-
- dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
- if use examples; then
- dodoc -r examples
- fi
-}