summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2020-07-12 16:22:36 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-07-24 15:03:30 +0300
commit07473f74b43a0d9ae4d7a0d5784ba3444ed020a9 (patch)
tree16d98dc810ba35051c2b15d3559aff7dfd1bf950 /sys-cluster
parentsys-cluster/hpx: Fix memory requirement (diff)
downloadgentoo-07473f74b43a0d9ae4d7a0d5784ba3444ed020a9.tar.gz
gentoo-07473f74b43a0d9ae4d7a0d5784ba3444ed020a9.tar.bz2
gentoo-07473f74b43a0d9ae4d7a0d5784ba3444ed020a9.zip
sys-cluster/hpx: Sync live ebuild
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Closes: https://github.com/gentoo/gentoo/pull/16679 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/hpx/hpx-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-cluster/hpx/hpx-9999.ebuild b/sys-cluster/hpx/hpx-9999.ebuild
index 25019566f392..168825c65b05 100644
--- a/sys-cluster/hpx/hpx-9999.ebuild
+++ b/sys-cluster/hpx/hpx-9999.ebuild
@@ -12,7 +12,7 @@ else
SRC_URI="https://stellar.cct.lsu.edu/files/${PN}_${PV}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi
-inherit cmake fortran-2 python-single-r1 check-reqs
+inherit cmake fortran-2 python-single-r1 check-reqs multiprocessing
DESCRIPTION="C++ runtime system for parallel and distributed applications"
HOMEPAGE="https://stellar.cct.lsu.edu/tag/hpx/"
@@ -58,7 +58,7 @@ hpx_memory_requirement() {
if [[ -z ${MAKEOPTS} ]] ; then
echo "2G"
else
- local jobs=`echo ${MAKEOPTS} | cut -d j -f 2`
+ local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
echo "${jobs}G"
fi
}