summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-03-20 14:53:46 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-03-20 14:54:20 -0700
commit12252b6abcce03e3154157193bc59c6653cbbb89 (patch)
tree70ea1784903022b71f4f5fe50bc4bd9a8002f9de /sys-cluster
parentsci-libs/libgeodecomp: add version 0.4.0. (diff)
downloadgentoo-12252b6abcce03e3154157193bc59c6653cbbb89.tar.gz
gentoo-12252b6abcce03e3154157193bc59c6653cbbb89.tar.bz2
gentoo-12252b6abcce03e3154157193bc59c6653cbbb89.zip
sys-cluster/ceph: Remove automagic dependency on dev-cpp/tbb
This removes an automagic dep on tbb in 13.2.5. Also remove unneeded patch from 14.2.0 Closes: https://bugs.gentoo.org/667024 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ceph-13.2.5-r1.ebuild (renamed from sys-cluster/ceph/ceph-13.2.5.ebuild)6
-rw-r--r--sys-cluster/ceph/ceph-14.2.0-r1.ebuild (renamed from sys-cluster/ceph/ceph-14.2.0.ebuild)10
-rw-r--r--sys-cluster/ceph/files/ceph-13.2.5-no-automagic-deps.patch37
-rw-r--r--sys-cluster/ceph/files/ceph-14.2.0-no-automagic-tbb.patch12
-rw-r--r--sys-cluster/ceph/metadata.xml1
5 files changed, 47 insertions, 19 deletions
diff --git a/sys-cluster/ceph/ceph-13.2.5.ebuild b/sys-cluster/ceph/ceph-13.2.5-r1.ebuild
index cca90b166f05..f83f6158171a 100644
--- a/sys-cluster/ceph/ceph-13.2.5.ebuild
+++ b/sys-cluster/ceph/ceph-13.2.5-r1.ebuild
@@ -26,7 +26,7 @@ SLOT="0"
CPU_FLAGS_X86=(sse{,2,3,4_1,4_2} ssse3)
-IUSE="babeltrace cephfs dpdk fuse jemalloc ldap lttng +mgr"
+IUSE="babeltrace cephfs dpdk fuse jemalloc ldap lttng +mgr numa"
IUSE+=" +radosgw +ssl static-libs +system-boost systemd +tcmalloc test"
IUSE+=" xfs zfs"
IUSE+=" $(printf "cpu_flags_x86_%s\n" ${CPU_FLAGS_X86[@]})"
@@ -54,6 +54,7 @@ COMMON_DEPEND="
ldap? ( net-nds/openldap:=[static-libs?] )
lttng? ( dev-util/lttng-ust:= )
fuse? ( sys-fs/fuse:0=[static-libs?] )
+ numa? ( sys-process/numactl:=[static-libs?] )
ssl? ( dev-libs/openssl:=[static-libs?] )
xfs? ( sys-fs/xfsprogs:=[static-libs?] )
zfs? ( sys-fs/zfs:=[static-libs?] )
@@ -136,6 +137,7 @@ PATCHES=(
"${FILESDIR}/ceph-13.2.0-mgr-python-version.patch"
"${FILESDIR}/ceph-13.2.0-no-virtualenvs.patch"
"${FILESDIR}/ceph-13.2.2-dont-install-sysvinit-script.patch"
+ "${FILESDIR}/ceph-13.2.5-no-automagic-deps.patch"
)
check-reqs_export_vars() {
@@ -193,6 +195,7 @@ ceph_src_configure() {
-DWITH_LTTNG=$(usex lttng)
-DWITH_MGR=$(usex mgr)
-DWITH_MGR_DASHBOARD_FRONTEND=NO
+ -DWITH_NUMA=$(usex numa)
-DWITH_OPENLDAP=$(usex ldap)
-DWITH_RADOSGW=$(usex radosgw)
-DWITH_SSL=$(usex ssl)
@@ -205,6 +208,7 @@ ceph_src_configure() {
-DWITH_SYSTEM_BOOST=$(usex system-boost)
-DBOOST_J=$(makeopts_jobs)
-DWITH_RDMA=no
+ -DWITH_TBB=no
-DSYSTEMD_UNITDIR=$(systemd_get_systemunitdir)
-DEPYTHON_VERSION="${EPYTHON#python}"
-DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${P}"
diff --git a/sys-cluster/ceph/ceph-14.2.0.ebuild b/sys-cluster/ceph/ceph-14.2.0-r1.ebuild
index d754478c6d04..8a6796f810f2 100644
--- a/sys-cluster/ceph/ceph-14.2.0.ebuild
+++ b/sys-cluster/ceph/ceph-14.2.0-r1.ebuild
@@ -27,13 +27,10 @@ SLOT="0"
CPU_FLAGS_X86=(sse{,2,3,4_1,4_2} ssse3)
IUSE="babeltrace cephfs dpdk fuse grafana jemalloc kerberos ldap lttng +mgr"
-IUSE+=" rabbitmq +radosgw +ssl static-libs +system-boost systemd +tcmalloc"
-IUSE+=" test xfs zfs"
+IUSE+=" numa rabbitmq +radosgw +ssl static-libs +system-boost systemd"
+IUSE+=" +tcmalloc test xfs zfs"
IUSE+=" $(printf "cpu_flags_x86_%s\n" ${CPU_FLAGS_X86[@]})"
-# unbundling code commented out pending bugs 584056 and 584058
-#>=dev-libs/jerasure-2.0.0-r1
-#>=dev-libs/gf-complete-2.0.0
COMMON_DEPEND="
virtual/libudev:=
app-arch/bzip2:=[static-libs?]
@@ -143,7 +140,6 @@ PATCHES=(
"${FILESDIR}/ceph-14.2.0-no-virtualenvs.patch"
"${FILESDIR}/ceph-13.2.2-dont-install-sysvinit-script.patch"
"${FILESDIR}/ceph-14.2.0-dpdk-cflags.patch"
- "${FILESDIR}/ceph-14.2.0-no-automagic-tbb.patch"
)
# dpdk and ninja don't get along
@@ -206,6 +202,7 @@ ceph_src_configure() {
-DWITH_GRAFANA=$(usex grafana)
-DWITH_MGR=$(usex mgr)
-DWITH_MGR_DASHBOARD_FRONTEND=NO
+ -DWITH_NUMA=$(usex numa)
-DWITH_OPENLDAP=$(usex ldap)
-DWITH_RADOSGW=$(usex radosgw)
-DWITH_RADOSGW_AMQP_ENDPOINT=$(usex rabbitmq)
@@ -219,6 +216,7 @@ ceph_src_configure() {
-DWITH_SYSTEM_BOOST=$(usex system-boost)
-DBOOST_J=$(makeopts_jobs)
-DWITH_RDMA=no
+ -DWITH_TBB=no
-DSYSTEMD_UNITDIR=$(systemd_get_systemunitdir)
-DEPYTHON_VERSION="${EPYTHON#python}"
-DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${P}"
diff --git a/sys-cluster/ceph/files/ceph-13.2.5-no-automagic-deps.patch b/sys-cluster/ceph/files/ceph-13.2.5-no-automagic-deps.patch
new file mode 100644
index 000000000000..1eb42b3e5ad6
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-13.2.5-no-automagic-deps.patch
@@ -0,0 +1,37 @@
+--- ceph-13.2.5.orig/src/rocksdb/CMakeLists.txt 2019-03-20 11:39:25.065954652 -0700
++++ ceph-13.2.5/src/rocksdb/CMakeLists.txt 2019-03-20 13:18:01.548085828 -0700
+@@ -286,18 +286,24 @@
+ endif()
+ endif()
+
+-find_package(NUMA)
+-if(NUMA_FOUND)
+- add_definitions(-DNUMA)
+- include_directories(${NUMA_INCLUDE_DIR})
+- list(APPEND THIRDPARTY_LIBS ${NUMA_LIBRARIES})
++option(WITH_NUMA "build with UBSAN" OFF)
++if(WITH_NUMA)
++ find_package(NUMA)
++ if(NUMA_FOUND)
++ add_definitions(-DNUMA)
++ include_directories(${NUMA_INCLUDE_DIR})
++ list(APPEND THIRDPARTY_LIBS ${NUMA_LIBRARIES})
++ endif()
+ endif()
+
+-find_package(TBB)
+-if(TBB_FOUND)
+- add_definitions(-DTBB)
+- include_directories(${TBB_INCLUDE_DIR})
+- list(APPEND THIRDPARTY_LIBS ${TBB_LIBRARIES})
++option(WITH_TBB "build with UBSAN" OFF)
++if(WITH_TBB)
++ find_package(TBB)
++ if(TBB_FOUND)
++ add_definitions(-DTBB)
++ include_directories(${TBB_INCLUDE_DIR})
++ list(APPEND THIRDPARTY_LIBS ${TBB_LIBRARIES})
++ endif()
+ endif()
+
+ # Used to run CI build and tests so we can run faster
diff --git a/sys-cluster/ceph/files/ceph-14.2.0-no-automagic-tbb.patch b/sys-cluster/ceph/files/ceph-14.2.0-no-automagic-tbb.patch
deleted file mode 100644
index 3e671a490981..000000000000
--- a/sys-cluster/ceph/files/ceph-14.2.0-no-automagic-tbb.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/cmake/modules/BuildRocksDB.cmake b/cmake/modules/BuildRocksDB.cmake
-index 69741f4601..8e7a9e30c3 100644
---- a/cmake/modules/BuildRocksDB.cmake
-+++ b/cmake/modules/BuildRocksDB.cmake
-@@ -39,6 +39,7 @@ function(build_rocksdb)
- list(APPEND rocksdb_CMAKE_ARGS -DCMAKE_BUILD_TYPE=${CMAKE_BUILD_TYPE})
- list(APPEND rocksdb_CMAKE_ARGS -DFAIL_ON_WARNINGS=OFF)
- list(APPEND rocksdb_CMAKE_ARGS -DUSE_RTTI=1)
-+ list(APPEND rocksdb_CMAKE_ARGS -DWITH_TBB=NO)
- CHECK_C_COMPILER_FLAG("-Wno-stringop-truncation" HAS_WARNING_STRINGOP_TRUNCATION)
- if(HAS_WARNING_STRINGOP_TRUNCATION)
- list(APPEND rocksdb_CMAKE_ARGS -DCMAKE_C_FLAGS="-Wno-stringop-truncation")
diff --git a/sys-cluster/ceph/metadata.xml b/sys-cluster/ceph/metadata.xml
index f1a3c5f52090..03215bde3fda 100644
--- a/sys-cluster/ceph/metadata.xml
+++ b/sys-cluster/ceph/metadata.xml
@@ -28,6 +28,7 @@
<flag name="lttng">Add support for LTTng</flag>
<flag name="mgr">Build the ceph-mgr daemon</flag>
<flag name="nss">Use <pkg>dev-libs/nss</pkg> for cryptography</flag>
+ <flag name="numa">Use <pkg>sys-process/numactl</pkg> for numa support in rocksdb</flag>
<flag name="rabbitmq">Use rabbitmq-c to build rgw amqp push endpoint</flag>
<flag name="radosgw">Add radosgw support</flag>
<flag name="system-boost">Use system <pkg>dev-libs/boost</pkg> instead of the bundled one</flag>