summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-03 00:20:38 +0000
committerSam James <sam@gentoo.org>2022-01-03 00:21:48 +0000
commit1e46e06ae70156fb4d4db508c727b1812e6a7aa4 (patch)
tree0c1501057307b542ddb23ba9ea292b94f6faa408 /sys-cluster
parentapp-emulation/virt-manager: enable py3.10 (diff)
downloadgentoo-1e46e06ae70156fb4d4db508c727b1812e6a7aa4.tar.gz
gentoo-1e46e06ae70156fb4d4db508c727b1812e6a7aa4.tar.bz2
gentoo-1e46e06ae70156fb4d4db508c727b1812e6a7aa4.zip
sys-cluster/openmpi: disable heterogeneous (unsupported, broken)
Upstream have let us know (thank you!) that heterogeneous should _not_ be used for anything before 5.0.x (which is not out yet). We can look at restoring support in the future once it is ready upstream. Upstream documentation has been fixed to reflect this too. Closes: https://bugs.gentoo.org/828123 Thanks-to: Jeff Squyres <jsquyres@cisco.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/files/openmpi-4.1.2-missing-includes.patch32
-rw-r--r--sys-cluster/openmpi/openmpi-4.0.2-r1.ebuild6
-rw-r--r--sys-cluster/openmpi/openmpi-4.0.3-r1.ebuild6
-rw-r--r--sys-cluster/openmpi/openmpi-4.0.4-r1.ebuild6
-rw-r--r--sys-cluster/openmpi/openmpi-4.0.5-r2.ebuild6
-rw-r--r--sys-cluster/openmpi/openmpi-4.0.5-r3.ebuild6
-rw-r--r--sys-cluster/openmpi/openmpi-4.0.6-r1.ebuild6
-rw-r--r--sys-cluster/openmpi/openmpi-4.0.7.ebuild6
-rw-r--r--sys-cluster/openmpi/openmpi-4.1.1-r1.ebuild6
-rw-r--r--sys-cluster/openmpi/openmpi-4.1.2.ebuild12
10 files changed, 30 insertions, 62 deletions
diff --git a/sys-cluster/openmpi/files/openmpi-4.1.2-missing-includes.patch b/sys-cluster/openmpi/files/openmpi-4.1.2-missing-includes.patch
deleted file mode 100644
index 89abc049df4e..000000000000
--- a/sys-cluster/openmpi/files/openmpi-4.1.2-missing-includes.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-https://github.com/open-mpi/ompi/commit/927e9aa97373dac652f9cba4813e6ee609ca2830
-https://bugs.gentoo.org/828123
-
-From: George Bosilca <bosilca@icl.utk.edu>
-Date: Tue, 23 Nov 2021 14:28:11 -0500
-Subject: [PATCH] Fix compile failure with enable-heterogeneous.
-
-An internal header file was missing, leading to an incomplete type.
-
-Fixes #9697.
-
-Signed-off-by: George Bosilca <bosilca@icl.utk.edu>
---- a/ompi/mca/coll/base/coll_base_alltoall.c
-+++ b/ompi/mca/coll/base/coll_base_alltoall.c
-@@ -29,6 +29,7 @@
- #include "mpi.h"
- #include "ompi/constants.h"
- #include "ompi/datatype/ompi_datatype.h"
-+#include "opal/datatype/opal_convertor_internal.h"
- #include "ompi/communicator/communicator.h"
- #include "ompi/mca/coll/coll.h"
- #include "ompi/mca/coll/base/coll_tags.h"
---- a/ompi/mca/coll/base/coll_base_alltoallv.c
-+++ b/ompi/mca/coll/base/coll_base_alltoallv.c
-@@ -31,6 +31,7 @@
- #include "mpi.h"
- #include "ompi/constants.h"
- #include "ompi/datatype/ompi_datatype.h"
-+#include "opal/datatype/opal_convertor_internal.h"
- #include "ompi/communicator/communicator.h"
- #include "ompi/mca/coll/coll.h"
- #include "ompi/mca/coll/base/coll_tags.h"
diff --git a/sys-cluster/openmpi/openmpi-4.0.2-r1.ebuild b/sys-cluster/openmpi/openmpi-4.0.2-r1.ebuild
index 7dedbcb532f9..6218dc7f7a65 100644
--- a/sys-cluster/openmpi/openmpi-4.0.2-r1.ebuild
+++ b/sys-cluster/openmpi/openmpi-4.0.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,7 +31,7 @@ SRC_URI="https://www.open-mpi.org/software/ompi/v$(ver_cut 1-2)/downloads/${MY_P
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
-IUSE="cma cuda cxx fortran heterogeneous ipv6 java romio
+IUSE="cma cuda cxx fortran ipv6 java romio
${IUSE_OPENMPI_FABRICS} ${IUSE_OPENMPI_RM} ${IUSE_OPENMPI_OFED_FEATURES}"
REQUIRED_USE="openmpi_rm_slurm? ( !openmpi_rm_pbs )
@@ -111,7 +111,7 @@ multilib_src_configure() {
$(use_with cma) \
$(multilib_native_use_with cuda cuda "${EPREFIX}"/opt/cuda) \
$(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
+ --disable-heterogeneous \
$(use_enable ipv6) \
$(multilib_native_use_enable java mpi-java) \
$(multilib_native_use_with openmpi_fabrics_ofed verbs "${EPREFIX}"/usr) \
diff --git a/sys-cluster/openmpi/openmpi-4.0.3-r1.ebuild b/sys-cluster/openmpi/openmpi-4.0.3-r1.ebuild
index 7dedbcb532f9..6218dc7f7a65 100644
--- a/sys-cluster/openmpi/openmpi-4.0.3-r1.ebuild
+++ b/sys-cluster/openmpi/openmpi-4.0.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,7 +31,7 @@ SRC_URI="https://www.open-mpi.org/software/ompi/v$(ver_cut 1-2)/downloads/${MY_P
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
-IUSE="cma cuda cxx fortran heterogeneous ipv6 java romio
+IUSE="cma cuda cxx fortran ipv6 java romio
${IUSE_OPENMPI_FABRICS} ${IUSE_OPENMPI_RM} ${IUSE_OPENMPI_OFED_FEATURES}"
REQUIRED_USE="openmpi_rm_slurm? ( !openmpi_rm_pbs )
@@ -111,7 +111,7 @@ multilib_src_configure() {
$(use_with cma) \
$(multilib_native_use_with cuda cuda "${EPREFIX}"/opt/cuda) \
$(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
+ --disable-heterogeneous \
$(use_enable ipv6) \
$(multilib_native_use_enable java mpi-java) \
$(multilib_native_use_with openmpi_fabrics_ofed verbs "${EPREFIX}"/usr) \
diff --git a/sys-cluster/openmpi/openmpi-4.0.4-r1.ebuild b/sys-cluster/openmpi/openmpi-4.0.4-r1.ebuild
index 7dedbcb532f9..6218dc7f7a65 100644
--- a/sys-cluster/openmpi/openmpi-4.0.4-r1.ebuild
+++ b/sys-cluster/openmpi/openmpi-4.0.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,7 +31,7 @@ SRC_URI="https://www.open-mpi.org/software/ompi/v$(ver_cut 1-2)/downloads/${MY_P
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
-IUSE="cma cuda cxx fortran heterogeneous ipv6 java romio
+IUSE="cma cuda cxx fortran ipv6 java romio
${IUSE_OPENMPI_FABRICS} ${IUSE_OPENMPI_RM} ${IUSE_OPENMPI_OFED_FEATURES}"
REQUIRED_USE="openmpi_rm_slurm? ( !openmpi_rm_pbs )
@@ -111,7 +111,7 @@ multilib_src_configure() {
$(use_with cma) \
$(multilib_native_use_with cuda cuda "${EPREFIX}"/opt/cuda) \
$(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
+ --disable-heterogeneous \
$(use_enable ipv6) \
$(multilib_native_use_enable java mpi-java) \
$(multilib_native_use_with openmpi_fabrics_ofed verbs "${EPREFIX}"/usr) \
diff --git a/sys-cluster/openmpi/openmpi-4.0.5-r2.ebuild b/sys-cluster/openmpi/openmpi-4.0.5-r2.ebuild
index 910b08a8e8f6..3ab02e1aff6a 100644
--- a/sys-cluster/openmpi/openmpi-4.0.5-r2.ebuild
+++ b/sys-cluster/openmpi/openmpi-4.0.5-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,7 +31,7 @@ SRC_URI="https://www.open-mpi.org/software/ompi/v$(ver_cut 1-2)/downloads/${MY_P
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
-IUSE="cma cuda cxx fortran heterogeneous ipv6 java romio
+IUSE="cma cuda cxx fortran ipv6 java romio
${IUSE_OPENMPI_FABRICS} ${IUSE_OPENMPI_RM} ${IUSE_OPENMPI_OFED_FEATURES}"
REQUIRED_USE="openmpi_rm_slurm? ( !openmpi_rm_pbs )
@@ -111,7 +111,7 @@ multilib_src_configure() {
$(use_with cma) \
$(multilib_native_use_with cuda cuda "${EPREFIX}"/opt/cuda) \
$(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
+ --disable-heterogeneous \
$(use_enable ipv6) \
$(multilib_native_use_enable java mpi-java) \
$(multilib_native_use_with openmpi_fabrics_ofed verbs "${EPREFIX}"/usr) \
diff --git a/sys-cluster/openmpi/openmpi-4.0.5-r3.ebuild b/sys-cluster/openmpi/openmpi-4.0.5-r3.ebuild
index 6609fda95cfc..dedc2ebe1349 100644
--- a/sys-cluster/openmpi/openmpi-4.0.5-r3.ebuild
+++ b/sys-cluster/openmpi/openmpi-4.0.5-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,7 +31,7 @@ SRC_URI="https://www.open-mpi.org/software/ompi/v$(ver_cut 1-2)/downloads/${MY_P
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~ia64 ppc ppc64 ~riscv sparc x86 ~amd64-linux"
-IUSE="cma cuda cxx fortran heterogeneous ipv6 java libompitrace peruse romio
+IUSE="cma cuda cxx fortran ipv6 java libompitrace peruse romio
${IUSE_OPENMPI_FABRICS} ${IUSE_OPENMPI_RM} ${IUSE_OPENMPI_OFED_FEATURES}"
REQUIRED_USE="openmpi_rm_slurm? ( !openmpi_rm_pbs )
@@ -112,7 +112,7 @@ multilib_src_configure() {
--with-libevent-libdir="${EPREFIX}/usr/$(get_libdir)"
$(use_enable cxx mpi-cxx)
- $(use_enable heterogeneous)
+ --disable-heterogeneous
$(use_enable ipv6)
$(use_enable libompitrace)
$(use_enable peruse)
diff --git a/sys-cluster/openmpi/openmpi-4.0.6-r1.ebuild b/sys-cluster/openmpi/openmpi-4.0.6-r1.ebuild
index 93df7d8495cc..e7d49f6d7e45 100644
--- a/sys-cluster/openmpi/openmpi-4.0.6-r1.ebuild
+++ b/sys-cluster/openmpi/openmpi-4.0.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -32,7 +32,7 @@ SRC_URI="https://www.open-mpi.org/software/ompi/v$(ver_cut 1-2)/downloads/${MY_P
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
-IUSE="cma cuda cxx fortran heterogeneous ipv6 java libompitrace peruse romio
+IUSE="cma cuda cxx fortran ipv6 java libompitrace peruse romio
${IUSE_OPENMPI_FABRICS} ${IUSE_OPENMPI_RM} ${IUSE_OPENMPI_OFED_FEATURES}"
REQUIRED_USE="openmpi_rm_slurm? ( !openmpi_rm_pbs )
@@ -113,7 +113,7 @@ multilib_src_configure() {
--with-libevent-libdir="${EPREFIX}/usr/$(get_libdir)"
$(use_enable cxx mpi-cxx)
- $(use_enable heterogeneous)
+ --disable-heterogeneous
$(use_enable ipv6)
$(use_enable libompitrace)
$(use_enable peruse)
diff --git a/sys-cluster/openmpi/openmpi-4.0.7.ebuild b/sys-cluster/openmpi/openmpi-4.0.7.ebuild
index 93df7d8495cc..e7d49f6d7e45 100644
--- a/sys-cluster/openmpi/openmpi-4.0.7.ebuild
+++ b/sys-cluster/openmpi/openmpi-4.0.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -32,7 +32,7 @@ SRC_URI="https://www.open-mpi.org/software/ompi/v$(ver_cut 1-2)/downloads/${MY_P
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
-IUSE="cma cuda cxx fortran heterogeneous ipv6 java libompitrace peruse romio
+IUSE="cma cuda cxx fortran ipv6 java libompitrace peruse romio
${IUSE_OPENMPI_FABRICS} ${IUSE_OPENMPI_RM} ${IUSE_OPENMPI_OFED_FEATURES}"
REQUIRED_USE="openmpi_rm_slurm? ( !openmpi_rm_pbs )
@@ -113,7 +113,7 @@ multilib_src_configure() {
--with-libevent-libdir="${EPREFIX}/usr/$(get_libdir)"
$(use_enable cxx mpi-cxx)
- $(use_enable heterogeneous)
+ --disable-heterogeneous
$(use_enable ipv6)
$(use_enable libompitrace)
$(use_enable peruse)
diff --git a/sys-cluster/openmpi/openmpi-4.1.1-r1.ebuild b/sys-cluster/openmpi/openmpi-4.1.1-r1.ebuild
index 6652c805f75a..aae744d9642b 100644
--- a/sys-cluster/openmpi/openmpi-4.1.1-r1.ebuild
+++ b/sys-cluster/openmpi/openmpi-4.1.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -32,7 +32,7 @@ SRC_URI="https://www.open-mpi.org/software/ompi/v$(ver_cut 1-2)/downloads/${MY_P
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
-IUSE="cma cuda cxx fortran heterogeneous ipv6 java libompitrace peruse romio
+IUSE="cma cuda cxx fortran ipv6 java libompitrace peruse romio
${IUSE_OPENMPI_FABRICS} ${IUSE_OPENMPI_RM} ${IUSE_OPENMPI_OFED_FEATURES}"
REQUIRED_USE="openmpi_rm_slurm? ( !openmpi_rm_pbs )
@@ -115,7 +115,7 @@ multilib_src_configure() {
--with-libevent-libdir="${EPREFIX}/usr/$(get_libdir)"
$(use_enable cxx mpi-cxx)
- $(use_enable heterogeneous)
+ --disable-heterogeneous
$(use_enable ipv6)
$(use_enable libompitrace)
$(use_enable peruse)
diff --git a/sys-cluster/openmpi/openmpi-4.1.2.ebuild b/sys-cluster/openmpi/openmpi-4.1.2.ebuild
index 036f1cbe8cb6..314ce22c8b3a 100644
--- a/sys-cluster/openmpi/openmpi-4.1.2.ebuild
+++ b/sys-cluster/openmpi/openmpi-4.1.2.ebuild
@@ -32,7 +32,7 @@ SRC_URI="https://www.open-mpi.org/software/ompi/v$(ver_cut 1-2)/downloads/${MY_P
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
-IUSE="cma cuda cxx fortran heterogeneous ipv6 java libompitrace peruse romio
+IUSE="cma cuda cxx fortran ipv6 java libompitrace peruse romio
${IUSE_OPENMPI_FABRICS} ${IUSE_OPENMPI_RM} ${IUSE_OPENMPI_OFED_FEATURES}"
REQUIRED_USE="openmpi_rm_slurm? ( !openmpi_rm_pbs )
@@ -71,10 +71,6 @@ MULTILIB_WRAPPED_HEADERS=(
/usr/include/openmpi/mpiext/mpiext_cuda_c.h
)
-PATCHES=(
- "${FILESDIR}"/${PN}-4.1.2-missing-includes.patch
-)
-
pkg_setup() {
fortran-2_pkg_setup
java-pkg-opt-2_pkg_setup
@@ -118,8 +114,12 @@ multilib_src_configure() {
--with-libevent="${EPREFIX}/usr"
--with-libevent-libdir="${EPREFIX}/usr/$(get_libdir)"
+ # Re-enable for 5.0!
+ # See https://github.com/open-mpi/ompi/issues/9697#issuecomment-1003746357
+ # and https://bugs.gentoo.org/828123#c14
+ --disable-heterogeneous
+
$(use_enable cxx mpi-cxx)
- $(use_enable heterogeneous)
$(use_enable ipv6)
$(use_enable libompitrace)
$(use_enable peruse)