summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Ten Harmsel <alec@alectenharmsel.com>2021-09-07 12:20:06 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-09-21 10:03:03 +0300
commit2f9364ff1df6d73f6012a94ebf90fe98ff7279cd (patch)
tree05be2a12d182d641dd14af2f971a578469d9d580 /sys-cluster
parentdev-util/ostree: x86 stable wrt bug #814089 (diff)
downloadgentoo-2f9364ff1df6d73f6012a94ebf90fe98ff7279cd.tar.gz
gentoo-2f9364ff1df6d73f6012a94ebf90fe98ff7279cd.tar.bz2
gentoo-2f9364ff1df6d73f6012a94ebf90fe98ff7279cd.zip
sys-cluster/spark-bin: Add version 3.1.2
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alec Ten Harmsel <alec@alectenharmsel.com> Closes: https://github.com/gentoo/gentoo/pull/22238 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/spark-bin/Manifest1
-rw-r--r--sys-cluster/spark-bin/spark-bin-3.1.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/sys-cluster/spark-bin/Manifest b/sys-cluster/spark-bin/Manifest
index 92ebba20e9ae..34d3a6ebefb2 100644
--- a/sys-cluster/spark-bin/Manifest
+++ b/sys-cluster/spark-bin/Manifest
@@ -3,3 +3,4 @@ DIST spark-bin-2.4.3-nohadoop-scala212.tgz 141465231 BLAKE2B e29b534076b981e3408
DIST spark-bin-2.4.7-nohadoop-scala211.tgz 168360525 BLAKE2B 9a8728a1c7450166d4d9635ff1be6a65d57df1832945672e92044e0fc88ef152e7e870d02ec590378ea97a47d4a68568da73e6a1e92f8eaaaa06f495ed9939ad SHA512 ff75e6db3c4ca5cece2a8a26ad7bd8a2c1c46b4f93e8f2922a31e6a8d98274bedc66bef3e469e862d249c5439355ccca83687a20d536a8400f2c058be553df57
DIST spark-bin-2.4.7-nohadoop-scala212.tgz 146775712 BLAKE2B f0381e6aebeae90990d5ad19d8db923efd01e9b215ddfe34e34a8272942e57fe7ec6a53208146006ba5c4e76f8e44d202e0715f63b559cc8749b523710b92a5f SHA512 708a702af5c754dba0137c88e3c7055d7759593f013798755468638b6fdc583a707aae4c2a4e14648f91c16b963f9bba9f8c44d28341c08c4512590a425f70a8
DIST spark-bin-3.0.1-nohadoop.tgz 156390722 BLAKE2B 9ac4645759ca0ec6d1501dfa79d149b9cbf49dee1c4b9dcf38f62490d3ad91db01ad61d9d6b1ef4dd7bcb81a868cb58b9251575dded823c8415801d10571afee SHA512 07fc6df224f303ef53189e6082004400d51cd6c2244d1851d90eabbe58404a69ff980bffe147a5259a34190e1e1c974c72d02470d10a783d2d87f43a8da0850b
+DIST spark-bin-3.1.2-hadoop.tgz 228834641 BLAKE2B 7b0191a15414146a96394abc489940a5e572cea66749b6201f234878935c6591ff809f551dae7d6c7c996baefd551cd27c5c967e2f06184ffe2bf972f901f1ba SHA512 2385cb772f21b014ce2abd6b8f5e815721580d6e8bc42a26d70bbcdda8d303d886a6f12b36d40f6971b5547b70fae62b5a96146f0421cb93d4e51491308ef5d5
diff --git a/sys-cluster/spark-bin/spark-bin-3.1.2.ebuild b/sys-cluster/spark-bin/spark-bin-3.1.2.ebuild
new file mode 100644
index 000000000000..63d7f5bbac0c
--- /dev/null
+++ b/sys-cluster/spark-bin/spark-bin-3.1.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2
+
+DESCRIPTION="Lightning-fast unified analytics engine"
+HOMEPAGE="https://spark.apache.org"
+SRC_URI="mirror://apache/spark/spark-${PV}/spark-${PV}-bin-hadoop3.2.tgz -> ${P}-hadoop.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=virtual/jre-1.8"
+
+DEPEND="
+ >=virtual/jdk-1.8"
+
+S="${WORKDIR}/spark-${PV}-bin-hadoop3.2"
+
+DOCS=( LICENSE NOTICE README.md RELEASE )
+
+# Nothing to compile here.
+src_compile() { :; }
+
+src_install() {
+ dodir usr/lib/spark-${SLOT}
+ into usr/lib/spark-${SLOT}
+
+ local spark_scripts=(
+ bin/beeline
+ bin/find-spark-home
+ bin/load-spark-env.sh
+ bin/pyspark
+ bin/spark-class
+ bin/spark-shell
+ bin/spark-sql
+ bin/spark-submit
+ )
+
+ local s
+ for s in "${spark_scripts[@]}"; do
+ dobin "${s}"
+ done
+
+ insinto usr/lib/spark-${SLOT}
+
+ local spark_dirs=( conf jars python sbin yarn )
+
+ local d
+ for d in "${spark_dirs[@]}"; do
+ doins -r "${d}"
+ done
+
+ newenvd - "50${PN}${SLOT}" <<-_EOF_
+ PATH="/usr/lib/spark-${SLOT}/bin:/usr/lib/spark-${SLOT}/sbin"
+ SPARK_HOME="/usr/lib/spark-${SLOT}"
+ _EOF_
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Spark is now slotted. You have installed Spark ${SLOT}."
+ einfo
+}