summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-26 03:49:01 +0000
committerSam James <sam@gentoo.org>2021-12-26 03:49:19 +0000
commit324823e1503875868dc4b98090eaf50142a6f516 (patch)
tree9eddfbaa22ef7f166edcc9b57a4c8d1effac094c /sys-cluster
parentsys-apps/hwloc: drop 2.3.0 (diff)
downloadgentoo-324823e1503875868dc4b98090eaf50142a6f516.tar.gz
gentoo-324823e1503875868dc4b98090eaf50142a6f516.tar.bz2
gentoo-324823e1503875868dc4b98090eaf50142a6f516.zip
sys-cluster/legion: examples need MPI
Closes: https://bugs.gentoo.org/821424 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/legion/legion-21.09.0-r1.ebuild (renamed from sys-cluster/legion/legion-21.09.0.ebuild)11
-rw-r--r--sys-cluster/legion/legion-9999.ebuild11
2 files changed, 10 insertions, 12 deletions
diff --git a/sys-cluster/legion/legion-21.09.0.ebuild b/sys-cluster/legion/legion-21.09.0-r1.ebuild
index a271def3a1d2..55c79a8cda25 100644
--- a/sys-cluster/legion/legion-21.09.0.ebuild
+++ b/sys-cluster/legion/legion-21.09.0-r1.ebuild
@@ -19,14 +19,13 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="gasnet hwloc test"
+IUSE="examples gasnet hwloc test"
RESTRICT="!test? ( test )"
-DEPEND="
+# See bug #821424 for examples/mpi
+DEPEND="examples? ( virtual/mpi[cxx] )
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( <sys-apps/hwloc-2:= )
-"
-
+ hwloc? ( <sys-apps/hwloc-2:= )"
RDEPEND="${DEPEND}"
src_configure() {
@@ -34,7 +33,7 @@ src_configure() {
-DLegion_USE_HWLOC=$(usex hwloc)
-DLegion_USE_GASNet=$(usex gasnet)
-DLegion_ENABLE_TESTING=$(usex test)
- -DLegion_BUILD_EXAMPLES=ON
+ -DLegion_BUILD_EXAMPLES=$(usex examples)
-DLegion_BUILD_TESTS=ON
-DLegion_BUILD_TUTORIAL=ON
)
diff --git a/sys-cluster/legion/legion-9999.ebuild b/sys-cluster/legion/legion-9999.ebuild
index a271def3a1d2..55c79a8cda25 100644
--- a/sys-cluster/legion/legion-9999.ebuild
+++ b/sys-cluster/legion/legion-9999.ebuild
@@ -19,14 +19,13 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="gasnet hwloc test"
+IUSE="examples gasnet hwloc test"
RESTRICT="!test? ( test )"
-DEPEND="
+# See bug #821424 for examples/mpi
+DEPEND="examples? ( virtual/mpi[cxx] )
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( <sys-apps/hwloc-2:= )
-"
-
+ hwloc? ( <sys-apps/hwloc-2:= )"
RDEPEND="${DEPEND}"
src_configure() {
@@ -34,7 +33,7 @@ src_configure() {
-DLegion_USE_HWLOC=$(usex hwloc)
-DLegion_USE_GASNet=$(usex gasnet)
-DLegion_ENABLE_TESTING=$(usex test)
- -DLegion_BUILD_EXAMPLES=ON
+ -DLegion_BUILD_EXAMPLES=$(usex examples)
-DLegion_BUILD_TESTS=ON
-DLegion_BUILD_TUTORIAL=ON
)