summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSandino Araico Sanchez <sandino@sandino.net>2019-03-21 07:20:54 -0600
committerPatrick McLean <chutzpah@gentoo.org>2019-03-21 10:15:31 -0700
commit348cf0b6d4e51f256ae7720a1942111b0f019460 (patch)
tree6c0faf36ba7eeac70e268c52bfe60a438879cec5 /sys-cluster
parentsys-cluster/ceph: Fix python sed in src_install in 4.2.0-r1 (diff)
downloadgentoo-348cf0b6d4e51f256ae7720a1942111b0f019460.tar.gz
gentoo-348cf0b6d4e51f256ae7720a1942111b0f019460.tar.bz2
gentoo-348cf0b6d4e51f256ae7720a1942111b0f019460.zip
sys-cluster/ceph: libressl support
Signed-off-by: Sandino Araico Sanchez <sandino@sandino.net> Closes: https://github.com/gentoo/gentoo/pull/11443 Closes: https://bugs.gentoo.org/681158 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ceph-13.2.4.ebuild17
-rw-r--r--sys-cluster/ceph/ceph-13.2.5-r1.ebuild21
-rw-r--r--sys-cluster/ceph/ceph-14.2.0-r1.ebuild21
3 files changed, 43 insertions, 16 deletions
diff --git a/sys-cluster/ceph/ceph-13.2.4.ebuild b/sys-cluster/ceph/ceph-13.2.4.ebuild
index cca90b166f05..f0e6c5adacdf 100644
--- a/sys-cluster/ceph/ceph-13.2.4.ebuild
+++ b/sys-cluster/ceph/ceph-13.2.4.ebuild
@@ -26,7 +26,7 @@ SLOT="0"
CPU_FLAGS_X86=(sse{,2,3,4_1,4_2} ssse3)
-IUSE="babeltrace cephfs dpdk fuse jemalloc ldap lttng +mgr"
+IUSE="babeltrace cephfs dpdk fuse jemalloc ldap libressl lttng +mgr"
IUSE+=" +radosgw +ssl static-libs +system-boost systemd +tcmalloc test"
IUSE+=" xfs zfs"
IUSE+=" $(printf "cpu_flags_x86_%s\n" ${CPU_FLAGS_X86[@]})"
@@ -54,13 +54,22 @@ COMMON_DEPEND="
ldap? ( net-nds/openldap:=[static-libs?] )
lttng? ( dev-util/lttng-ust:= )
fuse? ( sys-fs/fuse:0=[static-libs?] )
- ssl? ( dev-libs/openssl:=[static-libs?] )
+ ssl? (
+ !libressl? ( dev-libs/openssl:=[static-libs?] )
+ libressl? ( dev-libs/libressl:=[static-libs?] )
+ )
xfs? ( sys-fs/xfsprogs:=[static-libs?] )
zfs? ( sys-fs/zfs:=[static-libs?] )
radosgw? (
dev-libs/expat:=[static-libs?]
- dev-libs/openssl:=[static-libs?]
- net-misc/curl:=[curl_ssl_openssl,static-libs?]
+ !libressl? (
+ dev-libs/openssl:=[static-libs?]
+ net-misc/curl:=[curl_ssl_openssl,static-libs?]
+ )
+ libressl? (
+ dev-libs/libressl:=[static-libs?]
+ net-misc/curl:=[curl_ssl_libressl,static-libs?]
+ )
)
system-boost? (
>=dev-libs/boost-1.67:=[threads,context,python,static-libs?,${PYTHON_USEDEP}]
diff --git a/sys-cluster/ceph/ceph-13.2.5-r1.ebuild b/sys-cluster/ceph/ceph-13.2.5-r1.ebuild
index f83f6158171a..7d088a08ac60 100644
--- a/sys-cluster/ceph/ceph-13.2.5-r1.ebuild
+++ b/sys-cluster/ceph/ceph-13.2.5-r1.ebuild
@@ -26,9 +26,9 @@ SLOT="0"
CPU_FLAGS_X86=(sse{,2,3,4_1,4_2} ssse3)
-IUSE="babeltrace cephfs dpdk fuse jemalloc ldap lttng +mgr numa"
-IUSE+=" +radosgw +ssl static-libs +system-boost systemd +tcmalloc test"
-IUSE+=" xfs zfs"
+IUSE="babeltrace cephfs dpdk fuse jemalloc ldap libressl lttng +mgr"
+IUSE+=" numa +radosgw +ssl static-libs +system-boost systemd +tcmalloc"
+IUSE+=" test xfs zfs"
IUSE+=" $(printf "cpu_flags_x86_%s\n" ${CPU_FLAGS_X86[@]})"
# unbundling code commented out pending bugs 584056 and 584058
@@ -55,13 +55,22 @@ COMMON_DEPEND="
lttng? ( dev-util/lttng-ust:= )
fuse? ( sys-fs/fuse:0=[static-libs?] )
numa? ( sys-process/numactl:=[static-libs?] )
- ssl? ( dev-libs/openssl:=[static-libs?] )
+ ssl? (
+ !libressl? ( dev-libs/openssl:=[static-libs?] )
+ libressl? ( dev-libs/libressl:=[static-libs?] )
+ )
xfs? ( sys-fs/xfsprogs:=[static-libs?] )
zfs? ( sys-fs/zfs:=[static-libs?] )
radosgw? (
dev-libs/expat:=[static-libs?]
- dev-libs/openssl:=[static-libs?]
- net-misc/curl:=[curl_ssl_openssl,static-libs?]
+ !libressl? (
+ dev-libs/openssl:=[static-libs?]
+ net-misc/curl:=[curl_ssl_openssl,static-libs?]
+ )
+ libressl? (
+ dev-libs/libressl:=[static-libs?]
+ net-misc/curl:=[curl_ssl_libressl,static-libs?]
+ )
)
system-boost? (
>=dev-libs/boost-1.67:=[threads,context,python,static-libs?,${PYTHON_USEDEP}]
diff --git a/sys-cluster/ceph/ceph-14.2.0-r1.ebuild b/sys-cluster/ceph/ceph-14.2.0-r1.ebuild
index 2e9f40a55bae..868ca8e9fd71 100644
--- a/sys-cluster/ceph/ceph-14.2.0-r1.ebuild
+++ b/sys-cluster/ceph/ceph-14.2.0-r1.ebuild
@@ -26,9 +26,9 @@ SLOT="0"
CPU_FLAGS_X86=(sse{,2,3,4_1,4_2} ssse3)
-IUSE="babeltrace cephfs dpdk fuse grafana jemalloc kerberos ldap lttng +mgr"
-IUSE+=" numa rabbitmq +radosgw +ssl static-libs +system-boost systemd"
-IUSE+=" +tcmalloc test xfs zfs"
+IUSE="babeltrace cephfs dpdk fuse grafana jemalloc kerberos ldap libressl"
+IUSE+=" lttng +mgr numa rabbitmq +radosgw +ssl static-libs +system-boost"
+IUSE+=" systemd +tcmalloc test xfs zfs"
IUSE+=" $(printf "cpu_flags_x86_%s\n" ${CPU_FLAGS_X86[@]})"
COMMON_DEPEND="
@@ -54,13 +54,22 @@ COMMON_DEPEND="
fuse? ( sys-fs/fuse:0=[static-libs?] )
kerberos? ( virtual/krb5 )
rabbitmq? ( net-libs/rabbitmq-c:=[static-libs?] )
- ssl? ( dev-libs/openssl:=[static-libs?] )
+ ssl? (
+ !libressl? ( dev-libs/openssl:=[static-libs?] )
+ libressl? ( dev-libs/libressl:=[static-libs?] )
+ )
xfs? ( sys-fs/xfsprogs:=[static-libs?] )
zfs? ( sys-fs/zfs:=[static-libs?] )
radosgw? (
dev-libs/expat:=[static-libs?]
- dev-libs/openssl:=[static-libs?]
- net-misc/curl:=[curl_ssl_openssl,static-libs?]
+ !libressl? (
+ dev-libs/openssl:=[static-libs?]
+ net-misc/curl:=[curl_ssl_openssl,static-libs?]
+ )
+ libressl? (
+ dev-libs/libressl:=[static-libs?]
+ net-misc/curl:=[curl_ssl_libressl,static-libs?]
+ )
)
system-boost? (
>=dev-libs/boost-1.67:=[threads,context,python,static-libs?,${PYTHON_USEDEP}]