summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraeme Lawes <graemelawes@gmail.com>2018-01-10 11:13:30 -0500
committerMichał Górny <mgorny@gentoo.org>2018-01-27 09:24:39 +0100
commit4b149da6529335a09ff31cc3bf961b15a71b1d3f (patch)
tree1043af74244f3ad704396863dfbba2e52b4a191c /sys-cluster
parentx11-wm/awesome: Fix dependency issue for Gentoo/FreeBSD. (diff)
downloadgentoo-4b149da6529335a09ff31cc3bf961b15a71b1d3f.tar.gz
gentoo-4b149da6529335a09ff31cc3bf961b15a71b1d3f.tar.bz2
gentoo-4b149da6529335a09ff31cc3bf961b15a71b1d3f.zip
sys-cluster/teleport: add v2.4.0
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/teleport/Manifest1
-rw-r--r--sys-cluster/teleport/teleport-2.4.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-cluster/teleport/Manifest b/sys-cluster/teleport/Manifest
index 93a901c83942..26060b3f2699 100644
--- a/sys-cluster/teleport/Manifest
+++ b/sys-cluster/teleport/Manifest
@@ -1,3 +1,4 @@
DIST teleport-2.2.0.tar.gz 7229371 BLAKE2B 8425326e026e5ca23c43b11947d575efccda98e18519dbcd8b9fb4baa2fecf15b3d66b225b22f40e9d78e0e6d39bbed3c2c569b3d15b5af9099f0f4979259cbd SHA512 bec288983371bd3807b7ce994b1533a5e869d903251f8a8ce6315768a1d3ae95d72f832037345c36c9cd4789fbc449c54b86359988b1e74d4f46f9e0db6b3239
DIST teleport-2.2.1.tar.gz 7235188 BLAKE2B 1f1272bdc96bac0eb424660a285232980063b1a82fec60d7ba80f227da34fa22052aae1eba3137ae73e62fc9c71a8037f067f16ac6b22014f3a82fdd88b444fb SHA512 011ffd8fdf42131455c32b8a8ed1ddee0181a8dcd3424dc9cf5ac96c53ce719d369e0bfac4392cc0dec14e78fed94732bbcb56c2db5987ee778ad29e4f7a749d
DIST teleport-2.2.4.tar.gz 7234252 BLAKE2B 22c49e3659559ff6f8e55d3b60cf44fce00e67642d16457917b038cbbf48cc32db8caafbf39b70cef2ab39f0d8c1b3cb09e6ea1ab329e8e46c1fdf09b4a3aff2 SHA512 859bc34c90c4d1a504b9fa2958e49803c7af8bee3c2692d70590095ef0356a00cf963c5fc30613f3a7852b602fc7fbbd81ca99fc24ce51787f6d8d2e05af4762
+DIST teleport-2.4.0.tar.gz 9967298 BLAKE2B 26cb5610701c4c7deba0ba36b02f43928f4582cd81449045f58281b06a570eb5df762d21e5fef8f7f461855af3ac766fbafd1d2238b6916f9aaaaf07e20b7353 SHA512 4ed3a38fea4ba5acd52aa44cbc36d2bb1cda1fcb304d7787754b1165eefa3d1c8da65e76bf5c33a3f524ecf43b50145f2e850c927b35f2ec754ed90ed507c54d
diff --git a/sys-cluster/teleport/teleport-2.4.0.ebuild b/sys-cluster/teleport/teleport-2.4.0.ebuild
new file mode 100644
index 000000000000..dc7173e18dc7
--- /dev/null
+++ b/sys-cluster/teleport/teleport-2.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils golang-build systemd user
+
+DESCRIPTION="Modern SSH server for teams managing distributed infrastructure"
+HOMEPAGE="https://gravitational.com/teleport"
+
+EGO_PN="github.com/gravitational/${PN}/..."
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 golang-vcs
+ EGIT_REPO_URI="https://github.com/gravitational/${PN}.git"
+else
+ inherit golang-vcs-snapshot
+ SRC_URI="https://github.com/gravitational/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+IUSE=""
+LICENSE="Apache-2.0"
+RESTRICT="test strip"
+SLOT="0"
+
+DEPEND="
+ app-arch/zip
+ >=dev-lang/go-1.8.3"
+RDEPEND=""
+
+src_compile() {
+ GOPATH="${S}" emake -j1 -C src/${EGO_PN%/*} full
+}
+
+src_install() {
+ keepdir /var/lib/${PN} /etc/${PN}
+ dobin src/${EGO_PN%/*}/build/{tsh,tctl,teleport}
+
+ insinto /etc/${PN}
+ doins "${FILESDIR}"/${PN}.yaml
+
+ newinitd "${FILESDIR}"/${PN}.init.d ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_install_serviced "${FILESDIR}"/${PN}.service.conf ${PN}.service
+}
+
+src_test() {
+ BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*} test
+}