summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2022-06-27 23:46:39 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-07-05 11:52:02 +0300
commit5507cf55522d6a7df28b5979606bea656340e3ee (patch)
treec3b1d2dac37479ace86f4c205d2fdae003935ec0 /sys-cluster
parentsys-cluster/charliecloud: Bump to 0.28. (diff)
downloadgentoo-5507cf55522d6a7df28b5979606bea656340e3ee.tar.gz
gentoo-5507cf55522d6a7df28b5979606bea656340e3ee.tar.bz2
gentoo-5507cf55522d6a7df28b5979606bea656340e3ee.zip
sys-cluster/charliecloud: drop 0.26-r1
Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Closes: https://github.com/gentoo/gentoo/pull/26099 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/charliecloud/Manifest1
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.26-r1.ebuild82
2 files changed, 0 insertions, 83 deletions
diff --git a/sys-cluster/charliecloud/Manifest b/sys-cluster/charliecloud/Manifest
index f1ec11e3aad4..c0fba9575b38 100644
--- a/sys-cluster/charliecloud/Manifest
+++ b/sys-cluster/charliecloud/Manifest
@@ -1,3 +1,2 @@
-DIST charliecloud-0.26.tar.gz 472324 BLAKE2B 2b4b8f44f05a497e9367e97e49de255170b610880ef5d7909f7837bc54962f2c2de929d8381b99dc3f4b6124583744993b59839f8f1481cdbd5dc32334d3da9f SHA512 a8638db42a5563723b62ba0e9b9861b41e76b9246b94887d57a8d4c421d9dd2e8c0965b62af166e47859b72a50a2e01ec6775ef13f79c52696a6b2fd95134174
DIST charliecloud-0.27.tar.gz 471754 BLAKE2B b683847a79dd55a4bb79458e94e03988acdff0a1e6a24e7f67d56758bdbc3754cc3609e97bfc778f5cb6ce35d6f4df773235314c2ed642ac796b28b824ecadf6 SHA512 cfa5b1ac923008b9a38fc0228562b31551ea941bf222c9b9e12d8dce4c83ca896893e3509773a5ebc02d6b374d08dc049797226cf1432099aae7174c2bc5ee2b
DIST charliecloud-0.28.tar.gz 504793 BLAKE2B 97b9249be59700506b7b7032da7111b0099b88bea6cb73e348238ef2aacfb55ee9d868f81036728b1e67a41911ca3e754d009ba74375847747f3303a7dc2304c SHA512 62a00f16c118e3dd8d9f011290666961216d24d07825590c9a3ec9dd527948be75c66df8d5ef50f4796567aa358ca4e466148ca78bad9d0715bb4caa26004eb6
diff --git a/sys-cluster/charliecloud/charliecloud-0.26-r1.ebuild b/sys-cluster/charliecloud/charliecloud-0.26-r1.ebuild
deleted file mode 100644
index 229be33862e8..000000000000
--- a/sys-cluster/charliecloud/charliecloud-0.26-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8,9,10} )
-
-inherit autotools optfeature python-single-r1
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
- S="${WORKDIR}/${P}"
-else
- SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~x86-linux"
-fi
-
-DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
-HOMEPAGE="https://hpc.github.io/charliecloud/"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-IUSE="ch-image doc"
-
-# Extensive test suite exists, but downloads container images
-# directly and via Docker and installs packages inside using apt/yum.
-# Additionally, clashes with portage namespacing and sandbox.
-RESTRICT="test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- elibc_musl? ( sys-libs/argp-standalone )
-"
-DEPEND="
- ch-image? (
- $(python_gen_cond_dep '
- dev-python/lark[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- ')
- )
- doc? (
- $(python_gen_cond_dep '
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- ')
- net-misc/rsync
- )"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local econf_args=()
- econf_args+=(
- $(use_enable doc html)
- $(use_enable ch-image)
- # Libdir is used as a libexec-style destination.
- --libdir="${EPREFIX}"/usr/lib
- # Attempts to call python-exec directly otherwise.
- --with-sphinx-python=${PYTHON}
- # This disables -Werror, see also: https://github.com/hpc/charliecloud/pull/808
- --enable-buggy-build
- # Do not use bundled version of dev-python/lark.
- --disable-bundled-lark
- # Use correct shebang.
- --with-python=${PYTHON}
- )
- econf "${econf_args[@]}"
-}
-
-pkg_postinst() {
- elog "Various builders are supported, as alternative to the internal ch-image."
- optfeature "Building with Buildah" app-containers/buildah
- optfeature "Building with Docker" app-containers/docker
- optfeature "Progress bars during long operations" sys-apps/pv
- optfeature "Pack and unpack squashfs images" sys-fs/squashfs-tools
- optfeature "Mount and umount squashfs images" sys-fs/squashfuse
-}