summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2023-10-31 17:57:00 +0100
committerNicolas Bock <nicolasbock@gentoo.org>2023-11-01 15:48:37 -0600
commit66820c88224721c6124f7320e5e869688dfc5c17 (patch)
tree4cc92375800980500d784a242ee7bca2cc776d1c /sys-cluster
parentsys-cluster/charliecloud: sync live ebuild with latest version (diff)
downloadgentoo-66820c88224721c6124f7320e5e869688dfc5c17.tar.gz
gentoo-66820c88224721c6124f7320e5e869688dfc5c17.tar.bz2
gentoo-66820c88224721c6124f7320e5e869688dfc5c17.zip
sys-cluster/charliecloud: drop 0.33
Closes: https://github.com/gentoo/gentoo/pull/33610 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/charliecloud/Manifest1
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.33.ebuild89
2 files changed, 0 insertions, 90 deletions
diff --git a/sys-cluster/charliecloud/Manifest b/sys-cluster/charliecloud/Manifest
index f99ea51964a1..5e9ba687e9fb 100644
--- a/sys-cluster/charliecloud/Manifest
+++ b/sys-cluster/charliecloud/Manifest
@@ -1,3 +1,2 @@
-DIST charliecloud-0.33.tar.gz 559786 BLAKE2B 46e8a488af5a27e6b52ae41118cea663cd6c01f8a24566576dbdc7bac99bd94ac50c0559da07a204c2e68ed46edb8c5a5e0bd26986b5bc960901457af632e134 SHA512 d6854873bdfca5512c54ba28ff70721442241a00cbec6d67c9693e946c6925d030773382c8ba9fc3ebcdfd52da56580e6c4e3ad7080d51d9844ad6f216f15e70
DIST charliecloud-0.34.tar.gz 565976 BLAKE2B 0c86877bd3f17bf91d287f57b5e0844f7cb1777a499ea2bf67fb2cd5762f453239fe20afa6e4ba71acc98609c718028dd1e813a36aee881aa5c2cae79a65effd SHA512 5ede938a8015391758e0eef0b3661c12025cbac3e5153e2e5219fb4d50f8f78ac12076e4c3b658379a1521825372a0ed792a63210371cdbdad1e6631112e371d
DIST charliecloud-0.35.tar.gz 585756 BLAKE2B ade539aa3f94055f84e1b6de73d0bea7739ab764c31399f25adbff82faa62c3ee7e8745aa74bb6e997d6723d002780339f48be8d7218462d3eb95ad119a2b8a8 SHA512 40f5e5891f0df8379b637c26c3d86b66a61b48ee1e7985260b47aa4abeffc77c3690af59ae38072b53f6dd348da4574249187ba922fc7c03fb74a513524dc08a
diff --git a/sys-cluster/charliecloud/charliecloud-0.33.ebuild b/sys-cluster/charliecloud/charliecloud-0.33.ebuild
deleted file mode 100644
index 7e84cbf18286..000000000000
--- a/sys-cluster/charliecloud/charliecloud-0.33.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit autotools optfeature python-single-r1
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
- S="${WORKDIR}/${P}"
-else
- SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~x86-linux"
-fi
-
-DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
-HOMEPAGE="https://hpc.github.io/charliecloud/"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-IUSE="ch-image doc"
-
-# Extensive test suite exists, but downloads container images
-# directly and via Docker and installs packages inside using apt/yum.
-# Additionally, clashes with portage namespacing and sandbox.
-RESTRICT="test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- elibc_musl? ( sys-libs/argp-standalone )
-"
-DEPEND="
- ch-image? (
- $(python_gen_cond_dep '
- dev-python/lark[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- ')
- )
- doc? (
- $(python_gen_cond_dep '
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
- ')
- net-misc/rsync
- )"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local econf_args=()
- econf_args+=(
- $(use_enable doc html)
- $(use_enable ch-image)
- # Libdir is used as a libexec-style destination.
- --libdir="${EPREFIX}"/usr/lib
- # Attempts to call python-exec directly otherwise.
- --with-sphinx-python="${EPYTHON}"
- # This disables -Werror, see also: https://github.com/hpc/charliecloud/pull/808
- --enable-buggy-build
- # Do not use bundled version of dev-python/lark.
- --disable-bundled-lark
- # Use correct shebang.
- --with-python="${PYTHON}"
- )
- econf "${econf_args[@]}"
-}
-
-src_install() {
- docompress -x "${EPREFIX}"/usr/share/doc/"${PF}"/examples
- default
-}
-
-pkg_postinst() {
- elog "Various builders are supported, as alternative to the internal ch-image."
- optfeature "Building with Buildah" app-containers/buildah
- optfeature "Building with Docker" app-containers/docker
- optfeature "Building with Podman" app-containers/podman
- optfeature "Progress bars during long operations" sys-apps/pv
- optfeature "Pack and unpack squashfs images" sys-fs/squashfs-tools
- optfeature "Mount and umount squashfs images" sys-fs/squashfuse
- optfeature "Build versioning with ch-image" dev-vcs/git
-}