summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-03 23:25:53 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-15 01:21:34 +0200
commit79860bfbe7b9e5b34e8eb5608e68de5519be10ec (patch)
tree498abdd16c91e0a5be632afc573bb37f3af5c922 /sys-cluster
parentnet-wireless/soapysdr: Drop superfluous calls to python_is_python3 (diff)
downloadgentoo-79860bfbe7b9e5b34e8eb5608e68de5519be10ec.tar.gz
gentoo-79860bfbe7b9e5b34e8eb5608e68de5519be10ec.tar.bz2
gentoo-79860bfbe7b9e5b34e8eb5608e68de5519be10ec.zip
sys-cluster/ceph: Drop superfluous calls to python_is_python3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ceph-14.2.9-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-cluster/ceph/ceph-14.2.9-r1.ebuild b/sys-cluster/ceph/ceph-14.2.9-r1.ebuild
index 8fbefa08d5f3..8f7886000139 100644
--- a/sys-cluster/ceph/ceph-14.2.9-r1.ebuild
+++ b/sys-cluster/ceph/ceph-14.2.9-r1.ebuild
@@ -215,7 +215,7 @@ ceph_src_configure() {
local mycmakeargs=(
-DWITH_BABELTRACE=$(usex babeltrace)
-DWITH_CEPHFS=$(usex cephfs)
- -DWITH_CEPHFS_SHELL=$(if python_is_python3; then usex cephfs; else echo OFF; fi)
+ -DWITH_CEPHFS_SHELL=$(usex cephfs)
-DWITH_DPDK=$(usex dpdk)
-DWITH_DPDK=$(usex spdk)
-DWITH_FUSE=$(usex fuse)
@@ -226,9 +226,9 @@ ceph_src_configure() {
-DWITH_MGR_DASHBOARD_FRONTEND=NO
-DWITH_NUMA=$(usex numa)
-DWITH_OPENLDAP=$(usex ldap)
- -DMGR_PYTHON_VERSION=$(if python_is_python3; then echo 3; else echo 2; fi)
- -DWITH_PYTHON3=$(if python_is_python3; then echo "ON"; else echo "OFF"; fi)
- -DWITH_PYTHON2=$(if python_is_python3; then echo "OFF"; else echo "ON"; fi)
+ -DMGR_PYTHON_VERSION=3
+ -DWITH_PYTHON3=ON
+ -DWITH_PYTHON2=OFF
-DWITH_RADOSGW=$(usex radosgw)
-DWITH_RADOSGW_AMQP_ENDPOINT=$(usex rabbitmq)
-DWITH_SSL=$(usex ssl)